×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

7961G-GE CME 4.0 compatibility issues

Unanswered Question
Apr 1st, 2006
User Badges:

I have 7961G-GE registered to CME4.0, with 7.0.3.0S Firmware loaded on the phone.

The main problem right now is, when I dial an outside number, I hear static noise while rining-and only during ringing.

Also, the phone is looking for g3-tones.xml and mk-sccp.jar files from router. I guessed I should map g3-tones to 7960-tones.xml in system:/its... but what about mk-sccp.jar?


Thanks!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
thisisshanky Sat, 04/01/2006 - 10:31
User Badges:
  • Purple, 4500 points or more

Mahmoud,


Is this happening to all the 7961s?

mahmuod Sat, 04/01/2006 - 11:56
User Badges:

yeah... i have two connected, one with 7914 and one without... both have the same static issue.

by the way i'm using 12.4.4.XC1, and PSTN is ISDN PRI to a national switch (Verizon).

It only happens when calling ISDN, ext-to-ext is working just fine...

mwenger Mon, 04/03/2006 - 04:01
User Badges:

I'm having the same problem with the 7961G (and also the 7941G) with 7.0.3.0S firmware looking for g3-tones.xml and mk-sccp.jar. I'm also running CME 4.0 on IOS 14.4(4)XC1. Where do I get these files from?


I have tried copying system:its/switzerland/7960-tones.xml to flash:g3-tones.xml and enabling it with the "tftp-server flash:g3-tones.xml" command, but it still doesn't find it.


I have tried upgrading to phone firmware 8.0 but the problem remains. The consequence of this is that I can't use localization (everything remains US English, dialtones and texts on the screen).


Sorry, I can't help you with the static noise issue.


Thanks

-Manuel

mahmuod Mon, 04/03/2006 - 07:05
User Badges:

Upgrading to version 8 was my next step, but if it didnt fix your issue, I will probably skip it. So you dont have any static noise issues at all?

If you are working on localization, i think you need to use "locale" commands. Have you used them? it doesnt fix?

If you want to use 7960-tones.xml instead of g3-tones, just create an alias with tftp-server command. That'll do it, my phone now loads g3-tones, but still no idea for mk-sccp.jar... i guess mk-sccp.jar is not related to tones, so it's not my biggest concern right now...

mahmuod Mon, 04/03/2006 - 08:48
User Badges:

Ok, I found the solution to static noise.

tftp-server system:/its/united_states/7960-tones.xml alias /g3-tones.xml

That fixed the static noise issue!

mwenger Tue, 04/04/2006 - 00:50
User Badges:

No, I don't have the static noise issue.


I have used the "locale" commands like this:


telephony-service

user-locale IT

network-locale CH


I need the display language to be in Italian, and I need to use Swiss ringing tones. The tftp-server alias command actually works, thank you!


But when the phone boots, when trying to apply the locales, the error message "Error updating locale" briefly appears, and the menu buttons are still in English.


If I look at the phone's console logfile, that's what I get:


10:43:00.345680 TFTP: Requesting Italian_Italy/mk-sccp.jar from 192.168.1.1

10:43:00.351260 TFTP: Error --> No such file

10:43:00.388096 Unable to process LocaleProperty 'device.settings.config.localization.userlocale'


I think mk-sccp.jar is needed for menu button text localisation (ie. user locale).


Anyone? I have no idea how to fix this, I have tried almost everything. And that mk-sccp.jar file seems to be unknown to Google and to the entire Cisco.com website.

mahmuod Tue, 04/04/2006 - 06:08
User Badges:

You are absolutely right about mk-sccp.jar, it's the reason u see that locale error.

I've checked all you've checked for that file too, the only other suggestion which I was going to check (but didnt) is, I guess mk-sccp.jar is part of call manager or call manager localization package. If you check Cisco's voice download section, there're some packages there. I couldnt install cause it asks for an installed version of CM, but still, if you dont have CM, you can run it till it extracts all its files, check the temporary directory that it has decompressed its files, and see if you can find that file there... The first file i was gonna try was li-ffr.4-1-3-sr1.exe (Cisco Unified Call Manager Locale Installer)...

mwenger Tue, 04/04/2006 - 08:08
User Badges:

You are right! The mk-sscp.jar is in that file. Precisely in the Data/TFTPFiles/User directory where the installer extracts its temporary files. Thank you!


After copying it to the flash, remember issuing this command:


tftp-server flash:mk-sccp.jar alias Italian_Italy/mk-sccp.jar

(don't put a "/" in front of the directory name, for some reason the phone looks for the file in a relative, and not in an absolute path).


mbastianello, did you issue the tftp alias command? Without this, the menus are half English, half Italian.


-Manuel

mbastianello Tue, 04/04/2006 - 09:46
User Badges:

Yes, sure. I have issude that command, but button still in english and menus in italian. Any idea ? Thanks in advance.

mwenger Wed, 04/05/2006 - 00:10
User Badges:

This looks like a bug somewhere. My phones now are in Italian, except the softbuttons (Redial, NewCall, CFwdAll,...). These are still in English. I have checked inside the mk-sccp.jar file, and they are translated correctly in the ca-s-dictionary.utf8.xml file. But the phone doesn't apply the translations. All other translations are applied correctly.


I have opened a TAC case for this.

mbastianello Tue, 04/04/2006 - 07:50
User Badges:

Yes! thanks you for the hint!


I have the mk-sccp.jar file, you fill find here attached, but this solve only half of the problem.

Now the phone attachet to my CME 4.0 are partialy italian and partialy english....






Attachment: 
mahmuod Tue, 04/04/2006 - 15:13
User Badges:

I think this should be posted as a bug or an upgrade request to Cisco, or they should mention it somewhere for CME too.

If anybody here can send me mk-sccp.jar for United States too, that will help me get rid of error message here too!

For mixed English/Italian menus, check debug logs and see if everything has loaded correctly... Maybe your phone is still missing some files.

mbastianello Wed, 04/05/2006 - 01:40
User Badges:

Here you are, the file attacched is from my CM 4.1(3).


Cisco reply to my TAC case saying that 794G1/7961G on CME 4.0 doesn't support localization until late this year...so we have to do some "home made" solution. Now I try to sniff traffic from 7941G and CM 4.1(3) to see what the phone ask and download from the full CallManager.



mwenger Thu, 04/06/2006 - 04:33
User Badges:

Oh, so we both opened a TAC case... I also got the same reply from Cisco, about localization not being supported. If you find out how we can do this home-made while waiting for official support, I'd appreciate it. I don't have a "big" CM to test with unfortunately.

mbastianello Fri, 04/07/2006 - 09:33
User Badges:

Bad news. Etherreal reveals that button text is inside a SKINNY message generated by IOS... so whe connot do anything to accomodate this. We have to wait the official support. Regards

adamhinett Wed, 06/14/2006 - 21:03
User Badges:

Mahmuod,


In reading your post I see you are using CME 4.0 with a 7961G-GE and a 7914 attached.


Did you have any problems getting the 7914 to load?


I'm using CME4.0 with 12.4(4)XC and have a 7961G-GE and a 7914 attached. The GUI and a 'sh ephone' shows me that the modules are present and I have configured monitor lines to it.


However my 7914 is showing only red lights?


Phones have the correct load 7.0.3.0S and Im using

S00104000100.sbn for the 7914


Can you clarify if you are using the same loads ?


Many thanks

Adam




sh ephone 7914



ephone-91 Mac:0017.5A6D.D7DF TCP socket:[41] activeLine:0 REGISTERED in SCCP ver 6 and Server in ver 5

mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0 caps:7

IP:192.168.49.143 49450 7961GE sub=4 keepalive 51 max_line 34

Phone reports 6 Available Lines

button 1: dn 91 number 1000 CH1 IDLE CH2 IDLE

button 2: dn 92 number 1000 CH1 IDLE CH2 IDLE

button 3: dn 93 number 1000 CH1 IDLE CH2 IDLE

button 4: dn 94 number 1000 CH1 IDLE CH2 IDLE

button 5: dn 95 number 1000 CH1 IDLE CH2 IDLE

button 6: dn 96 number 1000 CH1 IDLE CH2 IDLE

button 7: dn 6 number 1007 CH1 IDLE CH2 IDLE mwi monitor-ring shared

button 8: dn 10 number 1050 CH1 IDLE CH2 IDLE monitor-ring shared

button 9: dn 15 number 1033 CH1 IDLE CH2 IDLE monitor-ring shared

button 10: dn 23 number 1030 CH1 IDLE CH2 IDLE mwi monitor-ring shared

button 11: dn 30 number 1008 CH1 IDLE CH2 IDLE monitor-ring shared

button 12: dn 54 number 1005 CH1 IDLE CH2 IDLE monitor-ring shared

button 13: dn 40 number 1056 CH1 IDLE CH2 IDLE mwi monitor-ring shared

button 14: dn 41 number 1068 CH1 CONNECTED CH2 IDLE monitor-ring shared

button 15: dn 48 number 1070 CH1 IDLE CH2 IDLE monitor-ring shared

button 16: dn 49 number 1060 CH1 IDLE CH2 IDLE mwi monitor-ring shared

Actions

This Discussion