Looking for Cisco 827 Config for a Layer 3 Routed VC-MUX connection ?

Unanswered Question
Apr 2nd, 2006
User Badges:

Got a client with a Layer 3 Routed connection using a Cisco 827 and encapsulation aal5snap. It was working good til a week a go. They no longer get any data flow when using LLC/SNAP (aal5snap) on the 827 but the service has been proven to work fine using VC-MUX on another ADSL modem/router.


How do I change the encapsulation on a cisco 827 so VC-MUX encapsulation is used? I've tried configuring the pvc 8/35 to use "encapsulation aal5mux ip" but that hasn't restored data flow. I presume it's more than just changing from "aal5snap" to "aal5mux ip" ???


Pls find sample config below.


interface Ethernet0

ip address 203.x.x.x 255.255.255.224

no ip directed-broadcast

no shutdown

!

interface ATM0

no ip address

no ip directed-broadcast

no atm ilmi-keepalive

bundle-enable

hold-queue 224 in

no shutdown

!

interface ATM0.1 point-to-point

ip address 202.x.x.x 255.255.255.252

no ip directed-broadcast

no shutdown

pvc 8/35

encapsulation aal5snap

!

!

ip classless

ip route 0.0.0.0 0.0.0.0 ATM0.1


Thanks in advance.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3.8 (4 ratings)
Loading.
pkhatri Mon, 04/03/2006 - 00:26
User Badges:
  • Purple, 4500 points or more

Hi,


Is this what you tried:


interface ATM0.1 point-to-point

ip address 202.x.x.x 255.255.255.252

no ip directed-broadcast

pvc 8/35

protocol ip

encapsulation aal5mux ip


Pls do remember to rate posts.


Paresh

andysaykao Tue, 04/04/2006 - 15:35
User Badges:

Hi Paresh,


I tried it without the "protocol ip" part because I don't know what the IP is on the Telco's side. I thought it was as simple as changing the encapsulation from aal5snap to aal5mux. I know with aal5snap, we didn't need to specify any "protocol ip" line.


Basically, the client has a /30 subnet from the ISP/Telco and through that /30, the Telco route the client's /27 through it. I've got no idea that protocol IP the client should be using ???


The first usable IP of the /30 is the gateway on the Telco's side and the second usable IP resides on the client's side.


I've checked the cisco web site and they keep making reference to some protocol ip when using aal5mux. I have no idea what they are talking about.


Ayy more thoughts?


Thanks.

pkhatri Tue, 04/04/2006 - 15:38
User Badges:
  • Purple, 4500 points or more

Just use the second usable IP of the /30 with the protocol ip command...


Also, for this to work, VC-MUX encap has to be used at the other end so make sure that the ISP has also configured their end correctly.


Pls do remember to rate posts.


Paresh

andysaykao Wed, 04/05/2006 - 15:14
User Badges:

Hi Paresh,


The second usable IP of the /30 is already being used on the ATM0.1 point-to-point interface. Will this create an IP conflict if I also place it with the protocol ip command?


I can't test it out anytime soon but when I get a chance, I'll try adding the second usable IP of the /30 to the protocol ip command and see how it goes.


Thanks for all your help.

pkhatri Wed, 04/05/2006 - 15:39
User Badges:
  • Purple, 4500 points or more

No, that's not what I meant. I meant use the IP that is not the one being used locally, which would make it the IP at the other end.


Cheers,

Paresh

andysaykao Wed, 04/05/2006 - 20:02
User Badges:

OK, the IP not being used locally is the client's default gateway which resides on the Telco's side. I presume this is the IP you want to add to the protocol ip command?

pkhatri Wed, 04/05/2006 - 20:04
User Badges:
  • Purple, 4500 points or more

That is it, mate.


Paresh/

Actions

This Discussion