Connecting 2950 switch to a 3550 switch

Unanswered Question
Apr 3rd, 2006
User Badges:

I’m trying to connect a 2950 switch to a 3550 switch. I have tried straight through and crossover cat 5e patch cables and the results are the same. There is no indication on the 2950 switch port and there is a slow blinking amber light on the 3550 switch port. The 3550 switch port is on VLAN 1 and the 2950 switch port VLAN 2. Placing the ports on same VLAN does not change the status. When forcing speed to 100 Mbps and duplex to full, there is no indication on the 2950 switch port and the 3550 switch port turned green.


2950 Configuration …


interface FastEthernet0/23

switchport access vlan 1

switchport mode access


3550 Configuration …


interface FastEthernet0/23

switchport mode dynamic desirable


Any help would be appreciated.


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
glen.grant Mon, 04/03/2006 - 10:36
User Badges:
  • Purple, 4500 points or more

on the 3550 try typing in "switchport" on the interface and then switchport mode access . Switch to switch should be a xover cable .

dgahm Mon, 04/03/2006 - 10:37
User Badges:
  • Blue, 1500 points or more

Flashing amber indicates blocked by Spanning Tree Protocol. That would suggest there is another active link between the 2 switches.


If you disconnect the other link the new one should transition to forwarding. There can only be one active link between layer 2 switches.


Please rate helpful posts.

Mohamed Sobair Mon, 04/03/2006 - 12:27
User Badges:
  • Gold, 750 points or more

Hi,


flashing amber means there is CRC , errors on ur switch port, Dynamic desirable Makes the interface actively attempt to convert the link to a trunk link. The interface becomes a trunk interface if the neighboring interface is set to trunk, desirable, or auto mode.


I would suggest if u can set ur f0/23 on 2950 switch to dynamic desirable mode & connecting it to f0/23 3550 switch port & let us know the results.

dgahm Mon, 04/03/2006 - 14:35
User Badges:
  • Blue, 1500 points or more

http://www.cisco.com/en/US/customer/products/hw/switches/ps646/products_installation_guide_chapter09186a008049d1f0.html#wp1021241


Off No link, or port was shut down administratively.


Solid green Link present.


Flashing green Activity. Port is transmitting or receiving data.


Alternating green-amber Link fault. Error frames can affect connectivity, and errors such as excessive collisions, CRC errors, and alignment and jabber errors are monitored for a link-fault indication.


Solid amber Port is blocked by Spanning Tree Protocol (STP) and is not forwarding data.


Note After a port is reconfigured, the port LED can remain amber for up to 30 seconds as STP checks the switch for possible loops.


Flashing amber Port is blocked by STP and is transmitting or receiving packets.

Mohamed Sobair Mon, 04/03/2006 - 23:51
User Badges:
  • Gold, 750 points or more

Hi dgahm,


Yes u are right, the ports led status which written a bove is right, I am sorry it was my fault since I thought it was alternating green - amber. hope we can help out the guy's problem.

Desmond Holoman Mon, 04/03/2006 - 16:32
User Badges:

I did try this and the results were the 3550 port turned green and the 2950 port remained off. "Down Down" is the state.

Mohamed Sobair Mon, 04/03/2006 - 23:17
User Badges:
  • Gold, 750 points or more

Hi Mate,


could u pls enter the show int f0/23 command on the 2950 switch?


pls let us know the output of the show command.


thanks

Desmond Holoman Tue, 04/04/2006 - 06:06
User Badges:

I typed the wrong port number for the 2950 switch before. Here is the information.


SW2950#sh int fa0/11

FastEthernet0/11 is down, line protocol is down (notconnect)

Hardware is Fast Ethernet, address is 0012.01e2.308b (bia 0012.01e2.308b)

MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 100Mb/s, media type is 100BaseTX

input flow-control is unsupported output flow-control is unsupported

ARP type: ARPA, ARP Timeout 04:00:00

Last input never, output 03:21:20, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

1 packets input, 64 bytes, 0 no buffer

Received 0 broadcasts (0 multicast)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog, 0 multicast, 0 pause input

0 input packets with dribble condition detected

1 packets output, 64 bytes, 0 underruns

0 output errors, 0 collisions, 5 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier, 0 PAUSE output

0 output buffer failures, 0 output buffers swapped out


trackme Tue, 04/04/2006 - 00:00
User Badges:

hello,

some things need to be checked here to isolate where exactly the problem is .


1. ensure within the 3550, the switch works ,meaning you can connect systems and works, same applies for the 2950 as well.


2. when you have ensured that, make sure the connection between these two switches are in the same vlan (some time this is required to have both switch ports should be in the same vlan)


3. check the cable if its working properly, u can try that some where else to ensure that the cable is ok.


4.if not working, swap the ports in both switches and try.some times u need to do to eliminate port failures.


5. check the logs or issue a sh cdp n command to see whether that switch is active or not.


i have cascaded several switches and hence it should not be a big deal :)


if still not working, try with another switch say any other unmanaged switch to see whether they can connected to together to eliminate hardware issues as well.

Desmond Holoman Tue, 04/04/2006 - 06:29
User Badges:

1: When connecting other devices to these switches, the ports function normally.


2: Having the two switches on the same VLAN did not change the status.


3: Cables test good. I’ve had them replace cables with new out of the bag cables. No change :-(


4: Have moves ports. It seems that no matter the port, the results are the same.


5: The switches do not show up in each others CDP table, arp table, or mac-address table.


The ws-C3550-24smi has IOS ver 12.1(19)EA1c


The ws-C2950-12 has IOS ver 12.1(22)EA1


Are there any know bugs with these switches interfacing with each other?


MUHAMMAD SHAHEEN Tue, 04/04/2006 - 05:17
User Badges:
  • Silver, 250 points or more

Hi,


Make sure you use x-over cable to connect them together and also change configurations on your switch ports to as:


2950 Switch port configuration--------------


interface FastEthernet0/23

switchport access vlan 1

switchport mode trunk




3550 Switch port Configuration ----------


interface FastEthernet0/23

switchport access vlan 1

switchport trunk encapsulation dot1q

switchport mode trunk



Regards

Shaheen


Please rate the post if it helps !

Actions

This Discussion