×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

CS-Mars - getting e-mail notifications

Unanswered Question

Having trouble getting Mars to e-mail

alarms to designated staff. Here is what we did:


1. Configured Mars with mail gateway (ip address):25


2. Configured Mars admin with e-mail address (pnadmin@"domain.com"


2. Configured Mars User (alarm recipient) with e-mail address.


3. Created account (pnadmin@"domain.com") on mail server.


4. Configured rule that triggers ... the incident appears when it is triggered.


5. Configured action within the rule to e-mail a user


... no e-mail is ever received by alarm recipient.


I have also attempted to e-mail results of a case ... it seems to process

the case e-mail, but nothing is ever received.


Any help???


TIA

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3.8 (3 ratings)
Loading.

Thanks to you that replied. The problem has been identified and a work-around (not a good one) has been developed. I'll recap in case someone else runs into this:


Problem Ident: Mars appends "notifier." to the sending e-mail address; e.g. [email protected].


Our mail server is sendmail that uses POP-before-SMTP to prevent spammers from using the server as a relay. The problem is that sendmail limits user name to a max of 12 characters, and a user "notifier.marsname" cannot be created.


Work-around:

1. Config sendmail to permit relay from Mars IP.

2. change (legit) "domain.com" to "phoney.com" ... this tricks the mail server into thinking it is legit incoming mail to "domain.com" users.


Cisco development team says: this is a low priority item and will be addressed in some future release as a "feature" ... not NOW as a bug fix :-)

rsumidacisco Fri, 11/03/2006 - 16:14
User Badges:

Has this issue been fixed yet? I can't seem to find a way to change the sender address in the notifications sent from Mars. It looks like MARS is using the format of "[email protected]" which keeps getting bounced by our email servers because it is not a valid email address. Is there any other workaround to change which sender address is used in the notification emails? I don't want to change the hostname and I do not want to create a dummy email account just for MARS notifications.


Thanks,

Ryan

mhellman Mon, 11/06/2006 - 13:03
User Badges:
  • Blue, 1500 points or more

You'll want to specifically configure your SMTP server to allow all mail from your CSMARS. I'll explain why later.


Specifically, why are your mail servers bouncing the email? [email protected] is a syntactically legit email address.


I don't believe you can change the from address used by CSMARS. A different address is used depending on the process too, scheduled reports appear to use [email protected]. A failed hard drive will result in an email sent from [email protected] (oddly enough, with a from address of [email protected]). I'll bet there are others too! It appears Cisco has some work to do in this area.


Until they provide a consistent "mail from", I would encourage you to configure your SMTP server to allow all mail from the csmars.

rsumidacisco Mon, 11/06/2006 - 14:47
User Badges:

Wow, Cisco really needs to put some work into improving their MARS email notifications.


Our mail servers are bouncing the email because the account "notifier.hostname" does not exist for ourdomain.com. Our mail server does a sender account lookup and if the account does not exist the message will get bounced. We can change our mail server to allow mail based on the MARS IP but our email admin prefers no to.


I've found a work around but I'd rather not post here because it could invite spammers to our campus. It?s more of a kluge and would really only work in certain email structures.


Now I have a somewhat related follow up question. Is there a way to edit the "more details" url in the email notification? The notifications I receive list 5 different urls. The first url just uses the hostname/path, the following two use the appended DNS search path domains, the fourth uses the interface ip and the fifth uses the loopback address. How do I get it to post a link only using the FQDN?


Much appreciated,


Ryan


rsumidacisco Mon, 11/06/2006 - 15:34
User Badges:

**correction**

the fifth url uses the second interface IP, not the loopback. I wrote the post after lunch and had a little case of food comatose =p

mhellman Mon, 11/06/2006 - 19:41
User Badges:
  • Blue, 1500 points or more

I actually have the mail sent to a linux box, where it is parsed and we apply custom formatting (getting rid of all the crap basically). I have seen what you're talking about but since you can't customize the email notifications, I think you're out of luck.

Actions

This Discussion