×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

CSA agents could not registered with CSAMC

Unanswered Question
Apr 5th, 2006
User Badges:

Hi all,

I have just rebuild my CSAMC and install 4.5.1.565 (VMS2.2), since installation, my csa agent Pcs could not registered with csamc, all agents in Test Mode group. I have valid licenses for csamc, agent, vms & servers.


Any thought Please?


ade

mgn


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3.8 (4 ratings)
Loading.
fkhan6_wb Wed, 04/05/2006 - 14:42
User Badges:

From my understanding, you have rebuilt the CSAMC but the agents were reporting to the old one? Or you have created new Agentkit and distributed to the machines?


-I am assuming the CSAMC resides in the same server. Every thing is the same (active directory name)


-You are not updating software to 4.5.1.565 from older versions.

If so you need to Scheduled Software Updates, but even so, I guess the agents need to be reporting to get the update!


-Make sure you have in

Registration Control

Enter the IP address ranges allowed to register with the Management Console:

I doubt that this is the case


ade-olusanya Thu, 04/06/2006 - 01:19
User Badges:

I Have only 1 CSAMC server, I have deployed the agent kit in TestMode, assign policies to the Test-group and I have even upgrade to 4.5.1.639 none of the agents could still registered with CSAMC.


Thanks for your input will try your suggestion.


ade

tsteger1 Thu, 04/06/2006 - 08:32
User Badges:
  • Red, 2250 points or more

My understanding is if they were reporting to the old MC, they won't report to the new one because the certificate is different.


Tom S

aduerr Mon, 04/10/2006 - 03:54
User Badges:

Yep, excactly. Tom is right. You`ll have to manually refresh certificates on installed agent hosts or uninstall old agents and roll out new kits(would prefer this one). agent kits contain csamc server ssl certificate which in this case is old(unknown) one. remember that agents communicate via ssl handshake with management center.


Otherwise check if domain name lookup (forward and reverse) could be correctly answered. But seems to be that Tom was already on right track.


Regards,

Arne

fkhan6_wb Fri, 02/02/2007 - 13:24
User Badges:

Ade,


You just have to make sure that you back up the CSAMC server and store the files some where. When you build the new MC, move back the back-up files and run ?restore configuration? utility on the server.


Agents from the old MC will be able to communicate with the new MC. I have tried this several times in our disaster recovery drills.


Check the attached file.



TradeSecrets Thu, 03/08/2007 - 12:55
User Badges:
  • Bronze, 100 points or more

Make sure you can ping the MC and have the address in the host-file.


Also the MC uses PKI encrptytion bound to the IP address of the MC so; You need the same MC IP address. create new agent kits and re-try.


P.S. Make sure Firewalls have the proper ports open.

Actions

This Discussion