×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

translation for Outside Global addresses

Unanswered Question
Apr 10th, 2006
User Badges:

Hi, Messrs!


I would like to know, how can I do a translation for Outside Global addresses for one IP address and that comes from a specific interface serial (example serial 3/5)?


I would like to translate destination ip 10.12.0.170 to 192.168.1.1, but only

for packets comes from serial 3/5.


I can´t do the translation for outside global addresses in other interfaces

serials.


What wrong with that cfg?


interface FastEthernet0/0

ip address 10.145.107.131 255.255.255.0

ip nat inside

!


interface Serial3/5

ip address 192.168.151.1 255.255.255.0

ip nat outside

!


ip nat pool PROBLEMA 10.12.0.170 10.12.0.170 netmask 255.255.255.0

ip nat inside source list 50 pool PROBLEMA

access-list 50 permit 192.168.1.1


thanks in advance,

Renato


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
sundar.palaniappan Mon, 04/10/2006 - 10:32
User Badges:
  • Green, 3000 points or more

You don't need a nat pool if you are doing just static NAT. All you need is a static nat entry (see below) for transalating your global address of 10.12.0.170 to inside address of 192.168.1.1. Remove all but the interface nat commands and add the static nat noted below.


ip nat inside source static 192.168.1.1 10.12.0.170


Pls. rate all helpful posts.


HTH,

Sundar

conectividade Mon, 04/10/2006 - 11:01
User Badges:

Sundar,


but when I did it, I have had another problem.

Please look the attached file.


Ther return to other ip client when that try to connect with 192.168.1.1, does not work.

Because the router translate ip server, in the return of connection.


Renato




sundar.palaniappan Mon, 04/10/2006 - 16:02
User Badges:
  • Green, 3000 points or more

Renato,


May be I am not following something here.


To clear things up.


Global IP: 10.12.0.170.


Local IP: 192.168.1.1


192.168.1.1 is a host connected to E0/0 on your inside network. Users on the outside of s3/5 will try to get to the server using IP of 10.12.0.170 and it should be transalated to 192.168.1.1.


But there are other users on other serial interfaces, which are configured as nat outisde interfaces, they will try to get to 192.168.1.1 using it's local IP and you want that to work as well.


If I understood your requirement incorrectly and then let me know what and where.


--Sundar



conectividade Tue, 04/11/2006 - 06:10
User Badges:

Sundar,


please look this new file attached. This file have a example of our conections, where we have 3 clients, but the client-3 can not connect with server 192.168.1.1 and can not do a NAT in their router.

So we need to do this NAT of 10.12.0.170 to 192.168.1.1.

I hope you understand me.


thanks,

Renato



Actions

This Discussion