Problem with HSRP

Unanswered Question
Apr 12th, 2006
User Badges:

I have two routers in LAN with HSRP configured between them. Below the configuration:


interface FastEthernet0/0

ip address 163.x.x.5 255.255.255.0

ip nat inside

speed 100

full-duplex

standby 10 ip 163.x.112.1

standby 10 priority 120

standby 10 preempt

standby 10 track ATM2/IMA1.1 60

bridge-group 1


...


!

interface FastEthernet0/0

description Collegamento LAN CED

ip address 163.x.x.6 255.255.255.0

speed 100

full-duplex

standby 10 ip 163.157.112.1

standby 10 priority 80

standby 10 preempt

!


Each router is able to ping the FastEthernet of the other one and sees the other router as CDP neighbor, but the HSRP doesn't work:


TRNR02#sh stand brie

P indicates configured to preempt.

|

Interface Grp Prio P State Active Standby Virtual IP

Fa0/0 10 120 P Active local unknown 163.157.112.1




Below logs on 'active' router:


pr 12 16:00:33.153: HSRP: Fa0/0 API active virtual address 163.157.112.2 not found

Apr 12 16:00:33.793: HSRP: Fa0/0 Grp 10 Redundancy group hsrp-Fa0/0-10 state Active -> Active

Apr 12 16:00:33.793: HSRP: Fa0/0 Grp 10 Hello in 163.157.112.6 Active pri 80 vIP 163.157.112.1

Apr 12 16:00:33.793: HSRP: Fa0/0 Grp 10 Active: h/Hello rcvd from lower pri Active router (80/163.157.112.6)

Apr 12 16:00:33.961: HSRP: Fa0/0 API active virtual address 163.157.112.5 not found

Apr 12 16:00:34.101: HSRP: To1/0 API active virtual address 163.157.216.2 not found

Apr 12 16:00:36.794: HSRP: Fa0/0 Grp 10 Redundancy group hsrp-Fa0/0-10 state Active -> Active

Apr 12 16:00:36.794: HSRP: Fa0/0 Grp 10 Hello in 163.157.112.6 Active pri 80 vIP 163.157.112.1

Apr 12 16:00:36.794: HSRP: Fa0/0 Grp 10 Active: h/Hello rcvd from lower pri Active router (80/163.157.112.6)



Below logs on 'passive' router:

Apr 12 16:00:48.799: HSRP: Fa0/0 API arp proto filter, 0000.0c07.ac0a is active vMAC for grp 10 - filter

Apr 12 16:00:48.803: HSRP: Use HSRP virtual address 163.157.112.1 as ICMP src

Apr 12 16:00:51.796: HSRP: Fa0/0 API arp proto filter, 0000.0c07.ac0a is active vMAC for grp 10 - filter

Apr 12 16:00:51.800: HSRP: Use HSRP virtual address 163.157.112.1 as ICMP src

Apr 12 16:00:51.804: HSRP: Fa0/0 API arp proto filter, 0000.0c07.ac0a is active vMAC for grp 10 - filter


Could someone help me please?


Thanks


Stefano

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
dabels Wed, 04/12/2006 - 09:56
User Badges:

can you issue a show standby command so we can see what the status is. also if you do a debug standby it may give you more info as well.



Roberto Salazar Wed, 04/12/2006 - 10:06
User Badges:
  • Gold, 750 points or more

TRNR02 does not know the other router and yet it is able to ping the other HSRP? How about the other router is it active too? If so, HSRP hello is not getting from one router to the other at least the "standby_ HSRP is not getting the HSRP from the "active" . What is between the routers?

s-durando Thu, 04/13/2006 - 00:16
User Badges:

Each router is able to ping the other one.

Both routers believe to be the active one and the standby is unknown.

I'm investigating with customer about which kind of switch is placed between routers.



The 'debug standby packet' shows that hello packets are sent from both sides but only the active side receives hello from the standby router.



From logs I posted in the first message it seems that in the standby router there is some kind of filtering on hello packets:

Apr 12 16:00:48.799: HSRP: Fa0/0 API arp proto filter, 0000.0c07.ac0a is active vMAC for grp 10 - filter

Apr 12 16:00:48.803: HSRP: Use HSRP virtual address 163.157.112.1 as ICMP src


I can't understand the meaning of 'API arp proto filter'.


Thanks


Stefano

Roberto Salazar Thu, 04/13/2006 - 08:07
User Badges:
  • Gold, 750 points or more

The hello packet are sent every certain period of time, the interval escapes me at this moment but the fact that both routers are seeing itself as active HSRP means that the Hello packet is lost in the device between them. The hsrp hello packet is sent to a multicast address 224.0.0.x (again the actual address escapes me at this time.) The easiest to test this out is to replace that device between the fa0/0 of both rotuers with a hub and see if the HSRP status gets corrected - one active HSRP per group and one standby.

mahmoodmkl Wed, 04/12/2006 - 20:43
User Badges:
  • Gold, 750 points or more

Hi


can u plz explain me why u have used the bridge-group command any particular reason for doing it.


Thanks

Mahmood

s-durando Thu, 04/13/2006 - 00:18
User Badges:

bridge group command is used because there is a Token Ring interface and dlsw configured on router


Thanks


Stefano

Actions

This Discussion