×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.
pkhatri Tue, 04/18/2006 - 20:41
User Badges:
  • Purple, 4500 points or more

When you boot up in rommon mode, are you then able to use the 'boot' command to boot up properly ?


If so, once you get back to the normal operating mode, enter the command 'config-reg 0x2102' and then save the config. The next time, the router should boot up properly.


If, however, you cannot get out of rommon at all, you may have a corrupt or missing image. You need to follow this procedure to perform recovery:

http://www.cisco.com/en/US/products/ps5854/prod_configuration_guide09186a00802c35e9.html#wp1070700


Hope that helps - pls do remember to rate posts that help.


Paresh

minimintu Tue, 04/18/2006 - 23:08
User Badges:

i have tried to configure according to the link provided by you.i am configuring through tftp.but the problem is that when i set these commands

ip_address=

ip_subnet_mask=

default_gateway=

tftp_server=

tftp_file=

set

tftpdnld


router gives error and it shows that IP address missing.i even changed the register as 0x2102 but the same error is coming. is the flash card got corrupted to such a level that it cannot be rectified??



help me out





pkhatri Tue, 04/18/2006 - 23:38
User Badges:
  • Purple, 4500 points or more

Would it be possible for you to advise the exact values you are using when setting the above variables ?


And can you confirm that you have a PC running a TFTP server connected to your Ethernet port ?


Paresh.

minimintu Wed, 04/19/2006 - 00:44
User Badges:

IP_ADDRESS=172.16.23.32

IP_SUBNET_MASK=255.255.255.224

DEFAULT_GATEWAY=172.16.23.40

TFTP_SERVER=172.16.23.33

TFTP_FILE=tftp-root/c2801-i-mz

FE_PORT=0


tftp server is running on my PC. 2811 router has external flash card

Richard Burts Wed, 04/19/2006 - 08:33
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

I believe that part of the problem is the addressing that you are using. With the mask of 255.255.255.224 the address 172.16.23.32 is a subnet address not a host address. I suggest that you try changing the address used to 172.16.23.34.


Try that and let us know if it works better.


HTH


Rick

minimintu Wed, 04/19/2006 - 22:47
User Badges:

i have changed the IP address as 172.16.23.34 but still i am getting the same error


help me out

Richard Burts Thu, 04/20/2006 - 12:45
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

It is strange that it would still report the IP address as missing. Perhaps you could post the new settings of the variables as you did before and post a screen capture of the attempt to tftpdnld and the response message. This might help us find a solution.


HTH


Rick

csco10837896 Thu, 04/20/2006 - 21:30
User Badges:

Hi,


Try to do it as following way:

IP_ADDRESS=172.16.23.1

IP_SUBNET_MASK=255.255.255.0

DEFAULT_GATEWAY=172.16.23.40

TFTP_SERVER=172.16.23.40

TFTP_FILE=tftp-root/c2801-i-mz

FE_PORT=0

tftpdnld


Make conectivity from router to machine via cross cable. copy ios in tftp root folder or C:\ tftp folder,run tftp from same folder.

TFTP_FILE=tftp-root/c2801-i-mz wrong just specify

c2801-i-mz with Extention as .t13 or .bin


I am sending you tftp server file





Attachment: 
minimintu Thu, 04/20/2006 - 21:57
User Badges:

i have done the same configuration but still i am getting the same result.


i have attached the screen shot of the error



Attachment: 
chirag-pandya Fri, 04/21/2006 - 01:55
User Badges:

Hello Minimintu,


I saw all messeges in ur case in netpro,

Can u give me detail about ur flash card and IOS version and size so we can rectifiy the prob,


Chirag Pandya

minimintu Fri, 04/21/2006 - 03:42
User Badges:

IOS version is Cisco IOS Software, 2800 Software (C2800NM-IPBASE-M), Version 12.3(8)T8


Flash is c2800nm-ipbase-mz.123-8.T8.bin and size is


13273916


help me outttt

Richard Burts Fri, 04/21/2006 - 06:20
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Thanks for posting the screen shots. Unfortunately both screen shots show the error, but do not show how the variables have been set. The error indicates that something is a problem about the setting of IP_ADDRESS and it would be helpful if we could see exactly how it (and the other variables) are set. Can you post a screen shot which shows how all the variables are set?


HTH


Rick

csco10837896 Fri, 04/21/2006 - 06:48
User Badges:

Hi,


Hi,


Try to do it as following way:

IP_ADDRESS=172.16.23.1

IP_SUBNET_MASK=255.255.255.0

DEFAULT_GATEWAY=172.16.23.40

TFTP_SERVER=172.16.23.40

TFTP_FILE=c2800nm-ipbase-mz.123-8.T8.bin

FE_PORT=0

tftpdnld


Make conectivity from router to machine via cross cable. copy ios in tftp root folder or C:\ tftp folder,run tftp from same folder.

TFTP_FILE=tftp-root/c2801-i-mz wrong just specify

c2800nm-ipbase-mz.123-8.T8.bin


or i think .t8 is your extention of file

if yes then try

c2800nm-ipbase-mz.123-8.T8 only


Pls rate this post,

Yogesh

minimintu Fri, 04/21/2006 - 20:50
User Badges:

i have done the configuration as above but i am getting the same error.

Is the flash destroyed permantely???



Richard Burts Sun, 04/23/2006 - 17:07
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

I do not believe that an error message indicating that IP address is missing is an indicator that flash is destroyed. As I asked before please post a screen shot showing the current setting of the variables.

And possibly a screen shot of the attempt to load the image and the resulting error message.


HTH


Rick

Actions

This Discussion