×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

help,is it a protocol problem?

Answered Question
Apr 20th, 2006
User Badges:

1142: *Apr 2 10:51:12: %SPANTREE-2-UNBLOCK_CONSIST_PORT: Unblocking GigabitEthernet0/1 on VLAN0202. Port consistency restored.

2006 Apr 20 17:28:39 utc +08:00 %SPANTREE-2-PORTUNBLK: Unblock previously inc port 3/1 on VLAN 202

2006 Apr 20 17:28:39 utc +08:00 %SPANTREE-2-PORTUNBLK: Unblock previously inc port 3/1 on VLAN 114

51: Inconsistent local vlan.

50: *Mar 1 00:36:34: %SPANTREE-2-BLOCK_PVID_LOCAL: Blocking GigabitEthernet0/2 on vlan 114.

49: Inconsistent peer vlan.

48: *Mar 1 00:36:34: %SPANTREE-2-BLOCK_PVID_PEER: Blocking GigabitEthernet0/2 on vlan 202.

47: Received BPDU with inconsistent peer vlan id 202 on GigabitEthernet0/2 on vlan 114.

46: *Mar 1 00:36:34: %SPANTREE-2-RECV_PVID_ERR:

430: Inconsistent local vlan.

429: *Mar 1 06:54:08: %SPANTREE-2-BLOCK_PVID_LOCAL: Blocking GigabitEthernet0/1 on vlan 114.

428: Inconsistent peer vlan.

427: *Mar 1 06:54:08: %SPANTREE-2-BLOCK_PVID_PEER: Blocking GigabitEthernet0/1 on vlan 202.

426: Received BPDU with inconsistent peer vlan id 202 on GigabitEthernet0/1 on vlan 114.

425: *Mar 1 06:54:08: %SPANTREE-2-RECV_PVID_ERR:

1141: *Apr 2 10:50:57: %SPANTREE-2-BLOCK_PVID_LOCAL: Blocking GigabitEthernet0/1 on VLAN0114. Inconsistent local vlan.

1140: *Apr 2 10:50:57: %SPANTREE-2-BLOCK_PVID_PEER: Blocking GigabitEthernet0/1 on VLAN0202. Inconsistent peer vlan.

1139: *Apr 2 10:50:57: %SPANTREE-2-RECV_PVID_ERR: Received BPDU with inconsistent peer vlan id 202 on GigabitEthernet0/1 VLAN114.

2006 Apr 20 17:28:25 utc +08:00 %SPANTREE-2-TX_BLKPORTPVID: Block 3/1 on xmtting vlan 202 for inc peer vlan

2006 Apr 20 17:28:25 utc +08:00 %SPANTREE-2-RX_BLKPORTPVID: Block 3/1 on rcving vlan 114 for inc peer vlan 202

2006 Apr 20 17:28:25 utc +08:00 %SPANTREE-2-RX_1QPVIDERR: Rcved pvid_inc BPDU on 1Q port 3/1 vlan 114

Correct Answer by ankurbhasin about 11 years 4 months ago

Hi Friend,


Yes this could be an issue as connecting a hub or even a cross over cable between 2 ports in different vlans can result in this kind of problem and to be frank it is really difficult to find out in a big network.


You just need to check the errors and follow the ports and trace it out.


Check this link for all kind of spanning tree error messages and what they mean and how to troubleshoot them. This link has all the errors which were reported in your logs


http://www.cisco.com/en/US/products/sw/iosswrel/ps1835/products_system_message_guide_chapter09186a008009e7a1.html#353669


HTH, if yes please rate the post.


Ankur

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
ankurbhasin Thu, 04/20/2006 - 02:47
User Badges:
  • Red, 2250 points or more

Hi Friend,


I already tried to put it into your last post. No its not a protocol problem and mostly the problem is with configuration.


Anways can you check the native vlan config on the trunk ports? Or is possible post the config for trunk from both the switches


Regards,


Ankur

crazyIvan Thu, 04/20/2006 - 03:25
User Badges:

distribute layer switch:


hqjr12_cat3550_1#show int trunk


Port Mode Encapsulation Status Native vlan

Fa0/3 on 802.1q trunking 1

Fa0/4 on 802.1q trunking 1

Fa0/5 on 802.1q trunking 1

Fa0/6 on 802.1q trunking 1

Fa0/11 on 802.1q trunking 1

Fa0/12 on 802.1q trunking 1

Fa0/13 on 802.1q trunking 1

Fa0/16 on 802.1q trunking 1

Fa0/18 on 802.1q trunking 1

Gi0/1 on 802.1q trunking 1

core layer switch:

CNC-6506-L2-1> (enable) show port trunk

* - indicates vtp domain mismatch

Port Mode Encapsulation Status Native vlan

-------- ----------- ------------- ------------ -----------

1/1 on dot1q trunking 1

3/1 on dot1q trunking 1

3/3 on dot1q trunking 203

3/8 on dot1q trunking 1

15/1 nonegotiate isl trunking 1

16/1 nonegotiate isl trunking 1


ankurbhasin Thu, 04/20/2006 - 03:52
User Badges:
  • Red, 2250 points or more

Hi Friend,


I think you are getting an error on


Gi0/1 on 802.1q trunking 1


3/1 on dot1q trunking 1 on different switch


Can you paste the complete config related to these ports from the 2 switches? as what all vlans are allowed on the trunks and other stuff , just paste all port related configs for these 2 ports only.


Regards,


Ankur




crazyIvan Thu, 04/20/2006 - 04:17
User Badges:

the native vlan is the same,however the crisis stop after all the clerk left,i thought it's not a misconfigeration,maybe someone connect two vlan togather using a hub or something,am i right?

could you tell me how can i find it,which kind of command is useful for me or send me a link,

thank you my dear friend

Correct Answer
ankurbhasin Thu, 04/20/2006 - 21:26
User Badges:
  • Red, 2250 points or more

Hi Friend,


Yes this could be an issue as connecting a hub or even a cross over cable between 2 ports in different vlans can result in this kind of problem and to be frank it is really difficult to find out in a big network.


You just need to check the errors and follow the ports and trace it out.


Check this link for all kind of spanning tree error messages and what they mean and how to troubleshoot them. This link has all the errors which were reported in your logs


http://www.cisco.com/en/US/products/sw/iosswrel/ps1835/products_system_message_guide_chapter09186a008009e7a1.html#353669


HTH, if yes please rate the post.


Ankur

Actions

This Discussion