ichat over cisco 857

Unanswered Question
Apr 21st, 2006
User Badges:

Hi

i'm not sure this is the correct forum but any help it's welcome.


I have a 857 router ios 12.4(4)T with no acl, and no firewall configured, i need to apple ichat for video but all the time i get no response from my client. Apple says this:

"Network address translation (NAT) is a popular method for sharing an Internet connection on small networks. Airport base stations and many other household routers have the option of using NAT. In many cases, NAT is the default setting. iChat can establish audio and video connections over NAT, which may allow iChat to succeed where similar teleconference applications cannot."

i'm using only 1 external ip address share thru NAT


Best Reagrds

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
beth-martin Thu, 04/27/2006 - 06:35
User Badges:
  • Bronze, 100 points or more

you may have to open the Port 5060.application may not work if there are two forms of NAT.

matheaudakoske Mon, 06/05/2006 - 16:32
User Badges:

I have the same problem on my Cisco 831 running ios 12.4(5a). iChat reports "Can't get video from the camera." but only when going through the router. I've opened up the recommended ports and have even tried having no filtering ("permit udp any any" "permit tcp any any") but no dice.


Same behavior for NAT and static mapping.


Thanks in advance for any advice.

matheaudakoske Fri, 10/27/2006 - 21:07
User Badges:

I actually got my Cisco 831 IOS 12.4 working with iChat after countless googles and many failed attempts. I finally stumbled accross this little gem at:


http://www.dslreports.com/forum/remark,16423505


I don't think NAT was the problem, but rather the way some of cisco's routers handle SIP (5060). These two lines in my config saved the day:


no ip nat service sip tcp port 5060

no ip nat service sip udp port 5060


Good luck!

alpineclubIT Fri, 10/27/2006 - 21:19
User Badges:

Thanks very much for the update.

I knew that NAT had nothing to do with it and was banging my head trying to figure out how to disable SIP, which seems weird that Cisco would hardcode that entry in these days with VOIP... Thanks again for the tip, hope it works, will please many many people in the office and reduce using Skype... thnx again.

alpineclubIT Sat, 10/28/2006 - 12:45
User Badges:

Were you actually able to get more than one machine to work, or only 1 static route using port 5190 after addressing the 5060 problem ?


J.

alpineclubIT Sat, 10/28/2006 - 12:57
User Badges:

Were you actually able to get more than one machine to work, or only 1 static route using port 5190 after addressing the 5060 problem ?


J.

Actions

This Discussion