×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Need help with SRST

Unanswered Question

I have a 2621 router running 12.1(5)YD5 with 2 FXO ports, outbound calls go out the FXO and my call manager is connected via the WAN created by a PIX-PIX VPN. When my WAN goes down, the phones go into fallback mode but do not recieve inbound calls and when I make an outbound call, I can hear the person I call but they can't hear me. My router config is:

call-manager-fallback

ip source-address 172.16.2.253 port 2000 strict-match

max-ephones 24

max-dn 24

dialplan-pattern 1 8067622... extension-length 3

default-destination 135

voicemail 500


and access-list is:

access-list 100 deny tcp any eq 2000 any eq 2000

access-list 100 permit ip any any


can anyone tell me what is wrong?


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (2 ratings)
Loading.
anup.anand Wed, 05/03/2006 - 11:36
User Badges:
  • Silver, 250 points or more

Can you post the entire configs? Also what is the IP Address range of the IP Phones?


Regards,


Anup

Building configuration...


Current configuration : 2356 bytes

!

version 12.1

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname lubbockvoice

!

logging rate-limit console 10 except errors

enable secret 5 xxxxx

!

!

!

ip subnet-zero

!

!

no ip finger

no ip domain-lookup

!

ip dhcp pool LAN

network 172.16.2.0 255.255.255.0

default-router 172.16.2.253

dns-server 172.16.1.201

netbios-name-server 172.16.1.3

netbios-node-type p-node

domain-name xxxxx

option 150 ip 172.16.3.1

!

!

!

!

voice class h323 1

h225 timeout tcp establish 1

!

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address 172.16.2.253 255.255.255.0

duplex auto

speed auto

h323-gateway voip interface

h323-gateway voip bind srcaddr 172.16.2.253

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

ip classless

ip route 0.0.0.0 0.0.0.0 172.16.2.254

no ip http server

!

access-list 100 deny tcp any eq 2000 any eq 2000

access-list 100 permit ip any any

!

!

snmp-server packetsize 4096

call rsvp-sync

!

voice-port 1/0/0

connection plar 100

signal groundStart

!

voice-port 1/0/1

connection plar 100

signal groundStart

!

no mgcp timer receive-rtcp

!

mgcp profile default

!

dial-peer cor custom

!

!

!

dial-peer voice 1 voip

preference 1

destination-pattern 1..

session target ipv4:172.16.3.1

dtmf-relay h245-alphanumeric

codec g711ulaw

no vad

!

dial-peer voice 102 pots

preference 1

destination-pattern 8

port 1/0/1

!

dial-peer voice 103 pots

preference 2

destination-pattern 8

port 1/0/0

!

dial-peer voice 205 voip

destination-pattern 2..

session target ipv4:172.16.3.1

dtmf-relay h245-alphanumeric

codec g711ulaw

no vad

!

dial-peer voice 100 pots

preference 2

destination-pattern 9

port 1/0/0

!

dial-peer voice 101 pots

preference 1

destination-pattern 9

port 1/0/1

!

dial-peer voice 2 voip

destination-pattern 121

voice-class h323 1

session target ras

dtmf-relay h245-alphanumeric

codec g711ulaw

no vad

!

!

call-manager-fallback

ip source-address 172.16.2.253 port 2000 strict-match

max-ephones 24

max-dn 24

dialplan-pattern 1 8067622... extension-length 3

default-destination 135

voicemail 500

!

!

line con 0

logging synchronous

transport input none

line aux 0

line vty 0 4

password pmm01

login

!

no scheduler allocate

end



IP Range of phones is 172.16.2.0 thanks

anup.anand Fri, 05/05/2006 - 16:05
User Badges:
  • Silver, 250 points or more

You are using the access-list to block all Skinny packets to and from the IP Phones to simulate a WAN Down, right. The WAN is not actually down, right.


Because of the access-list, the phones will go to Fallback mode. But the FXO ports are setup to send calls to extension 100 and they will use Dial-peer 1 and the calls will be routed to Callmanager using H323, since H323 ports are not blocked by the access list. To the Callmanager, these phones are no longer registerd to it, that could be why incoming calls are failing. If you have Callforward busy or no answer setup for these phones, then Callmanager will send the call to that destination.


Try the same test after shutting down dial-peer 1 and see what happens.


For the one way voice with outgoing calls, try issuing this command in global mode


voice rtp send-recv


Regards,


Anup




k_vishwesh Sun, 05/07/2006 - 05:51
User Badges:

i have gone through ur config.

for inbound cal u need to metioned the dial-peer matching. i see 2 voip dial-peer , which i belive pointing to CCM.

in order to make your local router as call processing.add the following config.


dial-peer voice 205 voip

destination-pattern ...

session target ipv4:172.16.2.253

dtmf-relay h245-alphanumeric

codec g711ulaw

no vad


for outgoing , define this command


voice rtp send-recieve


anup.anand Mon, 05/08/2006 - 15:16
User Badges:
  • Silver, 250 points or more

Do you have any phone at the remote site with X 100? If yes, then this will work. Since your dial-peer 1 is 1.. and the IP phone registers as 100, when the router does the digit analysis, the phone will be matched first.


If X 100 not at the remote site now, as an alternate solution, you can add X 100 to one of the remote site phones in a different partition and setup the CSS of the gateway so that it does not include the new partition. This way when the WAN is up, the gateway cannot reach X 100 at the remote site. But when the WAN is down, X 100 will register with the SRST gateway and incoming calls will get through.


Regards,


Anup

Actions

This Discussion