×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

can't upgrade IOS via tftp on 2821

Answered Question
May 8th, 2006
User Badges:

I am trying to upgrade a 2821 via tftp to an IOS image that is 34MB. My "old reliable" tftp cannot handle files larger than 16MB so I donwload and tried two other servers. I tried SolarWinds and a server by Whitehorn. In both cases the router begins to download the IOS but it seems to keep going after downloading the IOS's 34MB and it begins the download again. It seems to loop in this manner until the flash is full and then the xfer quits complaing of the full flash! Is this a problem on the router end or should I look for yet another large file capable tftp server?


Thanks,

Diego

Correct Answer by spremkumar about 11 years 3 months ago

Hi


The best bet for the file transfers ranging more than 16MB would be FTP.


Do find this link which talks about the limitation(bug) in detail..


http://www.cisco.com/en/US/products/sw/iosswrel/ps1831/products_field_notice09186a0080094cae.shtml


regds


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
DIEGO ALONSO Tue, 05/09/2006 - 03:01
User Badges:

That doesn't seem to be the issue that I am running into. Reason being that the current IOS is pretty recent. It is an 12.3 IOS and I am not getting the timeout condition. I am actually seeing the opposite whereby the IOS client transfers the IOS image repeatedly until it fills the flash. Nevertheless FTP seems like a good option and I will try it.


Thank you very much.

Diego

Actions

This Discussion