QOS Jitter Issues.

Unanswered Question
May 10th, 2006
User Badges:

I have a CME 3.2 router talking to a CM 4.0 server via a H323 dial-peer. They are connected via a 512/256K. I have the following QOS statement, and config.


class-map match-all VOICE-CONTROL

match ip dscp af31

match dscp cs3

class-map match-any VOICE

match ip dscp ef


policy-map VOIP-QOS

class VOICE

priority 96

class VOICE-CONTROL

priority 8

class class-default

fair-queue


interface FastEthernet0/0

bandwidth 256

ip address 172.18.33.2 255.255.255.0

service-policy output VOIP-QOS


interface FastEthernet0/1.1

encapsulation dot1Q 1 native

ip address 10.181.8.253 255.255.255.0

!

interface FastEthernet0/1.2

encapsulation dot1Q 2

ip address 10.181.9.253 255.255.255.0


interface FastEthernet0/1.3

encapsulation dot1Q 3

ip address 10.181.10.253 255.255.255.0

h323-gateway voip bind srcaddr 10.181.10.253


ip route 10.140.0.0 255.255.255.0 172.18.33.1

ip route 10.140.1.0 255.255.255.0 172.18.33.1

ip route 10.140.12.0 255.255.255.0 172.18.33.1

ip route 10.140.14.0 255.255.255.0 172.18.33.1

ip route 10.140.99.0 255.255.255.0 172.18.33.1

ip route 10.141.0.0 255.255.0.0 172.18.33.1

ip route 10.150.1.0 255.255.255.0 172.18.33.1

ip route 10.253.2.0 255.255.255.0 172.18.33.1


dial-peer voice 4000 voip

destination-pattern 4[136-8]..

session target ipv4:10.141.1.1

dtmf-relay h245-alphanumeric

no vad


telephony-service

load 7910 P00403020214

load 7960-7940 P00305000600

max-ephones 30

max-dn 100

ip source-address 10.181.10.253 port 2000

timeouts interdigit 3

create cnf-files version-stamp Jan 01 2002 00:00:00

max-conferences 4

transfer-system full-consult


ephone-dn 1 dual-line

number 3799


ephone 1

mac-address 0017.5987.88F7

type 7960

button 1:1


The phones are all on Vlan 3, with the PC's and servers on Vlan 2. With no traffic on the link, Voice Quality is fine, but when outbound traffic is maxing the link, the qos statements appears to be working, if I do a sh policy-map interface fastethernet 0/0. But I am still getting a lot of jitter on the call, for the oubound voice from the CME box. eg, Users at the CM end hear the jitter, while users at the CME do not.


I have tired everything I can find to do with QOS and Voice traffic, and at a loss. Does anybody have any fresh ideas that I can try, or see anything obvious that I have wrong.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
mheusinger Thu, 05/11/2006 - 06:36
User Badges:
  • Green, 3000 points or more

Hello,


there are a few recommendations and fresh ideas.

First, your queueing (f.e. "priority 8") will not have any effect in the config shown. The underlying reason is, that LLQ is only involved, when the hardware queue is overloaded. In your case this would mean that there is more traffic than your FE0/1 can handle!

So you need a nested policy to throttle the traffic to the desired value of 512k. Or you implement your policy at the router with your WAN link. Assuming this might not be possible you could do the following:


class-map match-all VOICE-CONTROL

match ip dscp af31

match dscp cs3

class-map match-any VOICE

match ip dscp ef


policy-map VOIP-QOS

class VOICE

priority 96

class VOICE-CONTROL

bandwidth 8

class class-default

fair-queue


policy-map shape256k

class class-default

shape 256000

service-policy output VOIP-QOS


interface FastEthernet0/0

bandwidth 256

ip address 172.18.33.2 255.255.255.0

service-policy output shape256k


This will make sure that there is no more traffic than the WAN link can handle and your service-policy is applied, when more than 256k of traffic crosses the FE0/1.


Second, jitter will be caused by large IP packets (1500 Byte) blocking your VoIP packets. Once the WAN router starts transmitting (OSI physical layer) a 1500 Byte IP packet (f.e. FTP download) it can not stop transmitting. Thus a VoIP packet might have to wait up to 47 ms (1500 Byte over 256k) - this gives a Jitter of 47 ms. The second contribution to jitter, presumably the larger one right now, comes from the queueing system on the WAN router, which does not prioritize VoIP packets (assumed). Thus even hundreds of ms could be observed.


Conclusion: modify the config to the suggested example config above. This should improve the situation. It might still give you jitter up to 50 ms because of large IP packet on a low bandwidth link (256k). Usually telephones can cope with this without massive voice quality degradation.


Hope this helps! please rate all posts.


Regards, Martin

Actions

This Discussion