QOS Prioritizing Traffic Problem

Unanswered Question

Remote office/Cisco 1841



I am puzzled.

The "show policy-map interface" shows the correct class-map (priority),

shows that there are plenty of packets that have been processed through the

priority class-map. Everything looks OK except for the "Packets marked 0"

piece. I don't understand why that doesn't show a non-zero number.


List below is my config.


!

version 12.3

no service pad

service tcp-keepalives-in

service tcp-keepalives-out

service timestamps debug datetime msec localtime show-timezone

service timestamps log datetime msec localtime show-timezone

service password-encryption

service sequence-numbers

!

boot-start-marker

boot-end-marker

!

security authentication failure rate 3 log

security passwords min-length 6

logging buffered 51200 warnings

!

memory-size iomem 25

clock timezone NewYork -5

clock summer-time NewYork date Apr 6 2003 2:00 Oct 26 2003 2:00

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

no aaa new-model

ip subnet-zero

no ip source-route

ip cef

!

!

ip tcp synwait-time 10

!

class-map match-all priority

match access-group name priority

!

!

policy-map outbound

class priority

set ip precedence 1

bandwidth 768

class class-default

set ip precedence 0

fair-queue

!

!

!

interface Null0

no ip unreachables

!

interface Serial0/0/0

description $FW_INSIDE$

ip address x.x.x.x

ip access-group 103 out

ip verify unicast reverse-path

no ip redirects

no ip unreachables

no ip proxy-arp

ip nbar protocol-discovery

max-reserved-bandwidth 100

service-policy output outbound

encapsulation ppp

ip route-cache flow

service-module t1 timeslots 1-24

!

ip http server

ip http access-class 1

ip http authentication local

!

ip access-list extended priority

permit tcp any any eq telnet

permit ip any 192.168.0.0 0.0.255.255

!

sh access-list


Extended IP access list priority

10 permit tcp any any eq telnet (44906 matches)

20 permit ip any 192.168.0.0 0.0.255.255 (19774 matches)



show policy-map interface

Serial0/0/0


Service-policy output: outbound


Class-map: priority (match-all)

64711 packets, 13911001 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: access-group name priority

QoS Set

precedence 1

Packets marked 0

Queueing

Output Queue: Conversation 266

Bandwidth 768 (kbps) Max Threshold 64 (packets)

(pkts matched/bytes matched) 0/0

(depth/total drops/no-buffer drops) 0/0/0


Class-map: class-default (match-any)

2909411 packets, 492075275 bytes

5 minute offered rate 1000 bps, drop rate 0 bps

Match: any

QoS Set

precedence 0

Packets marked 88296

Queueing

Flow Based Fair Queueing

Maximum Number of Hashed Queues 256

(total queued/total drops/no-buffer drops) 0/0/0



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
ahmed-hussein Wed, 05/17/2006 - 20:22
User Badges:

Hello,


It's better to modify the configuration as below


class-map match-all priority-in

match access-group name priority


class-map match-all priority-out

mach ip precedence 1


class-map

set ip precedence 0


Policy-map inbound

class priority-in

set ip precedence 1


policy-map outbound

class priority-out

bandwidth 768

class class-default

fair-queue



interface

service-policy input inbound


interface

service-policy outbound


Thanks,

Ahmed Hussein

mounir.mohamed Thu, 05/18/2006 - 01:09
User Badges:
  • Gold, 750 points or more

Dear smartin,


Its seems that there are no packet matched by the class-map priority due to ACL behavior which is (If match Then Stop) so i beleive that the below configurations example will achive your needs ISA.


Ex1:

----

class-map match-all priority

match access-group 101


policy-map Outbound

class priority

bandwidth 768

set ip precedence 1

class class-default

set ip precedence 0

fair-queue


access-list 101 permit tcp any 192.168.0.0 0.0.255.255 eq telnet


Ex2

---


class-map match-all priority

match protocol telnet


class-map match-all address

match access-group 100


class-map match-all parent

match class-map address

match class-map priority


policy-map outbound

class parent

bandwidth 768

set ip precedence 1

class class-default

set ip precedence 0

fair-queue


access-list 100 permit ip any 192.168.0.0 0.0.255.255


Please Let me know the results


Best Regards,

Mounir Mohamed

Core Engineer

NOOR Advanced Technology, SAE

Actions

This Discussion