×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

ISDN Idle-timeout

Unanswered Question
May 18th, 2006
User Badges:

Hi,

I have 803 router, ISDN is not disconnecting automatically. I have configured idle-timeout for 50 seconds.

Secounds idle is not showing when i excute "show isdn history"


Configuration :


interface Ethernet0

ip address 172.22.127.254 255.255.224.0

!

interface BRI0

description connected to NRAS

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

no cdp enable

ppp authentication pap callin

ppp pap sent-username [email protected] password 0 XXX123

ppp multilink

!

interface Dialer1

description connected to NRAS

ip address 97.184.x.x.255.255.224

encapsulation ppp

dialer pool 1

dialer idle-timeout 50

dialer string XXXXXXX

dialer-group 1

no cdp enable

ppp authentication pap callin

ppp pap sent-username [email protected] password 0 XXX123

ppp multilink

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

ip route 97.184.30.x.x.255.255 97.184.30.58

no ip http server

!

!

dialer-list 1 protocol ip permit


ELGI-Cochin#sh is his

--------------------------------------------------------------------------------

ISDN CALL HISTORY

--------------------------------------------------------------------------------

Call History contains all active calls, and a maximum of 100 inactive calls.

Inactive call data will be retained for a maximum of 15 minutes.

--------------------------------------------------------------------------------

Call Calling Called Remote Seconds Seconds Seconds Charges

Type Number Number Name Used Left Idle Units/Currency

--------------------------------------------------------------------------------

Out ---N/A--- 3233252 RNCCN1 6072 Unavail - 0




  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
a.hajhamad Thu, 05/18/2006 - 23:27
User Badges:
  • Bronze, 100 points or more

I think you need to know the config. for your coressponding dialer interface at the NRAS.


Richard Burts Fri, 05/19/2006 - 02:15
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

uvaraj


The idle timeout will take down the line when it has been idle for that period of time. When the dialer list says ip permit, then any IP packet going over the ISDN link will reset the idle timer. How much traffic is going over this link and what is the possibility that this is enough traffic that the link is never idle for that period of time?


HTH


Rick

pciaccio Fri, 05/19/2006 - 03:00
User Badges:
  • Silver, 250 points or more

Is it wise to have a default static route destined for the dialer interface. All default traffic will try the dialer interface. That could be alot of unnecessary traffic. Use a floating static route

ip route 0.0.0.0 0.0.0.0 dialer 1 2


The admin distance was changed to 2 in this statement. That means that any traffic destined for default will not take dialer 1 until the primary choice of traffic for default is down. Or you can remove the default static route all together and place a more specific route in its place, one that will not trigger the dialer.

cisand2002 Fri, 05/19/2006 - 03:42
User Badges:

Hi,


Agree with Rick. You need to filter interesting from non interesting traffic.

In your config all ip traffic will keep you connection up (broadcast, mutilcast.. routing protocols..)


I will suggest to start bu adding this:


access-list 120 deny ip any 0.0.0.0 0.0.0.255

access-list 120 deny ip any 224.0.0.0 0.255.255.255

access-list 120 deny ip any 127.0.0.0 0.255.255.255

access-list 120 deny ip 224.0.0.0 0.255.255.255 any

access-list 120 deny ip 127.0.0.0 0.255.255.255 any

access-list 120 deny udp any any eq netbios-ns

access-list 101 deny udp any any eq netbios-dgm

access-list 120 deny ospf any any

access-list 120 deny eigrp any any

access-list 120 deny igrp any any

access-list 120 permit tcp any any

access-list 120 permit udp any any

access-list 120 permit ip any any


dialer-list 1 protocol ip list 120


HTH, please rate.


cisand

cisand2002 Fri, 05/19/2006 - 03:43
User Badges:

Hi,


Agree with Rick. You need to filter interesting from non interesting traffic.

In your config all ip traffic will keep you connection up (broadcast, mutilcast.. routing protocols..)


I will suggest to start bu adding this:


access-list 120 deny ip any 0.0.0.0 0.0.0.255

access-list 120 deny ip any 224.0.0.0 0.255.255.255

access-list 120 deny ip any 127.0.0.0 0.255.255.255

access-list 120 deny ip 224.0.0.0 0.255.255.255 any

access-list 120 deny ip 127.0.0.0 0.255.255.255 any

access-list 120 deny udp any any eq netbios-ns

access-list 101 deny udp any any eq netbios-dgm

access-list 120 deny ospf any any

access-list 120 deny eigrp any any

access-list 120 deny igrp any any

access-list 120 permit tcp any any

access-list 120 permit udp any any

access-list 120 permit ip any any


dialer-list 1 protocol ip list 120


HTH, please rate.


cisand

uvaraj Wed, 05/24/2006 - 06:32
User Badges:

Hi All,


After removing the “ppp multilink” from dialer interface the isdn started disconnecting when it exits the idle timeout.


The input given by you are very useful which avoid triggering the ISDN line from broadcast and multicast traffic.

Thanks for your reply.


Regards

Uvaraj.B


prakhar_81 Sun, 05/28/2006 - 00:32
User Badges:

rather than putting the idle time out coommand on the dialer , put in the bri0 one::


bri0

dialer idle time out-50

Actions

This Discussion