Not able to change auto to trunk mode on switch

Unanswered Question
May 24th, 2006

SW-B-TOP(config-if)#switchport mode trunk

When trying to execute the above command am getting the following error.

Command rejected: An interface whose trunk encapsulation is "Auto" can not be configured to "trunk" mode.

I have this problem too.
2 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3.8 (9 ratings)
glen.grant Wed, 05/24/2006 - 15:30

You have to specifically set the encapsulation type first "switchport encapsulation dot1q" then try youir command...

aksher@cisco Wed, 05/24/2006 - 15:47

it's not accepting.

SW-B-TOP(config-if)#switchport encapsulation dot1q

^

% Invalid input detected at '^' marker

the model is CGESM.

glen.grant Wed, 05/24/2006 - 16:32

You need to specifically set the encapsulation first , "switchport encapsulation dot1q" then issue your trunk command...

glen.grant Wed, 05/24/2006 - 16:36

can you post the config...

ankurbhasin Wed, 05/24/2006 - 22:00

Hi All,

The command which he need to enter first is

"switchport trunk encapsulation dot1q " and then he can confgigure the interface in trunk mode.

So try this command

switch(config)#interface fa0/1

switch(config-if)#switchport trunk encapsulation dot1q

switch(config-if)#switchport mode trunk

and you will be good to go.

HTH, if yes please rate the post.

Ankur

aksher@cisco Thu, 05/25/2006 - 10:13

Thanks Ankur

Should we need to disable the concerned vlan of the port before entering the configuration.

ankurbhasin Fri, 05/26/2006 - 00:31

Hi Friend,

Thats not required because if you put the config which I posted in my previous mail it will take care of the issue.

HTH, if yes please rate the post.

Ankur

FatimaBeyelhadj Wed, 10/02/2013 - 09:28

This worked on one of the switches and not the other?! 

What do you think could be the cause besides lab technical issues?

Serge Wed, 10/09/2013 - 05:39

Could you run a " sh int gig #/# capabilities"

look under Trunk encap. type:

and Trunk mode:

it will give you capabilities information of the port

jhotles@unityte... Mon, 10/21/2013 - 07:01

The command is "switchport TRUNK encapsulation dot1q".  This will then allow the command "Switchport MODE TRUNK".

This is the core to the configuration - You NEED this command to run a standard trunk configuration otherwise it WILL NOT work...

zul qarnain Fri, 06/13/2014 - 17:14

Hi Ankur,

I have question why for switch multilayer is different from switch not multilayer if we need configure trunk on port?

 

Thanks,

Actions

Login or Register to take actions

This Discussion

Posted May 24, 2006 at 2:55 PM
Stats:
Replies:11 Overall Rating:3.79167
Views:53013 Votes:2
Shares:0
Tags: No tags.