×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Authorization Problem

Unanswered Question
May 31st, 2006
User Badges:

Hi, I'm having problems authenticating for calling a page http://IP/CGI/Execute


from a java process, in one machine I manage to do it with no problem but en the other machine I have problems 401 http, I use a page for authentication and send user and password Base64 Encoded but it doesn't work.


Can any one help me?




  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
stephan.steiner Thu, 06/01/2006 - 05:15
User Badges:
  • Silver, 250 points or more

Is the login you are using associated to both devices? The account you're using needs to be a controlling users of every device you want to push data to.

jrtejada2k Thu, 06/01/2006 - 07:28
User Badges:

Yes the user is associated to the phone and has privilegies but it doesn't work, using another model 7960 it works just fine but using a 7905 it don't


is it diferent for the phone model?





jrtejada2k Thu, 06/01/2006 - 08:28
User Badges:

which both devices? I did not get that because I've just associated the user to the device but it's only one, where can I associate to the other device the user

shahedvoicerite Thu, 06/01/2006 - 13:48
User Badges:

Is the AuthURL on the phone that does not work correctly setup ?


AFAIK, when using CGI/Execute you can have a simple servlet always return "AUTHORIZED" when the phone gets a push request.

So I dont really think user ids are an issue.

jrtejada2k Thu, 06/01/2006 - 15:55
User Badges:

As a mater of fact we use a servlet that allways returns AUTHORIZED but thats not the problem

the problem is that when we are trying to use CGI/Execute it sends error 4 as reply meaning authorization error



Whe do not know why in that call manager in the other two of them it workded just fine


please help with this triky issue.


Sascha Monteiro Thu, 06/01/2006 - 18:49
User Badges:
  • Silver, 250 points or more

So,

Just so I understand it correclty,

you cannot push to 7905, but can to a 7960?


Did you check if the authentication URL's for both phones are pointing to the same script.

Also, if you run CCM auhtentication, check if both phones are associated with the userID.

Actions

This Discussion