×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Multilink not working

Unanswered Question

hi,

I configured 2 routers with the following multilink configuration:

Router # 1

interface Multilink1

description Multilink connection to ####

ip address 10.82.163.1 255.255.255.252

ip unnumbered FastEthernet0/1

ip accounting output-packets

ip authentication mode eigrp 82 md5

ip authentication key-chain eigrp 82 YYYYYYY

ppp multilink

ppp multilink fragment disable

ppp multilink group 1

!

interface Serial0/0/0

description Connection to LAG

bandwidth 1544

no ip mroute-cache

no fair-queue

encapsulation ppp

ppp multilink

ppp multilink group 1

!

interface Serial0/1/0

description Connection to ####

bandwidth 1544

no ip mroute-cache

no fair-queue

encapsulation ppp

ppp multilink

ppp multilink group 1

no shut

!

interface Serial0/2/0

description Connection to ####

bandwidth 1544

no ip mroute-cache

no fair-queue

encapsulation ppp

no ip mroute-cache

no fair-queue

ppp multilink

ppp multilink group 1

no shut

!

interface Serial0/3/0

description Connection to ####

bandwidth 1544

no ip mroute-cache

no fair-queue

encapsulation ppp

ppp multilink

ppp multilink group 1

no shut

!



Router #2



interface Multilink1

ip address 10.82.163.2 255.255.255.252

description Multilink connection to &&&&

ip unnumbered FastEthernet0/1

ip accounting output-packets

ip authentication mode eigrp 82 md5

ip authentication key-chain eigrp 82 ZZZZZZZ

ppp multilink

ppp multilink fragment disable

ppp multilink group 1

!

interface Serial0/0/0

description Connection to &&&&

bandwidth 1544

no ip mroute-cache

no fair-queue

ppp multilink

ppp multilink group 1

!

interface Serial0/1/0

description Connection to &&&&

bandwidth 1544

no ip mroute-cache

no fair-queue

ppp multilink

ppp multilink group 1

no shut

!

interface Serial0/2/0

description Connection to &&&&

bandwidth 1544

no ip mroute-cache

no fair-queue

ppp multilink

ppp multilink group 1

no shut

!

interface Serial0/3/0

description Connection to &&&&

bandwidth 1544

no ip mroute-cache

no fair-queue

ppp multilink

ppp multilink group 1

no shut

!

I also set any static route that was pointing to a serial interface to point to multilink1.

Any suggestions?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
devang_etcom Thu, 06/01/2006 - 12:42
User Badges:
  • Gold, 750 points or more

hi,


what is the exact problem is???


packet dropping or multilink connection is not establishing.


regards

Devang

devang_etcom Thu, 06/01/2006 - 13:04
User Badges:
  • Gold, 750 points or more

hi,


if you are not able to ping further then it will be the issue of the internal network.


regards

Devang

Richard Burts Thu, 06/01/2006 - 12:56
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Nasir


I agree with Davang that you have provided some details on what you have done but not nearly enough detail about what the problem is. In addition to some detail of what is not working it would be helpful to have the output of show interface and of show ppp multilink.


Also I notice that both routers have both an IP address configured on the multilink interface and ip unnumbered on the interface. They should not both be on the same interface. I would suggest that you remove the ip unnumbered from both interfaces.


EDIT: it looks while I was writing my post that Nasir has provided additional information. From his response it seems that he can ping from one router to the other, so the link appears to be working satisfactorily. If he can not ping further than the other router it sounds like a routing issue.


First I would suggest post the output of show ip route from a router and see if routes from the other router have been learned. I am guessing that they have not.


If routes from the other router have not been learned then we need to investigate why. My first guess is that it may be an authentication problem. So I would suggest removing authentication from the config and see if things work better.


If that is not the problem then perhaps Nasir can provide some additional details.


HTH


Rick

devang_etcom Thu, 06/01/2006 - 12:53
User Badges:
  • Gold, 750 points or more

hi,


i am still confusing as you have confiugre interface multink with command ip address as well as ip unnumbered fastethernet ...what is logic behind this.


i think it will be much better to use the multilink virtual-templet.


rate the post if it helps


regards

Devang

Actions

This Discussion