×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Warning Message Related to Non-Secure Components!

Unanswered Question
Jun 10th, 2006
User Badges:

Hi There,


My CSS is configured to accept both HTTP and HTTPS requests. When accessing the secure logon page in my website, I receive a warning message related to non-secure components in the page, and the page flipps from HTTPS to HTTP.


I assume with CSS that the page should NOT flip to HTTP and should remain in secure format... Do you think that the warning message I'm receiving here is related to components in the page itself or is it something to do with the CSS?


Any idea on how to avoid this warning message from appearing? Appreciate your feedback.


Regards,

Haitham

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
skumar1969 Sun, 06/11/2006 - 15:37
User Badges:
  • Bronze, 100 points or more

Its a browser nature to alert the user that he is entering into a non-secure site/webpage. CSS got nothing to do with it.


Open IE browser go to 'Tools--> Internet Options--> Advanced--->Security' untick the option "Warn if changing between secure and non-secure modes".


Hope you should be okay now. Thanks.

haithamnofal Sun, 06/11/2006 - 23:55
User Badges:

Hi,


Thanks for your reply, I agree with you that by configuring the browser we can avoid this message, but actually we're a bank and it's un-feasible to ask 20,000 users to configure their browsers in this way.


Let me give you a good hint, it seems that the behaviour of my application is redirecting the HTTPS logon page to a non-secure page after logging. Is their a way to overwrite this on the CSS-level?


Thanks,

Haitham

Gilles Dufour Mon, 06/12/2006 - 01:00
User Badges:
  • Cisco Employee,

is the CSS doing the encryption and the server only doing plain HTTP ???

If so, all redirect from the server need to be translated by the CSS from HTTP into HTTPS.

There is a command called 'url-rewrite' for that.

You should be able to find all the documentation you need by searching this keyword.


Gilles.

haithamnofal Mon, 06/12/2006 - 01:08
User Badges:

Hi,


I applied this command and it solved the problem with the warning message:


ssl-server 100 urlrewrite 1 www.domainname.com sslport 443 clearport 80


Thanks,

Haitham

Actions

This Discussion