×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

I use Cisco IOS DHCP but I can not get the IP from manual binding.

Unanswered Question
Jun 18th, 2006
User Badges:

Could anybody help me? First of all, I have to tell that I just start to learn for Cisco switch, Cisco router.

I'm trying to automatically assign IP for switches which connect to router for some testing. The IP from automatic binding is assigned correctly but the IP from manual binding is not assigned to the specific switch.

Assume that I did the manual binding for switch A (IP : 192.168.0.60 MAC address 0013.5f0c.fec2) but when I check the assigned IP of switch A, the IP is not 192.168.0.60 but it is the IP from automatic binding pool (192.168.0.61).

How can I assign the IP from manual binding pool to the switch A? Please take a look at the configuration of the router as following.


!

ip subnet-zero

ip dhcp excluded-address 192.168.0.0 192.168.0.50

!

ip dhcp pool ts1pool

network 192.168.0.0 255.255.255.0

default-router 192.168.0.47

domain-name ts1domain.com

dns-server 192.168.0.1

lease 7

!

ip dhcp pool macc3

host 192.168.0.60 255.255.255.0

hardware-address 0013.5f0c.fec2

client-name macchiato_3

!

!

interface Ethernet0

ip address 192.168.0.47 255.255.255.0

!

interface Serial0

no ip address

shutdown

!




And this is the results from "sh ip dhcp binding" command


termserver1#sh ip dhcp binding

IP address Hardware address Lease expiration Type

192.168.0.60 0013.5f0c.fec2 Infinite Manual

192.168.0.61 0063.6973.636f.2d30. Jul 25 1993 02:35 AM Automatic

3031.332e.3566.3063.

2e66.6563.322d.566c.

3330


When I check at switch A, the IP 192.168.0.61 is assigned.

One more thing, please notice that actually MAC address of switch A is 0013.5f0c.fec2 but why it show

" 0063.6973.636f.2d30.3031.332e.3566.3063.2e66.6563.322d.566c.3330 " in "sh ip dhcp binding" command.


Help me please!!!!!

Thanks a lot.

-FILL-

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3.4 (5 ratings)
Loading.
Roberto Salazar Sun, 06/18/2006 - 11:10
User Badges:
  • Gold, 750 points or more

show version should actually tell you the switch's mac address, if this is a switch running IOS. and have you tried not putting the manual binding in a separate pool?

ssukpool Sun, 06/18/2006 - 23:13
User Badges:

Well, after I used "show version" command on switch A, I can get MAC address as following :

...

90K bytes of flash-simulated non-volatile configuration memory.

Base ethernet MAC Address : 00:13:5F:0C:FE:80

Motherboard assembly number : 73-9833-02

Motherboard serial number : FHH0913012Y

Motherboard revision number : 03

System serial number : FHH0913012Y

Hardware Board Revision Number : 0x01



Switch Ports Model SW Version SW Image

------ ----- ----- ---------- ----------

* 1 26 WS-CE500-24LC 12.2(0.0.232)SEG CE500-LANBASE-M


This MAC address is bound with specific IP (192.168.0.60)


But when I used "show ip int brief" command on the switch A, the IP from automatic binding was assigned (192.168.0.61) instead of manual binding as below :


Macchiato3#sh ip int brief

Interface IP-Address OK? Method Status Protocol

Vlan1 172.20.249.11 YES manual up down

Vlan30 192.168.0.61 YES DHCP up up

FastEthernet1 unassigned YES unset down down

FastEthernet2 unassigned YES unset up up

...


BTW, I have tried not putting the manual binding, so the automatic binding is assigned properly (I mean the switch A get any automatic IP from DHCP server properly).

However, I would like to test DHCP feature by using the specific IP to switch A , using automatic IP for others.

Please advise me.


Thanks,

-FILL-


olorunloba Mon, 06/19/2006 - 00:31
User Badges:
  • Silver, 250 points or more

Different physical interfaces on the switch have their unique mac addresses. You need to find out which interface the switch is using to talk to the router. One way to do this is to look for which interface is on the vlan 30.


Another thing you can do, is to use the mac address in the automatic binding for the manual binding.


For a list of all the mac addresses on the switch, issue the command sh mac address static.

Roberto Salazar Mon, 06/19/2006 - 13:57
User Badges:
  • Gold, 750 points or more

show interface vlan 30 would give you the mac-address for that SVI. what is the mac-address for interface vlan 30?

ssukpool Tue, 06/20/2006 - 10:15
User Badges:

After I have been trying to do, I get the information like this.


1). The interface Fa2 is on vlan 30.


2). When I use "show int vl 30", I get this info :


Macchiato3#sh int vl 30

Vlan30 is up, line protocol is up

Hardware is EtherSVI, address is 0013.5f0c.fec2 (bia 0013.5f0c.fec2)

Internet address is 192.168.0.62/24

MTU 1998 bytes, BW 1000000 Kbit, DLY 10 usec,


3). Right now all binding IP on router as following :


termserver1#sh ip dhcp binding

IP address Hardware address Lease expiration Type

192.168.0.60 0013.5f0c.fec2 Infinite Manual

192.168.0.62 0063.6973.636f.2d30. Aug 01 1993 10:13 AM Automatic

3031.332e.3566.3063.

2e66.6563.322d.566c.

3330


Same thing, the automatic binding IP is assigned to switch A (Macchiato3) instead of the manual binding IP.

So that I try to use the MAC address from automatic binding for manual binding, I get this error message :


termserver1(dhcp-config)#hardware-address 0063.6973.636f.2d30.3031.332e.3566.3063.2e66.6563.322d.566c.3330

% DHCP could not parse the hardware address. Check character 39 (.).


In other words, I use this MAC address, it's ok.


termserver1(dhcp-config)#hardware-address 0013.5f0c.fec2


4). When I use "sh mac address-table static", the information as following :


Macchiato3#sh mac address-table static

Mac Address Table

-------------------------------------------


Vlan Mac Address Type Ports

---- ----------- -------- -----

All 0100.0ccc.cccc STATIC CPU

All 0100.0ccc.cccd STATIC CPU

All 0180.c200.0000 STATIC CPU

All 0180.c200.0001 STATIC CPU

All 0180.c200.0002 STATIC CPU

All 0180.c200.0003 STATIC CPU

All 0180.c200.0004 STATIC CPU

All 0180.c200.0005 STATIC CPU

All 0180.c200.0006 STATIC CPU

All 0180.c200.0007 STATIC CPU

All 0180.c200.0008 STATIC CPU

All 0180.c200.0009 STATIC CPU

All 0180.c200.000a STATIC CPU

All 0180.c200.000b STATIC CPU

All 0180.c200.000c STATIC CPU

All 0180.c200.000d STATIC CPU

All 0180.c200.000e STATIC CPU

All 0180.c200.000f STATIC CPU

All 0180.c200.0010 STATIC CPU

All ffff.ffff.ffff STATIC CPU

Total Mac Addresses for this criterion: 20


5). When I use "sh mac address-table dynamic", the information as following :


Macchiato3#sh mac address-table dynamic

Mac Address Table

-------------------------------------------


Vlan Mac Address Type Ports

---- ----------- -------- -----

1 0002.b395.a3f0 DYNAMIC Fa1

1 0011.1100.256f DYNAMIC Fa1

1 0011.936b.6f0c DYNAMIC Fa1

30 000d.2818.ab97 DYNAMIC Fa2

30 0011.20df.6ec0 DYNAMIC Fa2

30 0011.955b.90d5 DYNAMIC Fa2

30 0013.462c.fb2e DYNAMIC Fa2

30 0013.462d.089b DYNAMIC Fa2

Total Mac Addresses for this criterion: 8



** If my info can not answer your questions, please teach me what you do about automatic binding and manual binding on the same


router.


Thanks a lot

-FILL-

Roberto Salazar Sat, 06/24/2006 - 16:00
User Badges:
  • Gold, 750 points or more

Hi,


Took me some time but I found why the switch is giving this client-id "0063.6973.636f.2d30.3031.332e.3566.3063.2e66.6563.322d.566c.3330 " and thus it does not match your hardware address and as a result it does not assing the static mac address.

From what I found, the dhcp server will look at the client indentifier in the dhcp

discover packet and use that, not the mac address. How do you know what the client

identifier is? You have to either use a sniffer or turn on debugs on the dhcp server.


*****************************************************

Here are the debugs on the dhcp server

****************************************************

Router4#debug ip dhcp server packet

Router4#debug ip dhcp server events

Router4#

*Dec 29 20:15:43.527: %OSPF-5-ADJCHG: Process 1, Nbr 3.3.3.3 on Ethernet0/0 from

LOADING to FULL, Loading Done

*Dec 29 20:16:27.479: DHCPD: DHCPDISCOVER received from client 0063.6973.636f.2d

61.6162.622e.6363.3030.2e30.3630.302d.4574.302f.30 through relay 10.1.1.1.

*Dec 29 20:16:27.479: DHCPD: Sending DHCPOFFER to client 0063.6973.636f.2d61.616

2.622e.6363.3030.2e30.3630.302d.4574.302f.30 (10.1.1.10).

*Dec 29 20:16:27.479: DHCPD: unicasting BOOTREPLY for client aabb.cc00.0600 to r

elay 10.1.1.1.

*Dec 29 20:16:27.619: DHCPD: DHCPREQUEST received from client 0063.6973.636f.2d6

1.6162.622e.6363.3030.2e30.3630.302d.4574.302f.30.

*Dec 29 20:16:27.619: DHCPD: Sending DHCPACK to client 0063.6973.636f.2d61.6162.

622e.6363.3030.2e30.3630.302d.4574.302f.30 (10.1.1.10).

*Dec 29 20:16:27.619: DHCPD: unicasting BOOTREPLY for client aabb.cc00.0600 to r

elay 10.1.1.1.

*Dec 29 20:16:57.419: DHCPD: checking for expired leases.

*Dec 29 20:18:57.431: DHCPD: checking for expired leases.


***********************************************************

Here is the config on the dhcp server. Notice the client id

***********************************************************


ip dhcp pool tes

network 10.1.1.0 255.255.255.0

default-router 10.1.1.1

!

ip dhcp pool host_test

host 10.1.1.10 255.255.255.0

client-identifier 0063.6973.636f.2d61.6162.622e.6363.3030.2e30.3630.302d.4574

.302f.30

!


The client identifier uses ASCII hex characters.

I you use an ascii hex to ascii symbol conversion chart you see the following.

There is a complete chart at

http://www.ascii.cl/index.htm

Cool, eh!

Tim Ryan



00 nul

63 c

69 i

73 s

63 c

6f o

2d -

-----------begin mac address---

30 0

30 0

30 0

35 5

2e .

33 3

31 1

33 3

65 e

2e .

39 9

63 c

30 0

30 0

------begin interface (swtich vlan1 = vl1 ; router = -et0/0) 2d -

56 V

6c l

31 1


Switch's real mac address = 0005.313e.9c00


client-identifier becomes


0063.6973.636f.2d30.3030.352e.3331.3365.2e39.6330.302d.566c.31

nul c i s c o - 0 0 0 5 . 3 1 3 e . 9 c 0 0 - v l 1


Got it?


Please rate all posts.

saxenapankaj7 Sat, 07/08/2006 - 10:42
User Badges:

Hi Could you please suggest the meaning of following error.


Internet 1.1.1.2 0 Incomplete ARPA


%OSPF-5-ADJCHG: Process 100, Nbr 1.2.2.3n FastEthernet0/0 from 2WAY to DOWN, Neighbor Down: Dead timer expired


Brgds

Pankaj

Roberto Salazar Sat, 07/08/2006 - 13:10
User Badges:
  • Gold, 750 points or more

Internet 1.1.1.2 0 Incomplete ARPA

>> Measn devices with ip address 1.1.1.2 is not responding to the router's ARP request, maybe the device had been taken out of the network or it's down.


%OSPF-5-ADJCHG: Process 100, Nbr 1.2.2.3n FastEthernet0/0 from 2WAY to DOWN, Neighbor Down: Dead timer expired

>> Means OSPF neighbor 1.2.2.3 on FE0/0 is not sending OSPF hello or this router is not receiving the OSPF hello.


Please rate all posts.

Actions

This Discussion