Auto QoS 3750 doesnt extend CoS 0 to PC

Unanswered Question
Jun 21st, 2006
User Badges:

Hi,


I just want to confirm that when configuring Autoqos see example below The switch 3750 doesnt remark the packets coming from the PC to CoS 0.


interface FastEthernet1/0/1

switchport access vlan 10

switchport voice vlan 20

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

mls qos trust device cisco-phone

mls qos trust cos

auto qos voip cisco-phone

spanning-tree portfast


And doing a


Switch(config)#interface fastEthernet 1/0/1


Switch(config-if)#switchport priority extend cos 0


Does not change the config to enforce the trust boundry to not trust marking from end devices.The config remains the same.



Is the only way to enforce the trust boundry to set up ports manually (or range)



interface FastEthernet1/0/20

switchport access vlan 20

switchport trunk encapsulation dot1q

switchport mode trunk

switchport voice vlan 10

spanning-tree portfast



Also when I add the following command it doesnt appear in the config



Switch(config-if)#switchport priority extend cos ?

<0-7> Priority for devices on appliance


Switch(config-if)#switchport priority extend cos 0

Switch(config-if)#



I also this this on CCO


mls qos trust device cisco-phone

Specify that the Cisco IP Phone is a trusted device.


You cannot enable both trusted boundary and auto-QoS (auto qos voip interface configuration command) at the same time; they are mutually exclusive


What does auto qos do if PC's are sending COS 5 traffic. It appears thought it stuffs them in the PQ is this correct?


If thats the case then AutoQos should never be used with a daisy chained device PC. If it is and the PC is marking packets with 802.1q CoS 5 the PQ is useless.


Would this be correct


Thanks


Allan

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
Aaron Harrison Wed, 06/21/2006 - 05:03
User Badges:
  • Super Bronze, 10000 points or more
  • Community Spotlight Award,

    Member's Choice, May 2015

Hi Allan


The switchport priority extend cos 0 command doesn't appear in the config becuase it's default on the 3750s. If you set it to anything other than 0 you'll see it.


You can verify the setting by viewing:


show int fa x/x/x switchport


The last few lines list the settings.


Hope this helps.


Aaron


Please rate helpful posts.

allanwells Wed, 06/21/2006 - 07:38
User Badges:

The Cisco documentation on 3750 QoS is allover the shop.


There is nothing to say that the appliance device is never trusted when autoqos is used.


I soppose I could span a port and sniff away

: )


Thanks Aaron the commands output last line says whats cooking.


Cheers

Aaron Harrison Wed, 06/21/2006 - 07:43
User Badges:
  • Super Bronze, 10000 points or more
  • Community Spotlight Award,

    Member's Choice, May 2015

Yup - also I can't really see how the trust would be broken by autoqos, it really seems to be just a batched up set of commands to get a standard QoS config...


The docs all say that if you want a custom QoS config with autoqos, then enable and configure autoqos first, and tweak it second.


So if you want the device trust, just check the current status using:


show mls qos interface f1/0/1


then put the commands in and check again.. I'd be surprised if it didn't work!


Aaron

Actions

This Discussion