×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Cisco 2800 Series and ISDN problems

Unanswered Question
Jun 23rd, 2006
User Badges:

Dears,


My company is using cisco routers as gateways conected through FXO and ISDN with Siemens HiPath PBX.

We have up and running twoo c2801 with ISND BRI coneted to PBX, but now we got more c2811 routers with ISDN BRI int. and I'm not enable to make calls through this devices.

Here you can see ISDN Status (which seams OK):


test#show isdn status

Global ISDN Switchtype = basic-qsig

ISDN BRI0/0/0 interface

******* Network side configuration *******

dsl 0, interface ISDN Switchtype = basic-net3

Layer 1 Status:

ACTIVE

Layer 2 Status:

TEI = 0, Ces = 255, SAPI = 0, State = TEI_ASSIGNED

Layer 3 Status:

0 Active Layer 3 Call(s)

Active dsl 0 CCBs = 0

The Free Channel Mask: 0x80000003

ISDN BRI0/0/1 interface

******* Network side configuration *******

dsl 1, interface ISDN Switchtype = basic-net3

Layer 1 Status:

ACTIVE

Layer 2 Status:

TEI = 0, Ces = 255, SAPI = 0, State = TEI_ASSIGNED

Layer 3 Status:

0 Active Layer 3 Call(s)

Active dsl 1 CCBs = 0

The Free Channel Mask: 0x80000003

Total Allocated ISDN CCBs = 0

When I try to make calls from PBX then I get this ERROR from Debug Isdn Q931:


*Jun 23 10:14:22.743: ISDN BR0/0/1 Q931: RX <- SETUP pd = 8 callref = 0x01

Bearer Capability i = 0x9090A3

Standard = CCITT

Transfer Capability = 3.1kHz Audio

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0x83

Progress Ind i = 0x8183 - Origination address is non-ISDN

Calling Party Number i = 0x0180, '108'

Plan:ISDN, Type:Unknown

*Jun 23 10:14:22.747: ISDN BR0/0/1 **ERROR**: CCBRI_Go: NO CCB Src->HOST call id 0xE, event 0x8 ces 1

*Jun 23 10:14:26.739: ISDN BR0/0/1 Q931: RX <- SETUP pd = 8 callref = 0x01

Bearer Capability i = 0x9090A3

Standard = CCITT

Transfer Capability = 3.1kHz Audio

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0x83

Progress Ind i = 0x8183 - Origination address is non-ISDN

Calling Party Number i = 0x0180, '108'

Plan:ISDN, Type:Unknown

*Jun 23 10:14:26.743: ISDN BR0/0/1 **ERROR**: CCBRI_Go: NO CCB Src->HOST call id 0xF, event 0x8 ces 1

*Jun 23 10:14:30.739: ISDN BR0/0/1 Q931: RX <- RELEASE_COMP pd = 8 callref = 0x01

Cause i = 0x81E6 - Recovery on timer expiry

*Jun 23 10:14:30.739: ISDN BR0/0/1 **ERROR**: L3_BadPeerMsg: event 0x5A cr 0x81 callid 0x0

*Jun 23 10:14:30.883: ISDN BR0/0/1 Q931: RX <- SETUP pd = 8 callref = 0x01

Bearer Capability i = 0x9090A3

Standard = CCITT

Transfer Capability = 3.1kHz Audio

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0x83

Progress Ind i = 0x8183 - Origination address is non-ISDN

Calling Party Number i = 0x0180, '108'

Plan:ISDN, Type:Unknown

*Jun 23 10:14:30.883: ISDN BR0/0/1 **ERROR**: CC_CHAN_GetIdleChanbri: All channels busy

*Jun 23 10:14:30.887: ISDN BR0/0/1 Q931: TX -> RELEASE_COMP pd = 8 callref = 0x81

Cause i = 0x82A2 - No circuit/channel available

*Jun 23 10:14:31.887: ISDN BR0/0/1 Q931: TX -> RELEASE_COMP pd = 8 callref = 0x81

Cause i = 0x82A2 - No circuit/channel available



After this attempt both channels are getting BUSY.


Any idea about this issue?


Thanks in advance...


Nazmi


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
anup.anand Fri, 06/23/2006 - 04:53
User Badges:
  • Silver, 250 points or more

There is a problem at Layer 2


Layer 2 Status:

TEI = 0, Ces = 255, SAPI = 0, State = TEI_ASSIGNED


It should have been


Layer 2 Status:

TEI = 0, Ces = 255, SAPI = 0, State =MULTIPLE_FRAMES_ESTABLISHED


Please check to make sure the ISDN Switch type is correct. Check this link for more details on ISDN Layer 2 troubleshooting.


http://www.cisco.com/en/US/tech/tk801/tk379/technologies_tech_note09186a0080094b77.shtml


Also verify which device should be the network side, the PBX or the router and configure the other device to be the user side.


Regards,


Anup




MEB-PR Mon, 06/26/2006 - 01:42
User Badges:

Thanks for Replay.


I made a mistake when copying isdn status.

I can make Layer 2 connection: (se below)


Global ISDN Switchtype = basic-net3

ISDN BRI0/1/0 interface

******* Network side configuration *******

dsl 2, interface ISDN Switchtype = basic-net3

Layer 1 Status:

ACTIVE

Layer 2 Status:

TEI = 0, Ces = 255, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED

Layer 3 Status:

0 Active Layer 3 Call(s)

Active dsl 2 CCBs = 0

The Free Channel Mask: 0x80000003


I noticed when Ces=255 it will not work.

I can manage somehow to make this work but ONLY when in LAYER 2 Ces=1.

When I change the router or ios or interface then it takes me hours to make it work and I still dont know what is going on.

Once again I manage every time to bring Layers UP (including Layer 2) but cannot make calls unless the Ces=1,


Any idea how to get Ces=1 ??????


Regards


Nazmi

kzeeshan Mon, 06/26/2006 - 03:24
User Badges:
  • Cisco Employee,

Hi,


Please check if you are not hitting CSCei13743.

Otherwise check with your Telco. The error you are getting is because of no channel is available to make a call on. There could be several reasons like SPID configuration, connectivity, incorrcet config and lastly a software bug.



Actions

This Discussion