×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

loop

Unanswered Question
Jun 23rd, 2006
User Badges:

hi guys,


I have edge switch 2950 connected to one of our core switch.


hub is connected to one of port in 2950 switch..


one end user by mistake did loop in the hub. which cause the layer 2 loop edge switch and core switch due trunk.


is there any control unnoticed cause like this...


note i have enabled bpdu and portfast globally expect trunk port..


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
gpulos Fri, 06/23/2006 - 05:53
User Badges:
  • Blue, 1500 points or more

bpdu guard, if that's what you mean, and portfast will not help the situation of creating a loop in a HUB connected to a catalyst.


can you be a little more clear. not sure what "...... which cause the layer 2 loop edge switch and core switch due trunk." means.


also, not sure what "....is there any control unnoticed cause like this... " means. please clarify.

Francois Tallet Fri, 06/23/2006 - 08:27
User Badges:
  • Gold, 750 points or more

The trunk is I guess between the 2950 and the core switch right?

The portfast configuration you did on the ports leading to the hub are enough to get a temporary loop. However, BPDUs should flow through the hub and it should not last forever.

I don't know what you mean by "I have enabled bpdu... globally". If this is bpdufilter, then you might consider removing it (even if we put some safeguard into global bpdufilter configuration that, I think, should prevent a permanent loop in your scenario).

If you want to be notified about such a case, you can enable bpduguard, that will complain about receiving a BPDU on a user port.

Regards,

Francois

kamalnathsingh Fri, 06/23/2006 - 08:49
User Badges:


Hi fancois,


U r right trunk is between 2950 to core switch...


yes port fast and bpdu guard enabled on the ports leading to the hub.



due physical loop in hub, packets are forward to leading hub it backed. those frames again forward to trunk port and forwarded to the core switch...


i would like to way to control the such failure.



jstoecker Fri, 06/23/2006 - 10:14
User Badges:
  • Silver, 250 points or more

So, are you saying the hub is connected to more than one port of the switch?


Or, are you saying that the hub has ports connected to itself (either directly or indirectly via other hubs)? Connecting a hub or hubs in a 'loop' is an incorrect configuration, as you now no doubt know.


Is this configuration something you are intentionally doing, or something your network users are doing?


As far as I know, there isn't any way for a switch to differentiate between a frame emitted from a workstation that's directly connected, and from a frame that has passed through a hub (setting aside the possibility that a directly connected workstation will likely be full-duplex).


John

Actions

This Discussion