Dialer Watch

Unanswered Question
Jun 28th, 2006
User Badges:

Hi all,


I am using ISDN as the backup for primary DSL line. I am plainning to use dialer watch to get the secondary line up when the primary link goes down. My edge router is configured with EIGRP for routing purpose.


So, what is the best practise like, do i need to add the secondary link's IP in EIGRP or is it acceptable to add the scondary link as a floating static route. Some one let me know which is the best practise to be followed.


Thanks


Rajesh

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
ariela Wed, 06/28/2006 - 05:47
User Badges:
  • Silver, 250 points or more

Hi,


with dialer watch it depends on what you have to "watch" on dialer watch-list


Example:

your spoke LAN subnet is 192.168.90.x/24

your hub LAN subnet is 192.168.30.x/24

the ISDN p2p subnet is 192.168.71.28/30


conf like that:


!

!

interface BRI0

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type xxxx

isdn static-tei 0

no cdp enable

ppp authentication chap

!

interface Dialer0

ip address 192.168.71.30 255.255.255.252

encapsulation ppp

dialer pool 1

dialer remote-name xxxxx

dialer string xxxxxx

dialer watch-group 2

dialer-group 1

ppp authentication chap

!

router eigrp 100

network 192.168.0.0 0.0.255.255

no auto-summary

!

ip route 192.168.30.0 255.255.255.0 Dialer0 254

!

access-list 101 deny eigrp any any

access-list 101 permit ip any any

dialer watch-list 2 ip 192.168.30.0 255.255.255.0

dialer watch-list 2 delay route-check initial 180

dialer watch-list 2 delay connect 30

dialer watch-list 2 delay disconnect 90

dialer-list 1 protocol ip list 101

!

!



more infos:

http://www.cisco.com/en/US/tech/tk801/tk133/technologies_tech_note09186a008009457d.shtml#floating_static_routes


Hope this helps

Regards

Andrea

sandipani Wed, 06/28/2006 - 11:21
User Badges:

Hi :


You can advertise in EIGRP, and declare the watched network in Dialer map command. But no need to add static route for that you can advertise the BRI ineterface in EIGRP.


it is like this : as an example.


interface bri0


! This is the secondary backup line


ip address 7.1.1.2 255.255.255.0


encapsulation ppp


dialer idle-timeout 5


! Use a dialer map for the IP address/network which is the same network as


! being watched.


dialer map ip 3.1.1.0 name remote router & primary link. 60079 broadcast


! Add a dialer map for remote end's IP address to make routing work over this interface.


dialer map ip 7.1.1.3 60079 broadcast


dialer-group 1


! Enable Dialer Watch on this interface.


dialer watch-group 1


ppp authentication chap



Regards

sandipani C

Network Admin Wipro technologies.





kradjesh13 Wed, 06/28/2006 - 18:28
User Badges:

Hi there,


Remote Sites

~~~~~~~~~~~~

interface BRI0/2/0

no ip address

encapsulation ppp

load-interval 30

dialer pool-member 2

isdn switch-type basic-net3

isdn send-alerting

ppp authentication chap


interface Dialer101

ip address 172.90.10.X 255.255.255.252

encapsulation ppp

dialer pool 2

dialer remote-name core_rtr

dialer string XXXXXXXXX

dialer watch-group 1

dialer-group 2

no cdp enable


router eigrp 76

redistribute connected

network 10.0.0.0


router eigrp 1

redistribute connected

network 172.90.0.0



ip route 0.0.0.0 0.0.0.0 172.90.10.X 200

ip route 172.90.10.X 255.255.255.255 BRI0/1/0 200


access-list 150 deny eigrp any any

access-list 150 permit ip any any


dialer watch-list 1 ip 10.1.0.0 255.255.0.0

dialer watch-list 1 ip 172.28.0.0 255.255.0.0

dialer watch-list 1 ip 10.160.0.0 255.255.0.0

dialer watch-list 1 delay route-check initial 180

dialer watch-list 1 delay connect 30

dialer watch-list 1 delay disconnect 90


dialer-list 1 protocol ip permit

dialer-list 2 protocol ip list 150


Core Router

~~~~~~~~~~~

router eigrp 1

network 172.90.0.0


The above is the configs which i used for Dialer Watch.


I am using 2 eigrp tables since, 2 core routers are found in the central office one for all DSL connections with EIGRP Autnomous no 72 and one for backup PRI links with Autnomous no 1.


The problem is, the ISDN backup fires up as soon as DSL line comes down. But once when the primary link comes up, the secondary link is also up inveriably and does not comes down even after certain period of time unless the line is physically pulled.


Is there any flaw in my above configs. Do i need to add any extra set of configs ???


Regards

Rajesh

sandipani Wed, 06/28/2006 - 18:47
User Badges:

Hi rajesh:


Please add this command

dialer watch-disable inside dialer watch command set.


Applies a disable time to the interface.


Hope this will work.


Sandipani C



kradjesh13 Thu, 06/29/2006 - 03:38
User Badges:

Hi Sandipani


I am going to try this tonight and let you know how it goes. Thank you very much for all u r help.


Which is good or best practice for dial backup. Dialer watch or Dialer map ?? Since, i came across many documents and in some they mention Dialer watch is good, but without any good illustration. So, can some one suggest which is the best, dialer watch or dial map???


Rajesh

sandipani Thu, 06/29/2006 - 18:26
User Badges:

Hi Rajesh:


ya you can go with dialer watch..


Bye


Sandipani

kradjesh13 Fri, 06/30/2006 - 01:27
User Badges:

Hi Sandipani,


I can enter the commadn, in bri 0/2/0 or in dialer interfaces.


I am also getting an error message like


Jun 30 09:32:44.852: ASSERTION FAILED: file "../chips/gt96k/gt96k_timer.c", lin

e 771


D't know what is the real cause of this message.


If u have any idea plz let me know.


Thanks for all u r help.


Rajesh

Actions

This Discussion