CTI OS CRASHES BECAUSE OF LOGOUT REASON CODE

Unanswered Question
Jul 6th, 2006
User Badges:

Hi,

I'm currently trying to set up some reason codes for 'Not Ready' and 'Logout' States. The 'Not Ready' reason codes seem to work fine but when I try to logout to test the logout reason codes, the CTI OS agent desktop just crashes. In the Agent Desktop Settings in ICM, if 'logout reason required' is unticked then it does not crash but then no reason codes appear either. Unfortunately, it is not providing any error messages or codes, so I can't troubleshooot properly. Using ICM 6 and CTI OS 6.0.0 sr3. Any help will be highly appreciated.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
sanjeev.thallik... Fri, 07/07/2006 - 04:50
User Badges:
  • Silver, 250 points or more

Funny. We are having the exact same issue at a client. One of my colleagues has a TAC case open on this with no apparent resolution yet. We will keep you posted and if you find out anything, let me know too. Thanks.

akinsolal Mon, 07/10/2006 - 03:38
User Badges:

Please could I have the bug toolkit ID that refers to your case, so that I can read up your fault synopsis.


Also, is there update yet?

adignan Tue, 07/11/2006 - 11:58
User Badges:
  • Blue, 1500 points or more

Export your Cisco Systems, Inc. Registry to a .txt file and see if you have a hidden blank registry key. See below for the issue we had. You couldn't see this blank key with Regedit but could see it in a .txt file or by using regedt32. We deleted the blank key using regedt32 and all is fine now.


[HKEY_LOCAL_MACHINE\SOFTWARE\Cisco Systems, Inc.\Ctios\CTIOS_HOLL\CTIOS1\Server\Agent\ReasonCodes\NotReady]

@=""

"Break"=dword:00000001

"Desk Work"=dword:00000002

"Lunch"=dword:00000004

"Meeting"=dword:00000005

"Personal"=dword:00000007

"Special Assignment"=dword:00000008

"Training"=dword:00000009

"End Of Day"=dword:00000003

"Out Call"=dword:00000006


please rate helpful posts.


adignan - berbee

akinsolal Tue, 07/11/2006 - 23:00
User Badges:

Excellent! You are a star! It works! Indeed there was a blank entry in the registry setting for the logout reason code.

Actions

This Discussion