bpdu doesn't cross wireless trunk

Unanswered Question
Jul 11th, 2006
User Badges:

I installed 2 bridges 1300 as a backup link. This link carry 5 vlans. Everything works except the spanning-tree. As soon as i establish the radio connection, i get a network loop for these vlans. The ports are in forward state from both switches on each side. Do you know any problem about spanning-tree bpdu crossing wireless link?


Thanks


Nuno Santos

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
oj88 Tue, 07/11/2006 - 18:18
User Badges:

Is STP explicitely enabled on the 1300? I hope you can post the config..

nuno.santos Wed, 07/12/2006 - 02:17
User Badges:

Here is the config. Lookinf to the bridge-group spanning-disabled, i also tried with it enabled without satisfatory results.


"

ip ssh source-interface BVI1

ip ssh version 2

no aaa new-model

!

dot11 ssid xxx

vlan 5

authentication open

authentication key-management wpa

infrastructure-ssid

wpa-psk ascii xxxxxx

!

!

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip redirects

no ip unreachables

no ip route-cache

!

encryption vlan 5 mode ciphers aes-ccm

!

ssid xxx

!

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0

power local cck 20

power local ofdm 10

no power client local

power client 20

channel 2412

station-role root bridge

!

interface Dot11Radio0.5

encapsulation dot1Q 5 native

no ip route-cache

bridge-group 1

!

interface Dot11Radio0.124

encapsulation dot1Q 124

no ip route-cache

bridge-group 124

bridge-group 124 spanning-disabled

!

interface Dot11Radio0.125

encapsulation dot1Q 125

no ip route-cache

bridge-group 125

bridge-group 125 spanning-disabled

!

interface Dot11Radio0.126

encapsulation dot1Q 126

no ip route-cache

bridge-group 126

bridge-group 126 spanning-disabled

!

interface Dot11Radio0.144

encapsulation dot1Q 144

no ip route-cache

bridge-group 144

bridge-group 144 spanning-disabled

!

interface Dot11Radio0.160

encapsulation dot1Q 160

no ip route-cache

bridge-group 160

bridge-group 160 spanning-disabled

!

interface FastEthernet0

no ip address

no ip redirects

no ip unreachables

no ip route-cache

hold-queue 80 in

!

interface FastEthernet0.5

encapsulation dot1Q 5 native

no ip route-cache

bridge-group 1

!

interface FastEthernet0.124

encapsulation dot1Q 124

no ip route-cache

bridge-group 124

!

interface FastEthernet0.125

encapsulation dot1Q 125

no ip route-cache

bridge-group 125

!

interface FastEthernet0.126

encapsulation dot1Q 126

no ip route-cache

bridge-group 126

!

interface FastEthernet0.144

encapsulation dot1Q 144

no ip route-cache

bridge-group 144

!

interface FastEthernet0.160

encapsulation dot1Q 160

no ip route-cache

bridge-group 160

!

interface BVI1

ip address xxx.xxx.xxx.xxx

no ip redirects

no ip unreachables

no ip route-cache

!

no ip http server

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

!

ip default-gateway aaa.aaa.aaa.aaa

!

control-plane

!

bridge 1 route ip

bridge 124 protocol ieee

bridge 125 protocol ieee

bridge 126 protocol ieee

bridge 144 protocol ieee

bridge 160 protocol ieee

!

!

!

line con 0

login local

line vty 0 4

login local

transport input telnet ssh

line vty 5 15

login local

transport input telnet ssh

!

"


Best regards


Nuno Santos

oj88 Wed, 07/12/2006 - 05:56
User Badges:

try adding "bridge 1 protocol ieee"

Actions

This Discussion

 

 

Trending Topics: Other Wireless Mobility

client could not be authenticated
Network Analysis Module (NAM) Products
Cisco 6500 nam
reason 440 driver failure
Cisco password cracker
Cisco Wireless mode