NAT with 2 global interfaces

Unanswered Question
Jul 17th, 2006
User Badges:

Hi all

recently i?ve purchased a 1801 for enable an isdn backup for my internet access via ADSL.

My first problem is that i need to use NAT to gain internet access from my network behind, but i don?t wnow how to proceed for enable it for ADSL and bri interfaces simultaneously because when the main ADSL interface goes down and bri comes up, i will need NAT too.

I?ve tried configuring the 2 static translations but only run the last configured and the first is ignored.

I can?t create a pool because my provider give?s me a dynamic ip address when the isdn link comes up


Any suggestion?


thank you very much


Miquel

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
desai.jaideep Mon, 07/17/2006 - 04:51
User Badges:
  • Gold, 750 points or more

Hi


You need to enable route map.



interface FastEthernet 0

ip nat inside


interface atm 0

ip nat outside

backup delay 1 1

backup interface Dialer 1



interface BRI 0

no ip address

dialer rotary-group 1


interface Dialer 1

ip nat outside


access-list 1 permit

dialer-list 1 protocol ip permit


ip nat inside source route-map interface 0 overload

ip nat inside source route-map Dialer interface Dialer 1 overload


route-map permit 10

match ip address 1

match interface 0

route-map Dialer permit 10

match ip address 1

match interface Dialer 1


ip route 0.0.0.0 0.0.0.0 0

ip route 0.0.0.0 0.0.0.0 Dialer 1



Regards


JD

Actions

This Discussion