×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Campus Manager 4.0.5 - Device Discovery and Campus Data Collection

Unanswered Question

Hi,


I?m using Campus Manager 4.0.5. I discover devices and they are marked as "unreacheable" so I can?t import these ones, to Campus Manager.


I verify the CDP configuration, the SNMP Community, the seed and the data collection filters and all these parameters are OK, so, what else can I verify?.


Best Regards.


Thanks !!!


Nuria

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
David Stanford Tue, 08/01/2006 - 05:04
User Badges:
  • Cisco Employee,

If they are unreachable then they aren't snmp reachable from CM. Can you use the snmpwalk tool in Device Center and try to walk the object sysObjectID? Do you get a response?


Any pix firewall in between server and devices?

No, I don?t get a response. It appears the following message "Failed to snmpwalk the device. Please check your community string and starting OID, and try again". However the community is OK and there is nothing between the devices and the CiscoWorks.


The devices that I want to discover are:


C1700-BNR2SY7-M, Version 12.2(16.4)T


The SNMP Configuration is:


snmp-server community RO

snmp-server community RW

snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart

snmp-server enable traps tty

snmp-server enable traps frame-relay

snmp-server enable traps frame-relay subif

snmp-server enable traps config

snmp-server host public


And the Campus Manager discovers them, but the are marked as "unreachable".


Thanks !!!


Best Regards


Nuria

David Stanford Tue, 08/01/2006 - 05:45
User Badges:
  • Cisco Employee,

If you get failed to snmpwalk the device then there are some communication issues between the device and the server. Are you using the default string that appears in the snmpwalk utility? Can you try editing it and typing in what is on the device?


If snmpwalk fails then campus will not discover the devices properly. There are some snmp issues here.

rdanevich Tue, 08/01/2006 - 06:48
User Badges:

If you can verify the Configurations via Telnet then it is reachable. Since SNMP is failing simply try re-writing the snmp community strings. This has also happened to me and that's what fixed it, strange but true!

David Stanford Tue, 08/01/2006 - 06:52
User Badges:
  • Cisco Employee,

Telnet reachable won't allow the device to be discovered by Campus Manager. It may fetch configs in RME, but it has to be snmp reachable for CM to show it properly.

rdanevich Tue, 08/01/2006 - 07:01
User Badges:

I understand what you're saying. I'm just saying "unreachable" is a bit mis-leading. I agree there's an snmp issue, re-writing the strings has worked for me in the past.


On my system I've noticed that I sometimes (often) get the "unreachable" status even though every thing is configured correctly. What I mean is, sometimes I go from reachable status to unreachable status, next discovery will be reachable again. It's as if snmp is timeing out on me for some reason.

David Stanford Tue, 08/01/2006 - 07:05
User Badges:
  • Cisco Employee,

True that it is not totally unreachable, but for the context of Campus Manager it has to be snmp reachable.


If there are timeout issues, you can try editing your snmp settings to increase the snmp timeout value to see if this makes any difference.

rdanevich Thu, 08/10/2006 - 12:37
User Badges:

Well I just had a similar situation! Added an old C2924XL switch to my network. Device Discovery found it but marked it as unreachable. Took my own advice and re-wrote the SNMP community strings (several times), no help!


I verified that I was able to do an SNMP-walk. I even let two days pass by and let CiscoWorks run it's default schedule, it still wouldn't show up.


Finally I decided to add it manually in Device Management of Common Services. Browsed to the switch's device type and added the IP address. It didn't show up in Campus Manager or RME or in the pre-deployed folder of RME in Device Management of Common Services. (In the past it would immediately show up after manually adding it) It's as if it got lost in cyber-space.


Now that I manually added it (even though it's M.I.A.) I ran a new Device Discovery. It now shows up as reachable and Campus Data Collection put it on the topology map.


I don't know why this happened but this is a work-around that has worked for me.


Hope this helps!

Actions

This Discussion