2924-XL -problem !!!

Unanswered Question
Aug 8th, 2006
User Badges:

Hi!


I have a network with only 2 2924 connected together so I get 48 ports.

The problem: The network was getting slow and it stopped for a while, then it was OK for a while. Up and down. Then I replaced the 2 2924's with a simple 3com and then it was working fine again! I keep getting messages on the 2924-switches: "Fastethernet x/x relearning xxxx addrs per min". And "Fastethernet x/x experiencing errors". What is wrong?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
abhishek_nandavat Tue, 08/08/2006 - 00:27
User Badges:
  • Silver, 250 points or more

Hi,


Seems like the FastEthernet port of yours is being made to learn too many MAC addresses in a min, What is connected to that port? Can you post the running configuration of the port on which you got the error?


Regards,

AbhisheK

globalnettech Tue, 08/08/2006 - 01:19
User Badges:
  • Silver, 250 points or more

Hello,


in addition to the other post, what do you have connected to the port that is giving you the errors ?


Regards,


GNT

ttkmm Tue, 08/08/2006 - 02:20
User Badges:

The config is this:


Current configuration:

!

version 12.0

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname switch1

!

enable secret xxx

!

!

!

!

!

!

ip subnet-zero

!

!

interface FastEthernet0/2

!

interface FastEthernet0/3

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface VLAN1

ip address 10.3.0.250 255.255.255.0

no ip directed-broadcast

ip nat outside

no ip route-cache

!

ip default-gateway 10.3.0.1

snmp-server engineID local xxx

snmp-server community private RW

snmp-server community public RO

!

line con 0

transport input none

stopbits 1

line vty 0 4

password xxxxxx

login

line vty 5 15

password xxxxxx

login

!

end



===============X====================


On these port I have modems with lines to different sites. On those sites I have a hub, a PC and/or some other terminal.


Regards,

KMM

globalnettech Tue, 08/08/2006 - 02:30
User Badges:
  • Silver, 250 points or more

Hello,


which port are you using to connect to the other switch, and which ports are you getting the errors on ?


Regards,


GNT

ttkmm Tue, 08/08/2006 - 02:37
User Badges:

Hi!

I am using port 24 for the other switch to get up to 48 ports.

I get the errors on Fastethernet 0/1, 0/3, 0/22 and some others.

Mayby there could be something with the modems/lines?

Line speed 64kbit.


Edison Ortiz Tue, 08/08/2006 - 06:52
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

It may be a sign of duplex mismatch. Are you forcing the speed/duplex setting on the modem's LAN interface ? Your cisco interface is set to auto/auto and that's the setting the modems should have.

ttkmm Tue, 08/08/2006 - 21:57
User Badges:

But then why can a "stupid" 3com with no config work fine?


Is it possible to stop arps from coming into the switch?

Edison Ortiz Wed, 08/09/2006 - 05:39
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

The cisco switch has more advanced error detection techniques than a unmanaged 3COM switch.


Can you please post the SH LOG where it contains the error verbatim ?


Thanks


ttkmm Wed, 08/09/2006 - 23:41
User Badges:

This is a little piece of the log file.



Log Buffer (4096 bytes):

1-ADDR_FLAP: FastEthernet0/3 relearning 31 addrs per min

03:06:19: %LINK-3-UPDOWN: Interface FastEthernet0/24, changed state to down

03:06:20: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/24, changed state to down

03:06:25: %LINK-3-UPDOWN: Interface FastEthernet0/24, changed state to up

03:06:26: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/24, changed state to up

03:07:10: %RTD-1-ADDR_FLAP: FastEthernet0/5 relearning 19 addrs per min

03:08:10: %RTD-1-ADDR_FLAP: FastEthernet0/3 relearning 6 addrs per min

03:11:30: %RTD-1-ADDR_FLAP: FastEthernet0/24 relearning 7 addrs per min

03:12:30: %RTD-1-ADDR_FLAP: FastEthernet0/7 relearning 65 addrs per min


jackyoung Wed, 08/09/2006 - 23:49
User Badges:
  • Gold, 750 points or more

Please check below link :


http://www.cisco.com/en/US/products/hw/switches/ps637/prod_release_note09186a0080099d1a.html



It explained :


ADDR_FLAP, RTD, LOG_ALERT, 0, "%s relearning %d addrs per min


Explanation

Normally, MAC addresses are learned once on a port. Occasionally, when a switched network reconfigures, due to either manual or STP reconfiguration, addresses learned on one port are relearned on a different port. However, if there is a port anywhere in the switched domain that is looped back to itself, addresses jump back and forth between the real port and the port that is in the path to the looped back port.


Action

Determine the real path (port) to the MAC address. Use the debug ethernet-controller addr privileged EXEC command to see the alternate path-port on which the address is being learned. Go to the switch attached to that port. Note that the show cdp neighbors privileged EXEC command is useful in determining the next switch. Repeat this procedure until you find the port that is receiving what it is transmitting, and remove that port from the network.



Please follow the action and try to find out the device which create the problem.


Hope this helps.


globalnettech Thu, 08/10/2006 - 00:07
User Badges:
  • Silver, 250 points or more

Hello,


not sure if that makes a difference, but since you seem to have only one uplink between the switches, try and disable spanning tree alltogether on both switches:


no spanning-tree vlan 1


You could try and configure the ports connecting both switches as trunk ports, e.g.:


interface FastEthernet0/24

switchport mode trunk

switchport trunk encapsulation isl


Regards,


GNT

ttkmm Thu, 08/10/2006 - 02:37
User Badges:

It seems like I have found the problem!

In the modem on the other side, the ethernetport there, seems to have problems. I know nothing is connected there...

So after disconnecting the 3-4 modem, it got up&running nice again!


But I need help to debug trafic going in/out the fastethernet ports.

Any recommendations?

I think there still are som suspicious trafic...

Fast Ethernet 0/7 relearning 21 addrs per min


These error message signify that a MAC address moves consistently between different ports. These error messages are only applicable on the Catalyst 2900XL and 3500XL switches. The messages can indicate that two or more HSRP routers have become active. The messages can indicate the source of an STP loop, duplicated frames, or reflected packets.

use debug ethernet-controller address


The ports that the debug command references are off by one. For example, port 0 is Fast Ethernet 0/1. The error messages indicate the flap of a MAC address between ports 5 and 34 on the respective switch.


Note: The message RTD-1-ADDR_FLAP can be incorrect. Refer to these Cisco bug IDs in order to rule out this possibility:


CSCdp81680 ( registered customers only) ?Incorrect RTD-1-ADDR_FLAP message


CSCds27100 ( registered customers only) and CSCdr30113 ( registered customers only) ?Fast EtherChannel issues cause RTD-1-ADDR_FLAP


The most common causes for the move of MAC addresses are spanning tree problems or physical layer problems. When you troubleshoot this error message, complete these steps:


Note: Also complete the steps in the HSRP Troubleshooting Modules for CatOS Switches section of this document.



Determine the correct source (port) of the host MAC address.


Disconnect the port that should not source the host MAC address.


Document the STP topology on a per-VLAN basis and check for STP failure.


Verify the port channeling configuration.


An incorrect port channel configuration can result in the flap of error messages by the host MAC address. This is because of the load-balancing nature of port channeling.


check the following link for more info


http://www.cisco.com/en/US/tech/tk648/tk362/technologies_tech_note09186a0080094afd.shtml




Actions

This Discussion