Multicast Routing across VLANs with C3560G-24TS-E(L3) and 2950T(L2)

Unanswered Question
Aug 10th, 2006
User Badges:

First off what limited experience I have have with imaging and multicasting has had to do with single VLAN or WAN implementations of Multicast services.


My configuration is as follows:


3560G (Acting as the gateway for VLANs 10, 100-1006, 200-206 and 300) with IP and Multicast routing enabled


5 x 2950T each with a 1Gig link back to the 3560 in 802.1q trunking mode with all VLANs allowed across the trunk


My VLANs each exist on multiple switches.


My 3560 config is as follows:


!

no aaa new-model

clock timezone eastern -5

ip subnet-zero

ip routing

!

ip multicast-routing distributed

!

password encryption aes

!

!

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

!

interface Loopback0

no ip address

!

___________

Physical Interfaces removed

___________

!

interface Vlan1

no ip address

shutdown

!

interface Vlan10

ip address 10.83.176.129 255.255.255.128

ip helper-address 10.83.176.150

ip pim dense-mode

!

interface Vlan30

no ip address

!

interface Vlan100

ip address 10.83.177.1 255.255.255.0

ip helper-address 10.83.176.150

ip pim dense-mode

!

interface Vlan101

ip address 10.83.178.1 255.255.255.0

ip helper-address 10.83.176.150

ip pim dense-mode

!

interface Vlan102

ip address 10.83.179.1 255.255.255.0

ip helper-address 10.83.176.150

ip pim dense-mode

!

interface Vlan103

ip address 10.83.180.1 255.255.255.0

ip helper-address 10.83.176.150

ip pim dense-mode

!

interface Vlan104

ip address 10.83.181.1 255.255.255.0

ip helper-address 10.83.176.150

ip pim dense-mode

!

interface Vlan105

ip address 10.83.182.1 255.255.255.0

ip helper-address 10.83.176.150

ip pim dense-mode

!

interface Vlan106

ip address 10.83.183.1 255.255.255.0

ip helper-address 10.83.176.150

ip pim dense-mode

!

interface Vlan200

ip address 10.83.184.1 255.255.255.0

ip helper-address 10.83.176.150

no ip redirects

ip pim dense-mode

!

interface Vlan201

ip address 10.83.185.1 255.255.255.0

ip helper-address 10.83.176.150

ip pim dense-mode

!

interface Vlan202

ip address 10.83.186.1 255.255.255.0

ip helper-address 10.83.176.150

ip pim dense-mode

!

interface Vlan203

ip address 10.83.187.1 255.255.255.0

ip helper-address 10.83.176.150

ip pim dense-mode

!

interface Vlan204

ip address 10.83.188.1 255.255.255.0

ip helper-address 10.83.176.150

ip pim dense-mode

!

!

interface Vlan205

ip address 10.83.189.1 255.255.255.0

ip helper-address 10.83.176.150

ip pim dense-mode

!

interface Vlan206

ip address 10.83.190.1 255.255.255.0

ip helper-address 10.83.176.150

ip pim dense-mode

!

interface Vlan300

ip address 10.83.191.1 255.255.255.0

ip helper-address 10.83.176.150

ip pim dense-mode

!

router eigrp 100

redistribute connected

redistribute static

network 10.83.176.0 0.0.15.255

auto-summary

!

ip classless

ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/24

ip http server



Example of one of the 2950 Configs:


!

ip subnet-zero

!

!

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

!

!

!

!

interface FastEthernet0/1

switchport access vlan 10

speed 100

duplex full

spanning-tree portfast

!

!

interface GigabitEthernet0/1

switchport access vlan 10

switchport mode trunk

switchport nonegotiate

speed 1000

duplex full

!

interface GigabitEthernet0/2

switchport access vlan 10

!

interface Vlan1

no ip address

no ip route-cache

shutdown

!

interface Vlan10

ip address 10.83.176.130 255.255.255.128

no ip route-cache

!

interface Vlan100

no ip address

no ip route-cache

shutdown

!

ip http server




At this point I am unable to see multicast offered by a multicast image server and I am also unable to see bonjour offered printers across VLANS. I am clearly missing something and I hope that someone will have a quick answer for this issue.



Thanks,

Josh


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Roberto Salazar Thu, 08/10/2006 - 10:33
User Badges:
  • Gold, 750 points or more

Can you tell us where the image server is coming from? First the router have to build the source tree, then the shared tree, then the SPT. so, knowing the topology and the location of where the source is coming from is important. Knowing that, you will be able to look at the following:

1. show ip mroute >> this will tell you whether there is a (*,G) entry and if the interface going to the receiver on the (S,G) are forwading or not. This will eliminate if we need to be troubleshooting at Layer 3 or we need to look at Layer 2 igmp. So, can you gather these information?

1. Topology, show where the server srving the image and the receiver are connected.

2. show ip mroute

3. show ip igmp group this will show if there are reports coming from that subnet having problem.


Please rate helpful posts.

cratejockey Thu, 08/10/2006 - 10:45
User Badges:

No problem:


The Server (source) is connected to the 3560 on Interface Gig0/1 in VLAN 10 (10.83.176.128 as address 10.83.176.150)


1.

IP Multicast Routing Table

Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,

L - Local, P - Pruned, R - RP-bit set, F - Register flag,

T - SPT-bit set, J - Join SPT, M - MSDP created entry,

X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,

U - URD, I - Received Source Specific Host Report, Z - Multicast Tunnel

Y - Joined MDT-data group, y - Sending to MDT-data group

Outgoing interface flags: H - Hardware switched, A - Assert winner

Timers: Uptime/Expires

Interface state: Interface, Next-Hop or VCD, State/Mode


(*, 239.255.255.253), 00:59:32/stopped, RP 0.0.0.0, flags: DC

Incoming interface: Null, RPF nbr 0.0.0.0

Outgoing interface list:

Vlan10, Forward/Dense, 00:59:32/00:00:00


(10.83.176.137, 239.255.255.253), 00:02:57/00:00:55, flags: PT

Incoming interface: Vlan10, RPF nbr 0.0.0.0

Outgoing interface list: Null


(*, 239.255.255.250), 00:59:16/00:02:04, RP 0.0.0.0, flags: DC

Incoming interface: Null, RPF nbr 0.0.0.0

Outgoing interface list:

Vlan100, Forward/Dense, 00:59:16/00:00:00


(*, 224.77.2.121), 00:52:52/stopped, RP 0.0.0.0, flags: DP

Incoming interface: Null, RPF nbr 0.0.0.0

Outgoing interface list: Null


(10.83.176.150, 224.77.2.121), 00:52:52/00:02:54, flags: PT

Incoming interface: Vlan10, RPF nbr 0.0.0.0

Outgoing interface list: Null


(*, 224.0.1.60), 00:59:11/00:02:06, RP 0.0.0.0, flags: DC

Incoming interface: Null, RPF nbr 0.0.0.0

Outgoing interface list:

Vlan100, Forward/Dense, 00:59:11/00:00:00


(*, 224.0.1.40), 00:59:35/00:02:04, RP 0.0.0.0, flags: DCL

Incoming interface: Null, RPF nbr 0.0.0.0

Outgoing interface list:

Vlan10, Forward/Dense, 00:59:35/00:00:00

2.

sh ip mroute 224.77.2.121

IP Multicast Routing Table

Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,

L - Local, P - Pruned, R - RP-bit set, F - Register flag,

T - SPT-bit set, J - Join SPT, M - MSDP created entry,

X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,

U - URD, I - Received Source Specific Host Report, Z - Multicast Tunnel

Y - Joined MDT-data group, y - Sending to MDT-data group

Outgoing interface flags: H - Hardware switched, A - Assert winner

Timers: Uptime/Expires

Interface state: Interface, Next-Hop or VCD, State/Mode


(*, 224.77.2.121), 01:03:18/stopped, RP 0.0.0.0, flags: DC

Incoming interface: Null, RPF nbr 0.0.0.0

Outgoing interface list:

Vlan10, Forward/Dense, 00:06:17/00:00:00


(10.83.176.150, 224.77.2.121), 01:03:18/00:02:59, flags: PT

Incoming interface: Vlan10, RPF nbr 0.0.0.0

Outgoing interface list: Null


3.

GE_3560_1#sh ip igmp group 224.77.2.121

IGMP Connected Group Membership

Group Address Interface Uptime Expires Last Reporter

224.77.2.121 Vlan10 00:06:55 00:02:08 10.83.176.140


Ok I have ammended my initial post. I think that I figured out the group address. If 224.77.2.121 isnt what you were looking for let me know.


Thanks,

Josh

Roberto Salazar Thu, 08/10/2006 - 13:59
User Badges:
  • Gold, 750 points or more

hmm, you did not not say which vlan is not recieving the mcast stream but from the output you've provided:

(10.83.176.150, 224.77.2.121), 01:03:18/00:02:59, flags: PT

Incoming interface: Vlan10, RPF nbr 0.0.0.0

Outgoing interface list: Null


3.

GE_3560_1#sh ip igmp group 224.77.2.121

IGMP Connected Group Membership

Group Address Interface Uptime Expires Last Reporter

224.77.2.121 Vlan10 00:06:55 00:02:08 10.83.176.140


mroute shows that it's not forwarding on vlan 10 but that's normal it's where the source is coming from, there is no need for L3 mcast. and the igmp roup tells me there is only one host requesting for the stream which is host with ip address 10.83.176.140. The output looks normal, what is the issue?



cratejockey Thu, 08/10/2006 - 14:14
User Badges:

The issue is that only VLAN 10 clients can see multicast traffic. I need my entire network to be able to see multicast traffic for Bonjour and Netimaging via Multicast. I have enabled ip igmp snooping from global config on the 3650 and I am getting more mroute info as follows.


IP Multicast Routing Table

Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,

L - Local, P - Pruned, R - RP-bit set, F - Register flag,

T - SPT-bit set, J - Join SPT, M - MSDP created entry,

X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,

U - URD, I - Received Source Specific Host Report, Z - Multicast Tunnel

Y - Joined MDT-data group, y - Sending to MDT-data group

Outgoing interface flags: H - Hardware switched, A - Assert winner

Timers: Uptime/Expires

Interface state: Interface, Next-Hop or VCD, State/Mode


(*, 239.255.255.253), 04:32:09/00:02:59, RP 0.0.0.0, flags: DC

Incoming interface: Null, RPF nbr 0.0.0.0

Outgoing interface list:

Vlan10, Forward/Dense, 00:04:09/00:00:00


(*, 239.255.255.250), 04:31:53/00:01:58, RP 0.0.0.0, flags: DC

Incoming interface: Null, RPF nbr 0.0.0.0

Outgoing interface list:

Vlan100, Forward/Dense, 04:31:53/00:00:00


(*, 224.0.1.60), 04:31:47/00:02:54, RP 0.0.0.0, flags: DC

Incoming interface: Null, RPF nbr 0.0.0.0

Outgoing interface list:

Vlan10, Forward/Dense, 00:23:26/00:00:00

Vlan201, Forward/Dense, 00:29:15/00:00:00

Vlan100, Forward/Dense, 04:31:47/00:00:00


(*, 224.0.1.40), 04:32:10/00:02:55, RP 0.0.0.0, flags: DCL

Incoming interface: Null, RPF nbr 0.0.0.0

Outgoing interface list:

Vlan10, Forward/Dense, 04:32:10/00:00:00



However as stated above I am still not able to see multicast traffic generated on any subnet on any other subnet but its own.


Thanks for the help so far I hope you stick with me on, this multicast issue is really killing this project.


thanks.

Roberto Salazar Thu, 08/10/2006 - 14:54
User Badges:
  • Gold, 750 points or more

Like I said, there is only one requester for that mcast traffic. No report to stream.


GE_3560_1#sh ip igmp group 224.77.2.121

IGMP Connected Group Membership

Group Address Interface Uptime Expires Last Reporter

224.77.2.121 Vlan10 00:06:55 00:02:08 10.83.176.140



Multicast will not just inadvertantly send mcast traffic to any segment. there must be a report or a join coming from the host. For the particular group you've captured there is one one host that sent a join and that is from the host with ip address 10.83.176.140.


I will assist you torubleshooting but you need to give me details.

1. Let's start with one vlan, which vlan is not able to get the stream from 224.77.2.121. 2. Select a host to test from that vlan and tell me what switch it is connected to and how it (the switch that the host connects to) connects to the 3560.

3. From the switch where the host used for testing do the following:

show ip igmp snooping vlan #

show ip igmp group

show ip igmp mrouter


Let start from there, I hope I am clear with the procedure.

cratejockey Thu, 08/10/2006 - 16:04
User Badges:

1. The stream is initiated on VLAN 10 (10.83.176.128 255.255.255.128). The listener is in VLAN 100 (10.83.177.0 255.255.255.0). The switch connects via Cat5 from Gig 0/1 onf the 2950 to Gig 0/23 on the 3560. Both ends of the connection are configured to 100 Full, set as trunks using 802.1x trunking with all vlans allowed accross the trunk. The client is on FE 0/11 of the 2950.


3.


show ip igmp snooping vlan 10 Results:

GE_3560_1#show ip igmp snooping vlan 10

Global IGMP Snooping configuration:

-----------------------------------

IGMP snooping : Enabled

IGMPv3 snooping (minimal) : Enabled

Report suppression : Enabled

TCN solicit query : Disabled

TCN flood query count : 2

Last Member Query Interval : 1000


Vlan 10:

--------

IGMP snooping : Enabled

IGMPv2 immediate leave : Disabled

Explicit host tracking : Enabled

Multicast router learning mode : pim-dvmrp

Last Member Query Interval : 1000

CGMP interoperability mode : IGMP_ONLY


show ip igmp snooping vlan 100 Results:

GE_3560_1#show ip igmp snooping vlan 100

Global IGMP Snooping configuration:

-----------------------------------

IGMP snooping : Enabled

IGMPv3 snooping (minimal) : Enabled

Report suppression : Enabled

TCN solicit query : Disabled

TCN flood query count : 2

Last Member Query Interval : 1000


Vlan 100:

--------

IGMP snooping : Enabled

IGMPv2 immediate leave : Disabled

Explicit host tracking : Enabled

Multicast router learning mode : pim-dvmrp

Last Member Query Interval : 1000

CGMP interoperability mode : IGMP_ONLY


show ip igmp group 224.77.2.121 Results:

Group 224.77.2.121 not found


show ip igmp mrouter Results: did not exist, however ip igmp snooping mrouter does and returned:

GE_3560_1#sh ip igmp snooping mrouter

Vlan ports

---- -----

10 Router

100 Router

101 Router

102 Router

103 Router

104 Router

105 Router

106 Router

200 Router

201 Router

202 Router

203 Router

204 Router

205 Router

206 Router

300 Router



For what its worth 224.77.2.121 is the Multicast group that we are broadcasting our image on at this moment. I do not see this group anywhere in my multicast routes.


Thanks for your ongoing help.


Roberto Salazar Thu, 08/10/2006 - 16:17
User Badges:
  • Gold, 750 points or more

maybe I was not clear but I ask for the following:

1. Let's start with one vlan, which vlan is not able to get the stream from 224.77.2.121. 2. Select a host to test from that vlan and tell me what switch it is connected to and how it (the switch that the host connects to) connects to the 3560.

3. From the switch where the host used for testing do the following:

show ip igmp snooping vlan #

show ip igmp group

show ip igmp mrouter



you gave me the right output but from the wrong switch, you should capture this output from the 2950 becuase you said "The client is on FE 0/11 of the 2950."

cratejockey Thu, 08/10/2006 - 16:26
User Badges:

1. The listener is in VLAN 100 (10.83.177.0 255.255.255.0). The switch connects via Cat5 from Gig 0/1 on the 2950 to Gig 0/23 on the 3560.


2.

show ip igmp snooping vlan 100 Results from 2950:

GE_2950_1#show ip igmp snooping vlan 100

Global IGMP Snooping configuration:

-----------------------------------

IGMP snooping : Enabled

IGMPv3 snooping (minimal) : Enabled

Report suppression : Enabled

TCN solicit query : Disabled

TCN flood query count : 2

Last member query interval : 1000


Vlan 100:

--------

IGMP snooping : Enabled

Immediate leave : Disabled

Multicast router learning mode : pim-dvmrp

Source only learning age timer : 10

Last member query interval : 1000

CGMP interoperability mode : IGMP_ONLY


show ip igmp group : Does not exist however sh ip igmp group does:

GE_2950_1#sh ip igmp snooping group

Vlan Group Version Port List

---------------------------------------------------------

10 224.0.1.40 v2 Gi0/1

102 224.0.1.60 v1 Fa0/38, Fa0/40, Fa0/43, Fa0/47


show ip igmp mrouter Results on 2950: Does not exist however sh ip igmp snooping mrouter returns


GE_2950_1#sh ip igmp snooping mrouter

Vlan ports

---- -----

10 Gi0/1(dynamic)

100 Gi0/1(dynamic)

101 Gi0/1(dynamic)

102 Gi0/1(dynamic)

103 Gi0/1(dynamic)

104 Gi0/1(dynamic)

105 Gi0/1(dynamic)

106 Gi0/1(dynamic)

200 Gi0/1(dynamic)

201 Gi0/1(dynamic)

202 Gi0/1(dynamic)

203 Gi0/1(dynamic)

204 Gi0/1(dynamic)

205 Gi0/1(dynamic)

206 Gi0/1(dynamic)

300 Gi0/1(dynamic)



Thanks


Roberto Salazar Thu, 08/10/2006 - 16:40
User Badges:
  • Gold, 750 points or more

2950 knows where the mrouter ports shoould be and so it knows where to forward the igmp join that the listener generates when it wants to subscribe to that group address. Now, you have to make sure that the group address is correct and if even the listener is sending a join. without a join the sender will never send, otherwise, it might as well just use broadcast. you have a couple of ways of troubleshooting this. 1. Take a sniffer capture of port 0/11 on 2950 where you said the listener in vlan 100 is connected. Try to subscribe to the group from the listener, as soon as you do this the client should generate a join. If we see a join then we need to know whether the 2950 is forwarding that join to 3560 which is the mcast router. That will mean another sniffer trace on gig 0/23 of the 3560.

2. Or try to disable the igmp snooping on 2950 and see the client is not able to get the stream. What disabling the igmp snooping does is the 2950 will just flood the mcast stream to all the ports, if there is a stream to flood.

and there is a another way to see if we can force the router to send stream but you need to make sure that the group address is actually the group address you've indicated. You can try putting in "ip igmp join-group 224.77.2.121" under the interface vlan 100 of the 3560.

cratejockey Thu, 08/10/2006 - 17:02
User Badges:

Thanks for your ongoing support on this issue. Things are starting to be a bit less murky. However I need to clarify what you are saying about joins.


How does the listener know what group it is trying to join? How to I get the listener to try to subcribe? All of this is happening in the clients ARD console. On VLAN 10 a client automatically sees the multicast offering. On VLAN 100 it never does.


I'm going to try to disable snooping as you stated but I think overall my issue lies with my groups. Is the group something that I can set to anything in the standard Multicast range?


If we are moving backware feel free to let me know and I'll walk away from this for tonight and read more about multicast.

Roberto Salazar Thu, 08/10/2006 - 19:07
User Badges:
  • Gold, 750 points or more

Per IGMP's general operation there is a join that needs to come from the client. However, the client is configured it must generate a join to a particualr group it need to get the stream from. The best thing to do probably is to sniff the port and see if you get any kind of join. You have a segment where the mcast is working, if you sniff that you would see an IGMP join at the beginning of the communication from the client. There are three IGMP version but the general operation is the same. Maybe you should look at the IGMP RFC:

IGMP v1 - RFC 1112

IGMP v2 - RFC 2236

IGNP v3 - RFC 3336


INTRODUCTION TO MULTICAST:

http://www.cisco.com/application/pdf/en/us/guest/products/ps6552/c1161/cdccont_0900aecd80310883.pdf



Actions

This Discussion