×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

2801 QoS/VoIP

Unanswered Question
Aug 15th, 2006
User Badges:

I am setting up a 2801 with QoS for VoIP. The following QoS config works fine on 1721s, but we are having issues with outbound voice on the 2801s with this policy. The IOS is 12.4(9T)ipbase.


policy-map QoS-Policy

class VoIP-RTP

priority 512

class class-default

fair-queue


Any thoughts?


Thanks.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
mheusinger Tue, 08/15/2006 - 07:04
User Badges:
  • Green, 3000 points or more

Hi,


what are the interface speeds? How much VoIP traffic is expected? Can you post a "show policy-map QoS-Policy " and a "show run int "?


It might be an issue with not enough VoIP bandwidth, it might be Link Fragmentation and Interleaving, which is missing. Many possibilities for VoIP to fail, so please provide more informations.


Regards, Martin

bregimand Tue, 08/15/2006 - 07:16
User Badges:

Martin-

Sure. First, more of the config:


class-map match-all VoIP-RTP

match access-group 101

!

Policy-map QoS-Policy

class VoIP-RTP

priority 512

class class-default

fair-queue

!

interface multilinkXXX

ip address xx.xx.xx.xx xx.xx.xx.xx

load-interval 30

no cdp enable

ppp mulitlink

ppp multilink group XXX

service-policy output QoS-Policy

!

access-list 101 permit ip xx.xx.xx.0 0.0.0.255 any


Now, the show policy-map:


Policy-map QoS-Policy

Class VoIP-RTP

Strict Priority

Bandwidth 512 (kbps) Burst 12800 (Bytes)

Class class-default

Flow based fair-queueing

Bandwidth 0 (kbps) Max Threshold 64 (packets)



Thanks again,

Ben





mheusinger Tue, 08/15/2006 - 07:39
User Badges:
  • Green, 3000 points or more

Well,


as already stated more info would be great.

BUT, your access-list is somewhat strange. There is no device I know of, where all traffic is voice. Even voip phones send signalling traffic, config updates, DHCP, firmware updates and what not.


Can you modify your class-map to the following:


class-map match-all VoIP-RTP

match protocol rtp


This still leaves signalling traffic as best effort. Giving it a second thought: use "auto qos voip"! This is what it is made for.

Remove the multilink stuff, if only one serial is involved, and then apply auto QOS:


interface Serial0/0

bandwidth !!!! set the interface bandwidth to the real value !!!!!

ip address ...

auto qos voip

!

Be aware that this has service disrupting effects during reconfiguration, so do it, when no user traffic is present.


Hope this helps! Please rate all posts.


Regards, Martin


bregimand Tue, 08/15/2006 - 10:54
User Badges:

Martin-

Thanks so far. We can't use auto QoS, as we need the MU interface (multiple T1's right now)

I have a question about the match protocol rtp statement - I understand why you pointed this out, and I used to do it this way. I don't think that ths is causing the voice-breakup issue, though, as in this case I don't care about signaling traffic, and QoS should be doing it's job for voice-traffic.

I wanted to know if anyone else running an ISR was having any voice quality issues - perhaps someone who is also not using auto-QoS...?


I can't post the whole config, as some of it is proprietary and I could get in trouble (!), but is there any other info I can give that would would be helpful?


Thanks,

Ben

fred.s.mollenkopf Tue, 08/15/2006 - 07:07
User Badges:
  • Gold, 750 points or more

This is not enough information to diagnose. Attach a show runn (with any passwords and ip excluded) so we can review the configuration for you. Also send a show policy-map interface for the applied interface.


Please rate any helpful posts


Thanks


Fred

globalnettech Tue, 08/15/2006 - 11:11
User Badges:
  • Silver, 250 points or more

Hello,


in addition to the other post, you might want to try this config:


class-map match-all VoIP

match access-group 101

!

Policy-map QoS-Policy

class VoIP

set dscpcs5

class class-default

fair-queue

!

interface multilinkXXX

ip address xx.xx.xx.xx xx.xx.xx.xx

load-interval 30

no cdp enable

ppp mulitlink

ppp multilink group XXX

service-policy output QoS-Policy

!

access-list 101 permit tcp xx.xx.xx.0 0.0.0.255 any eq 1720

access-list 101 permit udp xx.xx.xx.0 0.0.0.255 any range 16384 32767


The access list would match Cisco VoIP traffic utilizing the H.323 codec for signaling, and UDP ports 16384 - 32767 for the voice payload.


Regards,


GNT

bregimand Tue, 08/15/2006 - 12:29
User Badges:

It looks like the only difference here is also prioritizing the signaling?

Again, right now I don't care about this - only voice quality.

I have dozens of 1721s set up my way with no issues whatsoever, but the 4 2801s I set up this way all suffer from inbound voice quality issues.


I will be happy to post more info if anyone needs it.


thank you all for your input so far.


Regards,

Ben

ilya.varlashkin Tue, 08/15/2006 - 14:09
User Badges:
  • Silver, 250 points or more

Inbound? That seems to be wrong end of the problem - if we're talking about calls coming from the WAN link to this 2800 routers than you should be looking at QoS config of whatever is on the remote side of the connection. Is QoS configured on the other side of the link?


Second question: since you're using multilink I assume you have either E1/T1 or fractional E1/T1 link. How many links are in the bundle and what is speed of each individual link?


What WIC cards do you have, what IOS? These are just shots in the wild. Hard to guess without having first two things sorted out. 2800 series work find in respect to QoS and deliver much better than 1700 series.


Have you tried to take 2800 out and put 1721 at exactly the same location, not just in different location? And use your config from 2800 verbatim (except changing WIC card numbers), use the same WIC cards, same cables.



bregimand Wed, 08/16/2006 - 07:19
User Badges:

My mistake - it is OUTBOUND voice that is the problem.

I replaced the 2801 with a 1721 using the same WIC, a V2,and same cables, and had no issues whatsoever.

This is a full T1, and the IOS is 12.4(9T)ipbase.


This particular site only has one T1, but I have 2801s elsewhere with 2-3 full T1s and the same problem.


Thanks,

Ben

ilya.varlashkin Wed, 08/16/2006 - 10:16
User Badges:
  • Silver, 250 points or more

If you have no specific reasons for using 12.4T, try mainline 12.4.8a. If that doesn't help, please post full config of your 2801 (for simplicity let's limit it to the site with only single line).

Hi, I am having same problem with a 2821,with same configuration, during congestion period, voice break-up, This 2821 replaces an 1751, customer did not have problems with 1700, but when we put 2821 in service, problems arose.

The configuration is the same as in the 1751, so nothing in configuration changed.

I opened a TAC case, but up to now i did not receive any conclusion from Cisco, they could not reproduce the fail.

I made a workaround configuring a traffic shape in the class-default class, with this, voice is not affected by data traffic burst.

Does someone are having same problem?

Thank you, and excuse me for my English

Gustavo Chiarelli


sdemarchi Tue, 12/19/2006 - 00:14
User Badges:

Hi,

I found the same problem with a 3640, maybe do you have slow link too, and in my case is a 256 K leased line.

I opened a Cisco case too SR604800159. After the normal request (sh tech,?.) and changed 2 System Engineer, I don?t have received other help from Cisco support.

I tried your solution with traffic shaping, it works, bud the solution was no perfect.

I found the presumable solution on SRND QoS: http://www.cisco.com/application/pdf/en/us/guest/netsol/ns432/c649/ccmigration_09186a008049b062.pdf ?On some older versions of Cisco IOS Software, Tx-rings might need to be reduced on slow-speed links to avoid excessive serialization delay.?


I configured the tx-rings in LAB under the serial interface, then all works fine.


I?m not sure if this is correct solution, now I?m waiting a feedback from my customer.





Actions

This Discussion