×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

routing loop help!

Unanswered Question
Aug 28th, 2006
User Badges:

I have a routing loop.


tracert 10.121.62.1 which is the offsit location, loops between two routers here on the main site.


when I try to ping a known IP, I get a TTL expired on transit.


I phoned our provider, everything is set on their end. nothing has changed on either routers. what else could be the cause?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 2 (1 ratings)
Loading.
vijayasankar Mon, 08/28/2006 - 04:20
User Badges:
  • Silver, 250 points or more

Hi,

Routing loops could be due to misconfiguration or due to any link flap or any problem with the routing protocols enroute in the network.

Do you have access to the hops that you see in the tracert.

If so, login to those 2 hops which are looping, and check the output of "show ip route ".

This will give you a clue on what is wrong with the current routing setup on those hops.


HTH


-VJ


soklamarhy Mon, 08/28/2006 - 04:40
User Badges:

Yes I do,


I see there is no routing for 10.121.62.1


Subnet not in table.


How do I put this subnet in the table? My other site is D-EIGRP dynamically learned.


Why is this other site not learning it the same way?

devang_etcom Mon, 08/28/2006 - 04:48
User Badges:
  • Gold, 750 points or more

do you have any redistribution configured on your router?

soklamarhy Mon, 08/28/2006 - 05:00
User Badges:

If you mean by I assign a static IP for redistributing any IP's under this subnet, then yes I do, back to my core router which loops back to the router that talks to the offsite.


We have a PPP connection w/ serial int.



devang_etcom Mon, 08/28/2006 - 05:09
User Badges:
  • Gold, 750 points or more

if you have configured redistribution then make sure you have configure it properly... may be due to missconfiguration of redistribution causes most of the routing loop problem... so will you please post the topology with configuration so we can try to solve it ...


rate this post if it helps


regards

Devang

soklamarhy Mon, 08/28/2006 - 05:17
User Badges:

version 12.3

no service pad

service tcp-keepalives-in

service tcp-keepalives-out

service timestamps debug datetime localtime

service timestamps log datetime localtime

service password-encryption

service sequence-numbers

!

hostname XXX

!

boot-start-marker

boot-end-marker

!

security authentication failure rate 3 log

security passwords min-length 6

logging buffered 17384 debugging

logging console critical


!

no aaa new-model

!

resource policy

!

clock timezone EST -5

clock summer-time EDT recurring

no network-clock-participate wic 1

ip subnet-zero

no ip source-route

ip tcp synwait-time 10

!

!

ip cef

no ip dhcp use vrf connected

!

!

no ip bootp server

ip domain name XXX

ip name-server 10.121.26.36

ip name-server 10.121.24.4

ssh time-out 60

ip ssh authentication-retries 2

no ftp-server write-enable

!

voice-card 0

no dspfarm

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

controller T1 0/1/0

framing esf

linecode b8zs

channel-group 0 timeslots 1-24

!

controller T1 0/1/1

framing esf

clock source internal

linecode b8zs

channel-group 0 timeslots 1-24

!

!

!

interface GigabitEthernet0/0

description *** Old Network ***

ip address 10.121.24.2 255.255.252.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip route-cache flow

duplex auto

speed auto

no mop enabled

bridge-group 1

!

interface GigabitEthernet0/1

description None

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip route-cache flow

duplex auto

speed auto

no cdp enable

no mop enabled

!

interface Serial0/1/0:0

ip address 10.121.101.1 255.255.255.248

bridge-group 1

!

interface Serial0/1/1:0

ip address 10.121.101.129 255.255.255.248

!

router eigrp 1

network 10.0.0.0

no auto-summary

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.121.26.255

!

!

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 600 life 86400 requests 10000

!

logging trap debugging

!

!

!

control-plane

!

bridge 1 protocol ieee

Edison Ortiz Mon, 08/28/2006 - 05:46
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

"ip route 0.0.0.0 0.0.0.0 10.121.26.255"


You are pointing the default route to a broadcast address.


It's this part of your current config or a typo while posting the config ?


Edison Ortiz Mon, 08/28/2006 - 05:44
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Lamar said:

"Yes I do,

I see there is no routing for 10.121.62.1

Subnet not in table.

How do I put this subnet in the table? My other site is D-EIGRP dynamically learned.

Why is this other site not learning it the same way?"


Lamar,


The subnet will automatically return to the routing table as soon as EIGRP

is working again between the 2 routers.


If you issue


"sh ip eigrp neighbors detail"


do you see any neighbors listed ? If so, it's that neighbor holding the 10.121.62.0 network ?

soklamarhy Mon, 08/28/2006 - 06:15
User Badges:

No I do not. I called the provider again and they said their end is clean and see no response from the CSU


What does this mean?

Edison Ortiz Mon, 08/28/2006 - 06:19
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

The provider should be able to loop the CSU from remote, if they can't try resetting the CSU.


You should work closely with your telco on this problem since it can also be a hardware issue at the telco end or your end.

soklamarhy Mon, 08/28/2006 - 06:28
User Badges:

I have, they have already replaced some double loop circuit board on both ends. Now they are able to have a clean connection so they say, but still unable to hit the CSU.


You suggest I try to reset the CSU? There is an amber light on the serial interface card that is lighted up (AL) or (AC), I forgot the abbreviation for it.


What does this mean?

soklamarhy Mon, 08/28/2006 - 06:36
User Badges:

It is an AL light, for Alarm. We have already tried rebooting, and doing shut, no shut on the interface. Still no luck. Can we assume this card is bad now?

Edison Ortiz Mon, 08/28/2006 - 06:41
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Don't assume that just yet. Check cabling from the Dmark to CSU and tell the provider that you have an alarm. They should dispatch someone onsite. If you have a spare CSU try swapping for troubleshooting purposes.


It's an internal or external CSU ?


soklamarhy Mon, 08/28/2006 - 06:51
User Badges:

It is an internal CSU.


We are already ordering a new unit $400 bucks.


I have been working with our provider and they are still unable to hit the CSU unit.



Edison Ortiz Mon, 08/28/2006 - 07:09
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

If they can't hit the CSU, nothing I can suggest in terms of router config can help here. The only thing I want to remind you is to verify the default route to that broadcast address, that is wrong.


jackyoung Mon, 08/28/2006 - 19:10
User Badges:
  • Gold, 750 points or more

According to the config. The 10.121.62.1 should be learn via EIGRP if the looping is occured at the serial. Otherwise, the looping may be at the LAN side.


Please provide the routing table (sh ip route) at both sides and the config. at remote side then we know the problem. And also please provide the trace route result for reference.


Above is only assume there is software problem. If it is a hardware problem then you have to work w/ your provider.


Hope this helps.

Actions

This Discussion