No dhcp address

Unanswered Question
Aug 29th, 2006
User Badges:

I setup some ap1100 with a native vlan and VLAN for wireless clients. Setup trunking on the swtich set the ip address fron the dhcp as the ip helper address but the clients get no ip address.



no aaa new-model

dot11 vlan-name vlan14 vlan 14

dot11 vlan-name vlan16 vlan 16

!

dot11 ssid AMADEUS-1

vlan 14

max-associations 20

authentication open

mobility network-id 14

!

power inline negotiation prestandard source

!

!

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

encryption key 1 size 128bit

encryption mode wep mandatory

!

encryption vlan 14 mode wep mandatory

!

ssid AMADEUS-1

!

short-slot-time

speed basic-1.0 basic-2.0 basic-5.5 basic-6.0 basic-9.0 basic-11.0 basic-12.0 basic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0

power local cck 2

power local ofdm 2

power client 2

channel 2472

station-role root

payload-encapsulation dot1h

!

interface Dot11Radio0.14

encapsulation dot1Q 14

no ip route-cache

bridge-group 14

bridge-group 14 subscriber-loop-control

bridge-group 14 block-unknown-source

no bridge-group 14 source-learning

no bridge-group 14 unicast-flooding

bridge-group 14 spanning-disabled

!

interface Dot11Radio0.16

encapsulation dot1Q 16 native

no ip route-cache

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface Dot11Radio1

no ip address

no ip route-cache

shutdown

!

encryption key 1 size 128bit 7

encryption mode wep mandatory

speed basic-6.0 basic-9.0 basic-12.0 basic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0

station-role root

payload-encapsulation dot1h

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface FastEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

!

interface FastEthernet0.14

encapsulation dot1Q 14

no ip route-cache

bridge-group 14

no bridge-group 14 source-learning

bridge-group 14 spanning-disabled

!

interface FastEthernet0.16

encapsulation dot1Q 16 native

no ip route-cache

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

!

interface BVI1

ip address 192.168.16.242 255.255.255.0

no ip route-cache

!

ip default-gateway 192.168.16.254

ip http server

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

ip radius source-interface BVI1

!


!

control-plane

!

bridge 1 route ip

!

!

wlccp ap username

wlccp ap wds ip address 192.168.10.245

!

line con 0

transport preferred all

transport output all

line vty 0 4

login local

transport preferred all

transport input all

transport output all

line vty 5 15

login

transport preferred all

transport input all

transport output all

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
andrew.brazier@... Tue, 08/29/2006 - 05:37
User Badges:
  • Bronze, 100 points or more

Usually indicates that the client hasn't authenticated with the AP correctly and if using static WEP (which I think you are) that the WEP key is wrong somewhere. Re-enter on the AP and clients and try again.

jefvaneijk Tue, 08/29/2006 - 06:53
User Badges:

Wel is see that the client is Associated, i think somewhere the client cannot reach the dhcp server

drees Tue, 09/05/2006 - 04:51
User Badges:

You will see an association, but no authentication if the WEP key doesn't match. Type the wep key into both client and AP again. WEP key shouldn't be pasted into an AP. I've seen issues with this. Make sure you use the same index on both ends.


Good Luck,

Dave

vleonard Fri, 09/15/2006 - 08:13
User Badges:

You might try removing the "mobility network-id 14" under the SSID.


I just upgraded about 60 AP-1231 and none of the clients that tried to connect to a SSID that had that command would get an IP address.


I had upgraded to 12.3(8)JEA.

The old IOS was 12.3(7), 12.3(8)JA and a couple other older versions.

richkrissi Fri, 09/15/2006 - 15:14
User Badges:

I would double check your trunked on the port your ap is connected to. Also ensure that port is tagged to your vlans. Make sure your DHCP server can tracert to that vlan.

When I see this,usually it is a misconfigured switch port.

Actions

This Discussion