×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

CTIOS 7.0 problem

Unanswered Question
Sep 3rd, 2006
User Badges:

Hello,

I'm upgrading the IPCC to version 7.0.

i'm also uninstall the previous version and re-install the new version of CTIOS.

Now I'm receiving the following errors from the CTIOS service when started:


14:32:19 CTIOS1-ctios Trace: DEMO_CTIOS1 ctios server [7.0 07383] [STARTING]

14:32:19 CTIOS1-ctios Trace: LogWrapper::Trace(uint, TCHAR, va_list), caught exception.

14:32:19 CTIOS1-ctios Trace: CConfigurationServer::ReadSecurityConfig(), security path

[C:\ICM\DEMO\CTIOS1\Security\]

14:32:19 CTIOS1-ctios Trace: CConfigurationServer::ReadSecurityConfig(), security is disabled

14:32:19 CTIOS1-ctios Trace: CConfigurationServer::ReadSecurityConfig(), NumBytesRenegotiation[1073741824]

14:32:19 CTIOS1-ctios Trace: CGenericStorage::GetDataFromRegistry(). Table Not found in the registry.

14:32:19 CTIOS1-ctios Trace: CGenericStorage::GetDataFromRegistry(). Table Not found in the registry.

14:32:19 CTIOS1-ctios Trace: CGenericStorage::GetDataFromRegistry(). Table Not found in the registry.

14:32:19 CTIOS1-ctios Trace: CGenericStorage::GetDataFromRegistry(). Table Not found in the registry.

14:32:19 CTIOS1-ctios Trace: CGenericStorage::GetColumnNamesFromRegistry(). RegEnumKeyEx() failed. No Data

Found.

14:32:19 CTIOS1-ctios Trace: CGenericStorage::GetDataFromRegistry(). GetColumnNamesFromRegistry failed.

Error :: -103

14:32:19 CTIOS1-ctios Trace: StartThreads, Starting 6 IOCP worker threads

14:32:19 CTIOS1-ctios Trace: WorkerThread, started ThreadID[5184]

14:32:19 CTIOS1-ctios Trace: WorkerThread, started ThreadID[5188]

14:32:19 CTIOS1-ctios Trace: WorkerThread, started ThreadID[5192]

14:32:19 CTIOS1-ctios Trace: WorkerThread, started ThreadID[5196]

14:32:19 CTIOS1-ctios Trace: WorkerThread, started ThreadID[5200]

14:32:19 CTIOS1-ctios Trace: Connection Settings: ListenPort: 42028, TOS: 0, ClientPoolInitialSize: 500,

ClientPoolMinSize: 50, ClientPoolIncrement: 25, AcceptPoolSize: 200,

KeepAliveEnable: 1, KeepAliveInterval: 5000, KeepAliveTime: 3000

14:32:19 CTIOS1-ctios Trace: WorkerThread, started ThreadID[5204]

14:32:19 CTIOS1-ctios Trace: ServiceBroker:StartTrashCollector-Trash collection interval = 7200 sec.

14:32:19 CTIOS1-ctios Trace: SYSTEM: CTIOS ServerID is now [progger:42028].

14:32:19 CTIOS1-ctios Trace: ServiceBrokerQ - SetThreadPriority highest

14:32:19 CTIOS1-ctios Trace: DEMO_CTIOS1 ctios server [7.0 07383] [OFFLINE]

14:32:19 CTIOS1-ctios Trace: DEMO_CTIOS1 ctios server [7.0 07383] [CONNECTING, CG: 10.16.103.160, CGPort:

43027]

14:32:19 CTIOS1-ctios Trace: ** Attempting to connect to server [10.16.103.160 (10.16.103.160) port:43027] **

14:32:20 CTIOS1-ctios Trace: CNotSecureNetPort(00FA8CD8)::Open, WARNING,, Connection to Host[], Target

machine refused connection. (WSAECONNREFUSED), Error Number(10061).

14:32:20 CTIOS1-ctios Trace: Switching Sides: CurrentSide is now SideA [10.16.103.160 Port:42027].

14:32:20 CTIOS1-ctios Trace: DEMO_CTIOS1 ctios server [7.0 07383] [CONNECTING, CG: 10.16.103.160, CGPort:

42027]

14:32:20 CTIOS1-ctios Trace: ** Attempting to connect to server [10.16.103.160 (10.16.103.160) port:42027] **

14:32:20 CTIOS1-ctios Trace: CCtiSvrConnection(00FA9FB0)::StartConnectionMgr() WARNING: Previous connection

manager not yet stopped.

14:32:21 CTIOS1-ctios Trace: CCtiSvrConnection(00FA9FB0)::StartConnectionMgr() WARNING: Previous connection

manager not yet stopped.

14:32:21 CTIOS1-ctios Trace: CNotSecureNetPort(00FA8CD8)::Open, WARNING,, Connection to Host[], Target

machine refused connection. (WSAECONNREFUSED), Error Number(10061).

14:32:21 CTIOS1-ctios Trace: DEMO_CTIOS1 ctios server [7.0 07383] [OFFLINE, CG: 10.16.103.160, CGPort: 42027]

14:32:22 CTIOS1-ctios Trace: CCtiSvrConnection(00FA9FB0)::StartConnectionMgr() WARNING: Previous connection

manager not yet stopped.


Thanks for advise.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
bullett Tue, 09/05/2006 - 06:32
User Badges:

14:32:19 CTIOS1-ctios Trace: ** Attempting to connect to server [10.16.103.160 (10.16.103.160) port:43027] **

14:32:20 CTIOS1-ctios Trace: CNotSecureNetPort(00FA8CD8)::Open, WARNING,, Connection to Host[], Target

machine refused connection. (WSAECONNREFUSED), Error Number(10061).


It can't connect by the look of it. Have you check the ports and IP address and check for any possible firewalls blocking the communication path?

Demo is the instance? is the server running and able to accept connections.

Check everything 4 times! I've made silly typos in the past and got stuck for ages on stuff like this.

Bully

geoff@hp.com Wed, 07/02/2008 - 04:46
User Badges:
  • Green, 3000 points or more

Looks like you have configured the CTI servers that CTIOS is trying to connect to - side A (port 42027) and side B (43027) - with the same IP address of 10.16.103.160. That's odd.


Regards,

Geoff

Riccardo Bua Wed, 07/02/2008 - 04:53
User Badges:
  • Cisco Employee,

Hi Dror,


check if the server is listening on that port do a netstat -a, noticed this is a progger wondering if there is any issue with the amount of processes being deployed and the network card servicing it, did you hardcode it at 100MB Duplex?


Regards,


Riccardo

sandeep pokhriyal Wed, 07/02/2008 - 06:19
User Badges:

hi,

here is the screenshot of the CTI OS which is not connecting.

as soon i shutdown the other side it will come up and will show Active.


geoff@hp.com Wed, 07/02/2008 - 09:59
User Badges:
  • Green, 3000 points or more

I see - the CTIOS peers are trying to talk to each other and cannot.


Please make sure that the private NIC has not "migrated" to be first in the binding order for the network adapters. What you are seeing is symptomatic of that.


Network Connections - Advanced - Advanced Settings ... - Adapters and Bindings.


Ensure the visible LAN is first in the list.


Regards,

Geoff


sandeep pokhriyal Wed, 07/02/2008 - 23:58
User Badges:

many thanks Geoff,


that was quick

It worked as it was supposed to be.

a good note to add.

amitsrivastava Thu, 10/17/2013 - 12:18
User Badges:

11:21:31 CTIOS1-ctios Trace: CNetPort(00BBD4B8)::ReceiveData, recv, WARNING,, Connection to Host[],
     Connection reset by peer. (WSAECONNRESET), Error Number(10054).
11:21:31 CTIOS1-ctios Trace: Connection disconnected, host [155.17.105.40].
11:21:31 CTIOS1-ctios Trace: XXX CLIENT[00018], CLOSE
11:21:31 CTIOS1-ctios Trace: CClient::Close: CLIENT[00018][0x39f1638, CLOSE(), Calling OnConnectionClosed()
11:21:31 CTIOS1-ctios Trace: XXX RCV CLIENT[00018]: eOnConnectionClosed
11:21:31 CTIOS1-ctios Trace: ClientMgr[1]::OnConnectionClosed, Client[0x039F1638][00018]
11:21:31 CTIOS1-ctios Trace: CTIOSTrace - CConnectionMonitor::MonitorThread, Connection (CtiosServerNode.exe_3148_4924) Abandoned
11:21:31 CTIOS1-ctios Trace: CTIOSTrace - CConnectionMonitor::RemoveClient, Removing Connection (CtiosServerNode.exe_3148_4924)
11:21:31 CTIOS1-ctios Trace: CTIOSTrace - CConnectionMonitor::MonitorThread, Posting Quit Message
11:21:31 CTIOS1-ctios Trace: CTIOSTrace - WndProc(WM_DESTROY)
11:22:32 CTIOS1-ctios Initializing Event Management System (EMS) Library.
11:22:32 CTIOS1-ctios Trace: EMS Server pipe psc\CTIOS1\ctiosEMSPipe enabled for psc\CTIOS1\ctios
11:22:32 CTIOS1-ctios Trace: CTIOSTrace - InitInstance(), Creating window for message processing...
11:22:32 CTIOS1-ctios Trace: CTIOSTrace - InitInstance(), Created window.
11:22:32 CTIOS1-ctios Trace: CTIOSTrace - InitInstance(), Starting message pump...
11:22:32 CTIOS1-ctios Trace: CTIOSTrace - CConnectionMonitor::MonitorThread()
11:22:32 CTIOS1-ctios Trace: CTIOSTrace - CConnectionMonitor::MonitorThread, Waiting on 0 Connections.
11:22:32 CTIOS1-ctios Trace: CTIOSTrace - CConnectionMonitor::AddClient(CtiosServerNode.exe_7252_7792).
11:22:32 CTIOS1-ctios Trace: CTIOSTrace - CConnectionMonitor::MonitorThread, Waiting for list to be modified
11:22:32 CTIOS1-ctios Trace: CTIOSTrace - CConnectionMonitor::AddClient, Adding Connection 0, (CtiosServerNode.exe_7252_7792)
11:22:32 CTIOS1-ctios Trace: CTIOSTrace - CConnectionMonitor::MonitorThread, Waiting on 1 Connections.
11:22:32 CTIOS1-ctios Trace: ********* Started logging facility for CtiosServerNode.exe_7252_7792 *********
11:22:32 CTIOS1-ctios Trace: LogWrapper::Start, ServerMonitorThread started successfully.
11:22:32 CTIOS1-ctios Trace: LogWrapper::Start, Debug Output is OFF.
11:22:32 CTIOS1-ctios Trace: LogWrapper::Start, Screen Output is ON.
11:22:32 CTIOS1-ctios Trace: LogWrapper::Start, WaitThread started successfully.
11:22:32 CTIOS1-ctios Trace: CGlobalExceptionHandler::InstallGlobalExceptionHandler()
11:22:32 CTIOS1-ctios Trace: CGlobalExceptionHandler::PruneMiniDumpFiles()
11:22:32 CTIOS1-ctios Trace: CGlobalExceptionHandler::PruneMiniDumpFiles -- There are no files matching the
     pattern.
11:22:32 CTIOS1-ctios Trace: CTIOS Server unique instance name [psc].
11:22:32 CTIOS1-ctios Trace: CTIOS Server unique component number [CTIOS1].
11:22:32 CTIOS1-ctios Trace: CTIOS Server unique registry name [CTIOS_psc\CTIOS1].
11:22:32 CTIOS1-ctios Trace: CTIOS Server unique console title name [psc_CTIOS1 ctios server].
11:22:32 CTIOS1-ctios Trace: CTIOS Server unique name for events, semaphores, etc...
     [CTIOS_psc_CTIOS1_CtiosServer].
11:22:32 CTIOS1-ctios Trace: CTitleBarMsg::CTitleBarMsg(), disabling quick edit mode...
11:22:32 CTIOS1-ctios Trace: CTitleBarMsg::CTitleBarMsg(), quick edit mode is disabled.
11:22:32 CTIOS1-ctios Trace: psc_CTIOS1 ctios server [7.2 10956] [STARTING]
11:22:32 CTIOS1-ctios Trace: Added Peripheral [PG3CTIOS] PeripheralID [5002] type [17].
11:22:32 CTIOS1-ctios Trace: CService::ReadSecurityConfig(), security is disabled
11:22:32 CTIOS1-ctios Trace: ** Attempting to connect to server [155.17.105.40 (155.17.105.40) port:42028] **
11:22:32 CTIOS1-ctios Trace: CConfigurationServer::ReadClientConnectionSettings(),[TotalPendingSendLimit] =
     [0]
11:22:32 CTIOS1-ctios Trace: CGlobalExceptionHandler::SetLogPathName() C:\ICM\psc\CTIOS1\logfiles\
11:22:32 CTIOS1-ctios Trace: CConfigurationServer::ReadSecurityConfig(), security path
     [C:\ICM\psc\CTIOS1\Security\]
11:22:32 CTIOS1-ctios Trace: CConfigurationServer::ReadSecurityConfig(), security is disabled
11:22:32 CTIOS1-ctios Trace: CConfigurationServer::ReadSecurityConfig(), NumBytesRenegotiation[1073741824]
11:22:32 CTIOS1-ctios Trace: CConfigurationServer::ReadSGSpreadingConfig(),[EventSpreadIntervalMsec] = [5000]
11:22:32 CTIOS1-ctios Trace: CConfigurationServer::ReadSGSpreadingConfig(),[DistResIntervalMsec] = [100]
11:22:32 CTIOS1-ctios Trace: CConfigurationServer::ReadSGSpreadingConfig(),[PendingSendLimit] = [0]
11:22:32 CTIOS1-ctios Trace: CConfigurationServer::ReadMultiThreadSettings(), failed to open the
     MultiThread registry key [Software\Cisco Systems,
     Inc.\Ctios\CTIOS_psc\CTIOS1\Server\MultiThread]
11:22:32 CTIOS1-ctios Trace: CGenericStorage::GetDataFromRegistry(). Table Not found in the registry.
11:22:32 CTIOS1-ctios Trace: CGenericStorage::GetDataFromRegistry(). Table Not found in the registry.
11:22:32 CTIOS1-ctios Trace: CGenericStorage::GetDataFromRegistry(). Table Not found in the registry.
11:22:32 CTIOS1-ctios Trace: CGenericStorage::GetDataFromRegistry(). Table Not found in the registry.
11:22:32 CTIOS1-ctios Trace: CGenericStorage::GetDataFromRegistry(). GetTableNamesFromRegistry failed.
     Error :: -103
11:22:32 CTIOS1-ctios Trace: CGenericStorage::GetDataFromRegistry(). Table Not found in the registry.
11:22:32 CTIOS1-ctios Trace: CGenericStorage::GetColumnNamesFromRegistry(). RegEnumKeyEx() failed. No Data
     Found.
11:22:32 CTIOS1-ctios Trace: CGenericStorage::GetDataFromRegistry(). GetColumnNamesFromRegistry failed.
     Error :: -103
11:22:32 CTIOS1-ctios Trace: StartThreads, Starting 6 IOCP worker threads
11:22:32 CTIOS1-ctios Trace: IOCPConnectionMgrThread[8068], Started.
11:22:32 CTIOS1-ctios Trace: IOCPConnectionMgrThread[7868], Started.
11:22:32 CTIOS1-ctios Trace: IOCPConnectionMgrThread[6044], Started.
11:22:32 CTIOS1-ctios Trace: IOCPConnectionMgrThread[4624], Started.
11:22:32 CTIOS1-ctios Trace: Connection Settings: ListenPort: 42028, TOS: 0, ClientPoolInitialSize: 500,
     ClientPoolMinSize: 50, ClientPoolIncrement: 25, AcceptPoolSize: 200,
     KeepAliveEnable: 1, KeepAliveInterval: 5000, KeepAliveTime:
     3000TotalPendingSendLimit: 0
11:22:32 CTIOS1-ctios Trace: IOCPConnectionMgrThread[7480], Started.
11:22:32 CTIOS1-ctios Trace: IOCPConnectionMgrThread[7332], Started.
11:22:32 CTIOS1-ctios Trace: SYSTEM: read PostThreadCount = 4.
11:22:32 CTIOS1-ctios Trace: CClientMgr::DoDistributionThreadProc(): Timer resolution is set to 1 msec
11:22:32 CTIOS1-ctios Trace: ServiceBroker:StartTrashCollector-Trash collection interval = 7200 sec.
11:22:32 CTIOS1-ctios Trace: CTimerService::GetRegistryInfo-Timer resolution = 500 Msec
11:22:32 CTIOS1-ctios Trace: CTimerService::DoTimerThreadProc(): Timer resolution is set to 1 msec
11:22:32 CTIOS1-ctios Trace: CTimerService::Start(): ReqSpreadingInterval[7200000]
11:22:32 CTIOS1-ctios Trace: SYSTEM: CTIOS ServerID is now [pscftcppg3b:42028].
11:22:32 CTIOS1-ctios Trace: [SYSTEM] SYSTEM_EVENT: SYS_CTI_SERVER_DRIVER_ONLINE
11:22:32 CTIOS1-ctios Trace: CCtiDriverObject::SessionManagerThread : OpenConnection returned 1.
11:22:32 CTIOS1-ctios Trace: psc_CTIOS1 ctios server [7.2 10956] [OFFLINE]
11:22:32 CTIOS1-ctios Trace: psc_CTIOS1 ctios server [7.2 10956] [CONNECTING, CG: 155.17.105.90, CGPort:
     43027]
11:22:32 CTIOS1-ctios Trace: ** Attempting to connect to server [155.17.105.90 (155.17.105.90) port:43027] **
11:22:32 CTIOS1-ctios Trace: psc_CTIOS1 ctios server [7.2 10956] [CONFIGURING, CG: 155.17.105.90, CGPort:
     43027]
11:22:32 CTIOS1-ctios Trace: ********  Connection opened [155.17.105.90 port:43027] ******** 
11:22:33 CTIOS1-ctios Trace: CNetPort(00F3D4C0)::Open, WARNING,, Connection to Host[], Target machine
     refused connection. (WSAECONNREFUSED), Error Number(10061).
11:22:33 CTIOS1-ctios Trace: CCilConnection(00F3D328)::OpenConnection, FAILED
11:22:33 CTIOS1-ctios Trace: Connection disconnected, host [155.17.105.40].
11:22:33 CTIOS1-ctios Trace: CCtiDriverObject::SessionManagerThread : Sending OPEN_REQ, protocol 11.
11:22:33 CTIOS1-ctios Trace: COpenReq::EncodeMessage Begin,  Packet length 94
11:22:33 CTIOS1-ctios Trace: psc_CTIOS1 ctios server [7.2 10956] [ACTIVATING, CG: 155.17.105.90, CGPort:
     43027]
11:22:33 CTIOS1-ctios Trace: COpenConf::DecodeMessage Begin,  Packet length 34
11:22:33 CTIOS1-ctios Trace: OPEN_CONF: ProtocolVersion 11
11:22:33 CTIOS1-ctios Trace: DriverConnection: CtiServer is now online. 
11:22:33 CTIOS1-ctios Trace: psc_CTIOS1 ctios server [7.2 10956] [CONFIGURING, CG: 155.17.105.90, CGPort:
     43027]
11:22:33 CTIOS1-ctios Trace: >> CG: [SYSTEM]:EVT: eOpenConf
11:22:33 CTIOS1-ctios Trace: [SYSTEM] OPEN_CONF: Driver is now online.
11:22:33 CTIOS1-ctios Trace: >> CG: [SYSTEM]:EVT: eSystemEvent( eSysCtiServerOnline )
11:22:33 CTIOS1-ctios Trace: AgentTeamConfigEvent::DecodeMessage Begin,  Packet length 1556
11:22:33 CTIOS1-ctios Trace: team id 5088


Any Idea guys.. appears to be some network issue...NIC Binding order is correct

Actions

This Discussion