Why this summarization is not working;OSPF/RIP redistrib

Unanswered Question
Sep 10th, 2006
User Badges:

[RouterB s0:152.1.1.5/30]==V35==[S0:152.1.16/30 RouterC S1:152.1.2.1/24]=V35==[S0:152.1.2.2/24 RouterD]


I am doing redistribution RIP<->OSPF.Please find attached detailed configuration

showing routing tables and configuration for all routers.


RouterB is running OSPF. RouterC=OSPF/RIP redistribution. RouterD=RIP.


From RouterD, I expect to see network from RouterB 152.1.1.0/30 (OSPF) advertised on RouterD, which is running RIP.


In order to overcome the classful behavior with RIP, I did on RouterB:

config t

router ospf 64

area 1 range 152.1.1.0 255.255.255.0


Then on RouterD, I expected to see now a route advertised as

152.1.1.0/24.


However, that is not the case. I go to route D after issuing the configuration

above and I don't see 152.1.1.0/24 advertised there in my 'show ip route'.


What am I missing ? If I do the 'area <> range command that is the correct

way to make the 152.1.1.0/30 network summarize into 152.1.1.0/24 in order to

propagate via RIP ?



Attachment: 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
jackyoung Sun, 09/10/2006 - 18:43
User Badges:
  • Gold, 750 points or more

Check below link for RIP/OSPF redistribution :


http://www.cisco.com/en/US/tech/tk1330/technologies_design_guide_chapter09186a00806666ff.html


And please try below command in router C :


router rip

redistribute ospf 64 match internal external 1 external 2


And try to summary the route at router C instead of router B to observe the result.


Moreover, I found you are using area 0 in all router, so the OSPF summary command should be "area 0 range 152.1.1.0 255.255.255.0".


Hope this helps.


sundar.palaniappan Sun, 09/10/2006 - 18:53
User Badges:
  • Green, 3000 points or more

Hi,


It's not working because you are using RIP v1 which doesn't carry subnet mask info in routing updates and that's the reason why RouterD doesn't put network 152.1.0.0/16 in the routing table.


Can you configure RIP v2 on RouterC & D like below and let us know the outcome.


router rip

version 2

no auto


Hope this helps!


Sundar



news2010a Sun, 09/10/2006 - 21:28
User Badges:

Hello Jack,

I did exactly what you instructed, but from RouterD I still can't see 152.1.1.0 on show ip route. How can I troubleshoot this from here or any idea ?

Here is the result from 'show ip route' on RouterD after doing the 'area 0 range 152.1.1.0 255.255.255.0' on RouterC and do the redistribute ospf 64 match internal external 1 external 2 on RouterC as well.


RouterD#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route


Gateway of last resort is not set


152.1.0.0/16 is variably subnetted, 3 subnets, 2 masks

R 152.1.11.1/32 [120/2] via 152.1.2.1, 00:00:13, Serial0/0

C 152.1.3.0/24 is directly connected, Loopback0

C 152.1.2.0/24 is directly connected, Serial0/0

R 10.0.0.0/8 [120/2] via 152.1.2.1, 00:00:13, Serial0/0

RouterD#


Oops, great catch on the 'area 0' command :-)


Sundar, thanks I understand I could easily solve this by doing RIPV2, but it seems that the exercise is trying to show how I can summarize and get by with RIP v1/OSPF.

jackyoung Sun, 09/10/2006 - 21:40
User Badges:
  • Gold, 750 points or more

Thanks for the quick test and result. Did you find the sumamrized route in router C ? If yes, the summarization is working but the RIP cannot support classless, so only 152.1.0.0/16 advertised from router C via RIP.


If you understand RIPv2 or other classless supoprting routing protocol can work, then I am sure that you understand why RIP not works here.


Just a simple test to follow Sundar's suggestion, if it works then you can change the subnet from class B to class C then you can find the summarization and redistribution are working.


Hope this helps.

news2010a Mon, 09/11/2006 - 11:14
User Badges:

Hi Jack, as is now, on RouterC is:

RouterC#show ip route

Gateway of last resort is not set


152.1.0.0/16 is variably subnetted, 4 subnets, 3 masks

O 152.1.11.1/32 [110/65] via 152.1.1.5, 00:20:47, Serial0/0

R 152.1.3.0/24 [120/1] via 152.1.2.2, 00:00:19, Serial0/1

C 152.1.2.0/24 is directly connected, Serial0/1

C 152.1.1.4/30 is directly connected, Serial0/0

10.0.0.0/24 is subnetted, 1 subnets

O 10.1.1.0 [110/74] via 152.1.1.5, 00:20:47, Serial0/0

RouterC#RouterC#show ip route


I totally understand that RIP is a classful protocol, but this is

what the exercise was trying to do:


"...

Remember that RIP is a classful protocol and will not pass

subnet information.


In order to get these routes redistributed into RIP, we can either

create static routes using a 24-bit mask to the two networks

and redistribute the routes into RIP- ** OR ** we can summarize

the routes in OSPF.

..."


Then I created two static routes on RouterC using a 24-bit mask


RouterC

ip route 152.1.11.0 255.255.255.0 s0

ip route 152.1.1.0 255.255.255.0 s0


redistribute static


Then on RouterD I can see - OK

R 152.1.11.0 via 152.1.2.1

R 152.1.1.0 via 152.1.2.1


As you can see, I was able to reach the 152.1.1.0/30 networks

because the static route 'turned them' into /24 bit mask, correct ?

Then I thought that by using summarization and making 152.1.1.0/30

into a 24-bit subnet mask, I thought that I could get RIPv1 to

let me advertise that route as well. Maybe I misunderstood

the problem, but that's what the "Allin-one CCIE Lab Study Guide"

is suggesting.


You don't have to dig into this. I totally understand

that if I put RIP v2 or just stick with the static routes as I did

above, I can make routes 152.1.1.0/30 advertise as 152.1.1.0/24

to RouterD. I was just concerned that the concept why I used for the summarization was wrong and I was trying to get it right, but from what you confirmed, it seems my summarization entry looks OK.

sundar.palaniappan Mon, 09/11/2006 - 14:06
User Badges:
  • Green, 3000 points or more

Hi,


What the book says is correct.


I was thinking you were trying to get IP connectivity quickly and didn't know you didn't want to enable RIP v2. I can understand now this is a lab scenario and they are asking you to achieve this task without enabling RIP v2.


As far as your question about why the summary address is not working is because, you need to configure on RouterC under the interface s0/1 - int to Router_D - as a RIP summary and not an OSPF summary address like the one you had configured using the 'area range' command.


Try the following configuration and you should see Router_D learning the network.


interface Serial0/1

ip summary-address rip 152.1.1.0 255.255.255.0


Hope this helps!


Sundar

Actions

This Discussion