×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

unable to authenticate in axl

Unanswered Question
Sep 21st, 2006
User Badges:

hello


ccm version 4.1(2).

MLA not enabled.


I am trying to use a previously working axl program to list out the phone database. The callmanager I am trying to connect to worked previosly as well. I am not aware of any changes that took place on the system. That being said, when I attempt to connect to the machine via axl I get "connection actively refused" errors.


I browsed to

http://192.168.1.253/CCMApi/AXL/V1/soapisapi.dll


and was able to authenticate using Administrator/cisco as my user/pass.

I got the following back in my browser


<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/">

- <SOAP-ENV:Body>

- <SOAP-ENV:Fault>

<faultcode>SOAP-ENV:Client</faultcode>

<faultstring>The AXL API service only accepts the HTTP POST request type.</faultstring>

</SOAP-ENV:Fault>

</SOAP-ENV:Body>

</SOAP-ENV:Envelope>


I am befuzzeled as to why my ccm is acting this way. the exact soap message I am sending to the machine is listed below.


POST /CCMApi/AXL/V1/soapisapi.dll

Host: 192.168.1.253:80

Accept: text/*

Authorization: Basic QWRtaW5pc3RyYXRvcjpjaXNjbw==

Content-type: text/xml

Content-length: 463


<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">

<SOAP-ENV:Body>

<axl:listPhoneByName xmlns:axl="http://www.cisco.com/AXL/1.0" xsi:schemaLocation="http://www.cisco.com/AXL/1.0 http://gkar.cisco.com/schema/axlsoap.xsd" sequence="1">

<searchString>%</searchString>

</axl:listPhoneByName>

</SOAP-ENV:Body>

</SOAP-ENV:Envelope>


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
markoller Thu, 09/21/2006 - 09:58
User Badges:

disregard this, found out that my zone alarm firewall was corrupted and I had to reinstall.


mark

Actions

This Discussion