Two Private subnets on an Internal router won't talk?

Unanswered Question
Sep 21st, 2006
User Badges:

Hi,


This Posting is a continuation of my previous posting but it seem sthat that has been lost!


I have two subnets, currently on a single Interface Fa0/1 of a Cisco 2621 router with. the subnets are:

10.1.1.0/24

10.1.4.0/24


with DG of 10.1.1.251 and 10.1.4.251 respectively.


Now, I have put these two subnets on a Cisco 3815 router on two gi0/0 and gi0/1 interfcaes with the folwoing ip route and ACLs:

interface GigabitEthernet0/0

description Interface for main subnet 10.1.1.0/24

ip address 10.1.1.251 255.255.255.0

ip helper-address 10.1.1.21

ip policy route-map Main-outbound-hop2

duplex auto

speed auto

media-type rj45

negotiation auto


interface GigabitEthernet0/1

description Interface for main subnet 10.1.4.0/24

ip address 10.1.4.251 255.255.255.0

ip helper-address 10.1.1.21

ip policy route-map Main-outbound-hop2

duplex auto

speed auto

media-type rj45

negotiation auto


ip classless

ip route 0.0.0.0 0.0.0.0 10.1.2.10

ip route 10.1.1.0 255.255.255.0 10.1.1.10

ip route 10.1.4.0 255.255.255.0 10.1.1.10

ip route 10.5.1.0 255.255.255.0 10.222.222.2


access-list 102 deny ip 10.1.1.0 0.0.0.255 10.5.1.0 0.0.0.255

access-list 102 deny ip 10.1.4.0 0.0.0.255 10.5.1.0 0.0.0.255

access-list 102 deny ip 10.1.4.0 0.0.0.255 10.1.1.0 0.0.0.255

access-list 102 deny ip 10.1.1.0 0.0.0.255 10.1.4.0 0.0.0.255

access-list 102 permit ip 10.5.1.0 0.0.0.255 10.1.1.0 0.0.0.255

access-list 102 permit ip 10.5.1.0 0.0.0.255 10.1.4.0 0.0.0.255

access-list 102 permit ip 10.1.1.0 0.0.0.255 any

access-list 102 permit ip 10.1.4.0 0.0.0.255 any

access-list 102 permit ip 10.5.1.0 0.0.0.255 any

access-list 102 permit icmp any any

access-list 102 permit ip any any



I must note here that this configuration is working fine on a single Interface of a Cisco 2621 but when put on this router on two diffferent Interfaces they wont talk to each other.


I need to bring up the new router with the above configuration but they won't talk..


Can u please see if anything cathes your eyes which might be worng and anything that needs to be added to the config ofr it to work?


Please advise,


Masood


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
lgijssel Thu, 09/21/2006 - 10:00
User Badges:
  • Red, 2250 points or more

Hello Masood,


It would be nice to know how access-list 102 is used. Is this the list for PBR? What does your route-map look like?

Anyway, the static routes to net 10.1.1 & 10.1.4 are of no use. Both networks are connected and this takes precedence.

Please try to remove PBR bij removing the ip policy route-map Main-outbound-hop2 from both interfaces. If this resolves the problem, you will know where to look.


Regards,

Leo

Actions

This Discussion