×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Catalyst 2960 - IBM/Cisco IGESM - Trunk port configuration

Answered Question

Good day all!


I am new in Cisco world and try to configure a trunk between a Catalyst 2960 switch and a IBM Blade Center IGESM switch (manifactured by Cisco).


Unfortunately, it seems that the network traffic doesn't cross the trunk link.

I have followed (at least, I think so) the instructions given on the different Cisco documentation papers but I can't find the mistake in my configuration (lack of experience :-( !).


Both switches are using IOS. 2960 uses IOS 12.2(25)FX and IGESM uses IOS 12.2(22)EA8.


The ports are connected through a cross-over cable Cat5e.


Please find below the configuration for each ports:


Catalyst 2960:

--------------


Name: Gi0/1

Switchport: Enabled

Administrative Mode: trunk

Operational Mode: trunk

Administrative Trunking Encapsulation: dot1q

Operational Trunking Encapsulation: dot1q

Negotiation of Trunking: On

Access Mode VLAN: 200 (Workstation VLAN)

Trunking Native Mode VLAN: 200 (Workstation VLAN)

Administrative Native VLAN tagging: enabled

Voice VLAN: none

Administrative private-vlan host-association: none

Administrative private-vlan mapping: none

Administrative private-vlan trunk native VLAN: none

Administrative private-vlan trunk Native VLAN tagging: enabled

Administrative private-vlan trunk encapsulation: dot1q

Administrative private-vlan trunk normal VLANs: none

Administrative private-vlan trunk private VLANs: none

Operational private-vlan: none

Trunking VLANs Enabled: 1,99,200

Pruning VLANs Enabled: 2-1001

Capture Mode Disabled

Capture VLANs Allowed: ALL

Protected: false

Unknown unicast blocked: disabled

Unknown multicast blocked: disabled

Appliance trust: none



IBM/Cisco IGESM:

----------------


Name: Gi0/20

Switchport: Enabled

Administrative Mode: trunk

Operational Mode: trunk

Administrative Trunking Encapsulation: dot1q

Operational Trunking Encapsulation: dot1q

Negotiation of Trunking: On

Access Mode VLAN: 200 (Workstation VLAN)

Trunking Native Mode VLAN: 200 (Workstation VLAN)

Voice VLAN: none

Administrative private-vlan host-association: none

Administrative private-vlan mapping: none

Administrative private-vlan trunk native VLAN: none

Administrative private-vlan trunk encapsulation: dot1q

Administrative private-vlan trunk normal VLANs: none

Administrative private-vlan trunk private VLANs: none

Operational private-vlan: none

Trunking VLANs Enabled: 1,99,200

Pruning VLANs Enabled: 2-1001

Capture Mode Disabled

Capture VLANs Allowed: ALL

Protected: false

Unknown unicast blocked: disabled

Unknown multicast blocked: disabled

Appliance trust: none



For my test, I try to ping a blade (connected to IGESM) in VLAN 200 from a workstation connected to Catalyst 2960 (in VLAN 200 too). From a network anaylser (ethereal), I can see the ARP broadcast from each side but none are going across the trunk link.


I am a bit lost about this problem and would be grateful for any assistance in solving it!


Many, many thanks in advance for your time!


Best regards,


Fabian


Correct Answer by Edison Ortiz about 10 years 10 months ago

Fabian,


I noticed something strange in your Spanning-Tree configuration. Both switches are running a different spanning tree protocol, cisco running ieee and ibm running rspt. They are also showing themselves as Root bridge for each VLAN. This may be causing your trunk link problem. Can you change the ibm switch to run ieee ?


Thanks


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
Edison Ortiz Mon, 10/02/2006 - 08:11
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Let's see the vlan and vtp configuration from each switch with 'show vlan' and 'show vtp status' output.

glen.grant Mon, 10/02/2006 - 08:53
User Badges:
  • Purple, 4500 points or more

Probably have to post a "show run" for both boxes to see what the problem is . From what you have posted it looks ok , but that doesn't show everything . Also post a "show vlan" and a show int trunk" command for both sides.

sourabhagarwal Tue, 10/03/2006 - 02:05
User Badges:
  • Gold, 750 points or more

I can see from your config that there is a SPAN session on cisco and IBM switch


Cat 2960:-

monitor session 1 source interface Gi0/1

monitor session 1 destination interface Fa0/3 encapsulation replicate


IGESM:-

monitor session 1 source interface Gi0/20

monitor session 1 destination interface Gi0/17


i would say to remove these SPAN session if not in use from both switches and then see if there is any traffic over trunk link.


can you see interface status of gi0/1 and gi0/20 on cisco and IGESM respectively and confirm if they are UP.

Hi (and thanks for your reply)!


Yes, I did configure a SPAN session on each switch to listen to network traffic. I wanted to know if VLAN traffic was going through the trunk link. Using Etherearl, I have seen that VLAN traffic was going to the trunk port but not further (not to the next switch).


I had the trunk issue before having configured the SPAN sessions. They are actually there for debug purpose only.


Yes, both interfaces are up: "show interface" tells me that the interfaces are up as well as the protocol.


Fabian


glen.grant Tue, 10/03/2006 - 04:30
User Badges:
  • Purple, 4500 points or more

Try setting the native vlan on the blades the same as the trunk link (vlan 200) , they are currently different , this may be causing your problem . Not sure why you have them set as vlan 2 as vlan 2 is not even allowed across your trunk .

Hi Glen!


Both switches (Catalyst 2960 & IGESM) are brand new and most ports are still reflecting manufacturer's default configuration. Vlan 2 is the default native vlan for IGESM ports (excluding ports used for switch management which use vlan 1 as most Cisco switches).


I changed the native vlan for g0/5 on IGESM to 200. Now, ports g0/5 (access mode) and g0/20 (trunk mode) are on native vlan 200. On g0/5 is installed Windows 2003 instance (firewall disabled). The only purpose is to receive and send ping request to test connectivity.


My workstation is connected to 2960 switch on port fa0/1 (please find the configuration below). I can successfully ping other vlan 200 machines connected on the same switch. For testing purpose, I try to ping the blade machine connected on port g0/5 on IGESM.


Configuration of fa0/1:

-----------------------


Name: Fa0/1

Switchport: Enabled

Administrative Mode: dynamic auto

Operational Mode: static access

Administrative Trunking Encapsulation: dot1q

Operational Trunking Encapsulation: native

Negotiation of Trunking: On

Access Mode VLAN: 200 (Workstation VLAN)

Trunking Native Mode VLAN: 200 (Workstation VLAN)

Administrative Native VLAN tagging: enabled

Voice VLAN: none

Administrative private-vlan host-association: none

Administrative private-vlan mapping: none

Administrative private-vlan trunk native VLAN: none

Administrative private-vlan trunk Native VLAN tagging: enabled

Administrative private-vlan trunk encapsulation: dot1q

Administrative private-vlan trunk normal VLANs: none

Administrative private-vlan trunk private VLANs: none

Operational private-vlan: none

Trunking VLANs Enabled: ALL

Pruning VLANs Enabled: 2-1001

Capture Mode Disabled

Capture VLANs Allowed: ALL


Protected: false

Unknown unicast blocked: disabled

Unknown multicast blocked: disabled

Appliance trust: none



Is there any other information I could provide to better help you to understand the configuration?


Cheers!


Fabian




Edison Ortiz Tue, 10/03/2006 - 08:04
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Fabian,


You mentioned you see the ARP replies from each end but you don't see this traffic passing the trunk link you've configured, which means you have another link between these 2 devices ? If so, perhaps the other link is set to FWD while this trunk link is set to BLK by the Spanning-Tree process.


Please post the output from typing 'show spanning-tree' from both switches.


Thanks


Hi Edison (& thanks for your help!)


My workstation (Windows XP w/o firewall) has IP 10.160.0.99 and is connected on catalyst 2960, interface fa0/1 (vlan 200 (static access mode)).

The server (Windows 2003 w/o firewall) has IP 10.160.0.96 and is connected on IGESM, interface g0/5, vlan 200 (static access mode).

Catalyst 2960 is connected with g0/1 to g0/20 on IGESM (trunk mode).

I monitor 2960's g0/1 and IGESM's g0/20 using SPAN (and ethereal).



When i launch a continuous ping from 10.160.0.99 (connected on cat2960) to 10.160.0.96, I can see on cat2960's g0/1:

"arp who-has 10.160.0.96 tell 10.160.0.99". I don't see anything related to this arp broadcast from IGESM's g0/20.

If I do a continuous ping from 10.160.0.96 (IGESM) to 10.160.0.99, I get the same result (arp broadcasts arrive on g0/20 but not on cat2960's g0/1).



Please find attached the spanning-tree configuration for both switches.



Many thanks!


Kind regards,


Fabian



Correct Answer
Edison Ortiz Tue, 10/03/2006 - 11:02
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Fabian,


I noticed something strange in your Spanning-Tree configuration. Both switches are running a different spanning tree protocol, cisco running ieee and ibm running rspt. They are also showing themselves as Root bridge for each VLAN. This may be causing your trunk link problem. Can you change the ibm switch to run ieee ?


Thanks


Hahaaaaaaaa !


Hi Edison, hi all!


You were right!


As my configuration is quite simple and no loop can be generated, I have disabled spanning-tree on both IGESM and Cat2960 (I will enable it later).

Ethereal showed me much nicer packets with ARP broadcast coming from cat2960 and reaching IGESM. However, if ARP was good, the ping echo reply didn't get back to the echo request generating machine. I then did remember a comment I saw on a forum about gigabit ethernet and cable type. I swapped my cross-over cable for a standard ethernet cable and ... miracle, it worked fine!


To summary, my problem was related to a wrong cable type (cross-over instead of straight-through) and a wrong spanning-tree configuration (actually, I disabled it).


Many thanks for you help all, it was much appreciated!


best regards!


Fabian

glen.grant Wed, 10/04/2006 - 11:13
User Badges:
  • Purple, 4500 points or more

Gigabit has to have all 8 wires , anything less will not work as it balanced across all 4 pairs .

Actions

This Discussion