×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

BGP Datagram size

Answered Question
Oct 9th, 2006
User Badges:

Dear all,


on one of my router(MPLS Service) the BGP datagram size shows as

Datagrams (max data segment is 516 bytes)


and on another router(ISP Service) it shows

Datagrams (max data segment is 536 bytes):


Can anybody tell me the reason of such difference


Regards

Mahesh

Correct Answer by Harold Ritter about 10 years 10 months ago

The mtu of 516 is most likely due to the fact that you use MD5 authentication on this session. MD5 authentication adds 20 bytes of overhead in the TCP header, hence the MSS being reduced by 20 bytes.


Hope this helps,

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.5 (4 ratings)
Loading.
royalblues Tue, 10/10/2006 - 06:02
User Badges:
  • Green, 3000 points or more

536 is the default MSS (max segment size) for a TCP connection which is Very small considering the amount of data we transfer.


This can cause delays in BGP convergence.

Enable path MTU discovery and clear the BGP session

ip tcp path-mtu-discovery

clear ip BGP *


check the size now by

show ip bgp neighbor | include max data segment


http://www.cisco.com/en/US/products/ps6922/products_feature_guide09186a0080666002.html


HTH

Narayan




mamta.gohil Wed, 10/11/2006 - 01:57
User Badges:

I accept ,


But my basic question is on one of my router it shows 516 and another router it shows 536. why it is so?


i will enable mtu discovery once i take approval from customers..


so please provide me details of why it is 516 if document tells that default is 536


regards!!

royalblues Wed, 10/11/2006 - 02:25
User Badges:
  • Green, 3000 points or more

Mahesh,


Have you specified any MTU vlaue on any interface?


Narayan

mamta.gohil Wed, 10/11/2006 - 03:01
User Badges:

Dear Narayan,


I have not specified any MTU on interface


Regards!!

Correct Answer
Harold Ritter Wed, 10/11/2006 - 04:45
User Badges:
  • Cisco Employee,

The mtu of 516 is most likely due to the fact that you use MD5 authentication on this session. MD5 authentication adds 20 bytes of overhead in the TCP header, hence the MSS being reduced by 20 bytes.


Hope this helps,

mamta.gohil Wed, 10/11/2006 - 04:58
User Badges:

Thanks hritter and narayan for your extended support.


Regards!!


Mahesh

royalblues Wed, 10/11/2006 - 20:18
User Badges:
  • Green, 3000 points or more

Harold


Thanks for the information. Never thought this could be the reason


Narayan

Actions

This Discussion