4948 etherchannel or LACP to Intel Quad GigE NIC configuation issues

Unanswered Question
Oct 13th, 2006
User Badges:

We are trying to combine four gigE ports from a 4948 to a server with an Intel quad gigE nic so that we have 4 gbps throughput.


We have tried both etherchannel and LACP. The max throughput we can achieve is 1 gpbs. Almost all of the traffic is going through nic #4.

Then I noticed that when we do a sho int port-channel xx that the speed for the port-channel is 1000 mbps. I tried changing bandwidth in the port-channel interface and that did not help.


What are we doing wrong?


Running Version 12.2(25)EWA4


here is the config:


interface Port-channel31

description etherchannel down to stream 29 interface 20 22 24 26

bandwidth 10000000

ip address 1.2.3.153 255.255.255.248

duplex full

!


interface GigabitEthernet1/20

description stream 29 etherchannel 29 A

no switchport

no ip address

logging event link-status

duplex full

no cdp enable

channel-protocol lacp

channel-group 31 mode active


interface GigabitEthernet1/26

description stream 29 etherchannel 29 D

no switchport

no ip address

no ip redirects

no ip unreachables

logging event link-status

duplex full

no cdp enable

channel-protocol lacp

channel-group 31 mode active

end


and as I said above, the port-channel shows a 1000 mbps speed


sh int port-channel 31

Port-channel31 is up, line protocol is up (connected)

Hardware is EtherChannel, address is 0018.73b1.0f3f (bia 0018.73b1.0f3f)

Description: etherchannel down to stream 29 interface 20 22 24 26

Internet address is 1.2.3.153/29

MTU 1500 bytes, BW 10000000 Kbit, DLY 10 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 1000Mb/s, media type is N/A

input flow-control is off, output flow-control is unsupported

Members in this channel: Gi1/20 Gi1/22 Gi1/24 Gi1/26



========================================

And when we try it with etherchannel:


interface Port-channel27

description etherchannel down to stream 27 interface 12 14 16 18

ip address 1.2.3.65 255.255.255.240

duplex full

end


interface GigabitEthernet1/12

description stream 27 etherchannel 27 A

no switchport

no ip address

logging event link-status

duplex full

channel-group 27 mode active



nterface GigabitEthernet1/18

description stream 27 etherchannel 27 D

no switchport

no ip address

logging event link-status

duplex full

channel-group 27 mode active


sho int port-channel 27

Port-channel27 is up, line protocol is up (connected)

Hardware is EtherChannel, address is 0018.73b1.0f3f (bia 0018.73b1.0f3f)

Description: etherchannel down to stream 27 interface 12 14 16 18

Internet address is 1.2.3.65/28

MTU 1500 bytes, BW 4000000 Kbit, DLY 10 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 1000Mb/s, media type is N/A

input flow-control is off, output flow-control is unsupported

Members in this channel: Gi1/12 Gi1/14 Gi1/16 Gi1/18



What are we missing?


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
glen.grant Fri, 10/13/2006 - 09:18
User Badges:
  • Purple, 4500 points or more

Is the etherchannel actually working ? show etherchannel detail . If you look at the port channel it says BW 4000000 Kbit . You have to remember this is a little misleading because even though you have 4 gig of potential bandwidth any 1 conversation will only have access to one gig total . Etherchannel is more of a bandwidth sharing function as traffic gets balanced across all 4 links based on a algorithim based on the mac address I believe . So traffic is basically balanced across all 4 links based on either the mac address or the source or destination ip address , so any 1 conversation will always use the same link so it has access to 1 gig for that conversation along with whoever else happens to be using that link at the same time.

Actions

This Discussion