LMS2.5.1 to LMS2.6 upgrade issue

Unanswered Question
Oct 20th, 2006
User Badges:

I've a LMS2.5.1 with CS, CM and RME installed packages only (no DFM).


I would like to upgrade it to LMS 2.6 but it aborts because DFM 2.0.3 is not installed.


Do you know how I could install it without installing DFM ?


Patrice

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Joe Clarke Fri, 10/20/2006 - 08:27
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

What is the exact error you are receiving, and where in the install process do you see it? Was this 2.5.1 deployment an upgrade from LMS 2.1 or 2.2? Do you have an older, inactive version of DFM on the system?

ppoiron Mon, 10/23/2006 - 01:22
User Badges:

The message is:

Install Device Fault Manager 2.0.3 before updating to Device Fault Manager 2.0.6....


This message appears after extracting files and stopping WMI.


See the log:

Setup log file on this date 10-20-2006

...

INFO: checking CMDLINE % "REMOVE"

INFO: action action_uninstall skipped

INFO: action dfnmsverchange, begins at 17:27:41

INFO: action setupInstall, begins at 17:27:41

MAIN: SetupInstall START at 17:27:41

INFO: running installation of CiscoWorks LMS 2.6 Update

Normal mode installation, TAGS=cdone, cvw1, rme, cm, dfm, dfmnms, rsac

INFO-OVERRIDE: C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\CW2K.install file not found, normal installation mode

INFO: action AppInit, begins at 17:29:19

INFO: action CheckOS, begins at 17:29:19

------------ OS information -------------

OS : 5.0

Build: 2195

Service Pack: 3

NT type: ServerNT

Suite Mask: 0x110

...

Info: running in console session.

INFO: action initScreen, begins at 17:29:19

INFO: Screen title is: Installing CiscoWorks LMS 2.6 Update

...

QUESTION:Windows Management Instrumentation (WMI) is running

The setup program has detected Windows Management Instrumentation (WMI) services running.

This will lock some CiscoWorks processes and may abort installation abruptly.

To avoid this, installation will stop and start the WMI services.


Do you want to proceed?


Click Yes to proceed with this installation.

Click No to exit installation.

USER ANSWER: YES

INFO: action checkRequiredInstall, begins at 17:29:26

INFO: action Check_CS_SPInstall, begins at 17:29:26

INFO: action checkOptionalInstall, begins at 17:29:26

INFO: action CheckForIIS, begins at 17:29:26

W3SVC is not installed

INFO: action runInitHooks, begins at 17:29:26

Executing INIT hooks

INFO: action initStandardDialogs, begins at 17:29:26

INFO: answer file is not specified

INFO: NMSROOT already set to c:\LMS

INFO: action initDynChoice, begins at 17:29:26

INFO: comparing the version of installed package cdone (3.0.4) to 3.0.3

INFO: comparing the version of installed package cdone (3.0.4) to 3.0.5

INFO: comparing the version of installed package cvw1 (6.1.4) to 6.1.2

INFO: comparing the version of installed package cvw1 (6.1.4) to 6.1.5

INFO: comparing the version of installed package rme (4.0.4) to 4.0.3

INFO: comparing the version of installed package rme (4.0.4) to 4.0.5

INFO: comparing the version of installed package cm (4.0.5) to 4.0.3

INFO: comparing the version of installed package cm (4.0.5) to 4.0.6

INFO: comparing the version of installed package dfm (1.2.3) to 2.0.3

INFO: package dfmnms has not been installed before

INFO: package dfmnms has not been installed before

INFO: package rsac has not been installed before

INFO: package rsac has not been installed before

MESSAGE

Install Device Fault Manager 2.0.3 before updating to Device Fault Manager 2.0.6.

See the ReadMe and the Installation Guide for details.

INFO: action action_endInstall, begins at 17:29:43

MAIN: CleanUpInstall START at 17:29:43

INFO: finishing installation, ABORT_FLAG is set

...


You're right about DFM. On this platform, I installed a DFM package in LMS 2.2 that I desinstalled after a while. And this platform has been migrated from LMS 2.2 to LMS2.5.1.


Now, DFM does not appear in the installed products of Software Update, but I saw dfm directories in the application.


Do you know a method to bypass this error without reinstalling completely the platform ?


And I have a last question. I don't see Campus Manager 4.0.6 on the TAC, but a 4.0.7.


Does it replace 4.0.6 ?


And what is the order to install LMS2.6 and CM 4.0.7 ?


Thank in advance for your help.


Patrice.

ppoiron Tue, 10/24/2006 - 08:26
User Badges:

To fix that issue on my lab platform, I installed DFM 2.0 then LMS 2.5.1 update and finally LMS 2.6 update and CM4.0.7.


But, on my customer platform, I will not have DFM installed. So, has someone experienced of an installtion of LMS 2.6 update on a CW2K platform with Common Services, Campus Manager and RME installed only ?


Thanks in advance for your help,


Patrice



Joe Clarke Tue, 10/24/2006 - 09:49
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

To work around the DFM problem (because of the old 1.2), you will need to install DFM 2.0.3 from LMS 2.5.1, then remove DFM. Then you should be able to apply the LMS 2.6 update.


As to your other Campus Manager question, CM 4.0.6 is part of LMS 2.6. CM 4.0.7 is a device support patch that can be applied on top of LMS 2.6. It does have a few bug fixes, but it is mostly geared towards adding new device support.

Actions

This Discussion