QoS Config

Unanswered Question
Oct 21st, 2006
User Badges:

Hello Expert,

Could some one please let me know if the following config is a proper QoS config for a 3560 and a 3750? Any better suggetion is strogly welcome.


mls qos map dscp-cos 16 to 1


mls qos map dscp-cos 24 26 to 2


mls qos map dscp-cos 32 to 3


mls qos map dscp-cos 40 to 4


mls qos map cos-dscp 0 8 16 24 32 46 48 56


mls qos map ip-prec-dscp 0 8 16 24 32 46 48 56


mls qos





The following is for interfaces:





interface FastEthernet0/8


switchport access vlan 100


switchport mode trunk


switchport voice vlan 101


switchport trunk encapsulation dot1q


switchport trunk native vlan 100


mls qos trust device cisco-phone


spanning-tree portfast



Thanks,

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (4 ratings)
Loading.
thisisshanky Sat, 10/21/2006 - 17:59
User Badges:
  • Purple, 4500 points or more

Here is a sample config. 3750/3560 share the same qos config. You dont need to configure the port as a trunk any more (even thought that will work).


interface FastEthernet1/0/1

switchport access vlan 40

switchport mode dynamic desirable

switchport voice vlan 50

srr-queue bandwidth share 1 70 25 5

srr-queue bandwidth shape 3 0 0 0

priority-queue out

mls qos trust device cisco-phone

mls qos trust cos

macro description PhonePCPort | PhonePCPort

spanning-tree portfast




mls qos map policed-dscp 0 24 to 8

mls qos map cos-dscp 0 8 16 24 34 46 48 56

mls qos srr-queue output cos-map queue 1 threshold 3 5

mls qos srr-queue output cos-map queue 2 threshold 1 2 4

mls qos srr-queue output cos-map queue 2 threshold 2 3

mls qos srr-queue output cos-map queue 2 threshold 3 6 7

mls qos srr-queue output cos-map queue 3 threshold 3 0

mls qos srr-queue output cos-map queue 4 threshold 3 1

mls qos srr-queue output dscp-map queue 1 threshold 3 46

mls qos srr-queue output dscp-map queue 2 threshold 1 34 36 38

mls qos srr-queue output dscp-map queue 2 threshold 2 24 26

mls qos srr-queue output dscp-map queue 2 threshold 3 48 56

mls qos srr-queue output dscp-map queue 3 threshold 3 0

mls qos srr-queue output dscp-map queue 4 threshold 1 8

mls qos queue-set output 1 threshold 2 70 80 100 100

mls qos queue-set output 1 threshold 4 40 100 100 100

mls qos


You may refer to QOS SRND for qos commands.


Sankar.


PS: please remember to rate posts!


bahman.tajkarim... Sat, 10/21/2006 - 18:59
User Badges:

Thanks Sankar,

Isn't this the output of the auto qos?


Could you please let me know why we don't need to configure the port as a trunk?


Sankar, As you have been anwering all my questions in this forum, let me ask you another question.

I am installing a 4.2 Unity but am missing the Date store and Message store CD's. I have those CD's for 4.0 version. Can I use them to install the Data Store and Message Store and then continue with 4.2 installation? Are those software the same for both version?

And when I am done with 4.2 installation, the only remaning task after integrating the Unity with the CCM is to add users? Am I right? Is there anything else that I have to take care of it


Thanks,

thisisshanky Sun, 10/22/2006 - 06:37
User Badges:
  • Purple, 4500 points or more

Bahman,


The config i pasted was developed out of QOS SRND based on the following quidelines. This may look similar to auto qos but not exactly the same. Refer to QOS SRND for more details.


http://www.cisco.com/application/pdf/en/us/guest/netsol/ns432/c649/ccmigration_09186a008049b062.pdf


1. Each port of a 3750/3560 has 4 egress queues.

2. 2 ingress queues (no need to enable this, as both queues get activated only if the sum of bandiwdths of all ports exceed the switch backplane)

3. Each port can be configured with shaped mode or shared mode.

4. q1 is priority queue.

5. Configure q2,3,4 in shared mode (recommended and default).

6. Shared mode weights 70,25,5 should be assigned to 2,3,4 queues.


7. srr-queue bandwidth share 1 70 25 5 (q2 gets 70 percent of remaining bandwidth, q3 gets 25 percent of remaining bw, q4 gets 5 percent of rem. traffic)

8. srr-queue bandwidth shape 3 0 0 0 (q2,3,4 runs in shared mode). Q1 is shaped to 1/3 of remaining bandwidth.


9. q2 and 4 can be enabled with Weighted Tail drop per queue. two thresholds are configurable (explicit) one is not (implicit)

10. For q2 set first threshold to 70, second to 80, third is 100 by default

11. For q4 set first threshold to 40, leaving second and third at 100

12. Map cos0/dscp0 to q3,threshold 3

13. Cos 3 should go to q2, threshold 2

14. Cos 4 (video) should go to q2, threshold 1

15. Cos 5 should go to q1 threshold 3



From this document,


http://www.cisco.com/en/US/products/sw/voicesw/ps2237/prod_system_requirements_hardware09186a008061eb2a.html


it says that you need SQL 2000 SP4. You can use the Datastore discs from 4.0 cd kit and then update the software to Service pack 4. You can get this from 4.2 service pack discs.


If your OS is not Win2003, you can use the message store discs from 4.0 cd kit (Exch. 2000)


HTH


Sankar


PS: please remember to rate posts!

bahman.tajkarim... Sun, 10/22/2006 - 18:07
User Badges:

Thanks Sankar,

In the previous posting you mentionned that I don't need to configure the ports a Trunk. Could you please let me know what is the reason? Why would you prefer dynamic mode or access mode?


Thanks,

royalblues Sun, 10/22/2006 - 19:44
User Badges:
  • Green, 3000 points or more

Hi Friend,


When you use the switchport voice vlan command a special-case 802.1Q trunk automatically is enabled through a CDP information exchange between the switch and the IP Phone. The trunk contains only two VLANs a voice VLAN (tagged VVID) and the data VLAN. The switch port's access VLAN is used as the data VLAN that carries packets to and from a PC that is connected to the phone's PC port.


If an IP Phone is removed and a PC is connected to the same switch port, the PC still will be capable of operating because the data VLAN still will appear as the access VLAN even though the special trunk no longer is enabled


since the trunk is automatically negotiated there is no need to specifically configure it when using cisco ip phones (provided CDP is enabled)


The trunk configuration is required though if you use IP phones from other manufacturers like avaya, nortel etc as they cannot exchange CDP information.


HTH, rate if it does

Narayan



bahman.tajkarim... Mon, 10/23/2006 - 05:52
User Badges:

Thanks Narayan for this excellent explanation,

Would that apply to the ports where servers (CCM, Unity)are connected too? My servers are in the Voice Vlan.


Thanks,


thisisshanky Mon, 10/23/2006 - 06:30
User Badges:
  • Purple, 4500 points or more

Bahman,


For servers you dont need to setup any voice vlans on the port, you can configure the port as an access port, but use the voice vlan number instead of the data vlan.


int fa0/1

switchport access vlan 40

spanning-tree portfast.


HTH


Sankar.

Actions

This Discussion