×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

cisco 831

Unanswered Question
Oct 24th, 2006
User Badges:

I am unable to access cox internet through cable modem. I cannot upgrade IOS because I can't re-partition webflash to use for upgraded IOS.

version 12.2

no service pad

service timestamps debug uptime

service timestamps log

uptime

service password-encryption

!

hostname CISCO

!

no logging buffered

enable secret 5

********************************!


ip dhcp pool CLIENT

network 10.1.42.0

255.255.255.0

default-router 10.1.42.10

dns-server 68.1.x.x.1.208.30

lease

0 2

!

ip audit notify log

ip audit po max-events 100

!

partition flash 2 6 2

!

!

!

!

interface Ethernet0

description CRWS Generated text. Please do not delete

this:10.1.42.10-255.255.255.0

ip address 10.1.42.10 255.255.255.224

ip nat inside

no cdp

enable

hold-queue 32 in

hold-queue 100 out

!

interface Ethernet1

ip address *.*.*.*

ip nat outside

no ip mroute-cache

no cdp enable

!

!

!

line con 0

exec-timeout 120 0

no modem enable

stopbits 1

line

aux 0

transport input all

stopbits 1

line vty 0 4

exec-timeout 120 0

login local

length

0

!

scheduler max-task-time 5000

end

!

end



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
ajagadee Tue, 10/24/2006 - 13:51
User Badges:
  • Cisco Employee,

Josh,


Are you saying that you are not able to ping anything on the internet from the router itself or from PC's behind the router.


If you are not able to access the internet from PC's behind the router, then you need to configure NAT on the 831, so your private IP Address will be translated to a routable public ip address.


Sample Configuration:


Inside Interface

Interface Ethernet0

ip nat inside


Outside Interface

Interface Ethernet1

ip nat outside


access-list 100 permit ip 10.1.42.0 0.0.0.255 any

ip nat inside source list 100 interface Ethernet1 overload


The above configuration will allow all 10.1.42.x address to be Port Address Translated to the Ethernet1 Public IP Address.


Now, if you are not able to ping anything on the internet from the router itself, then I would check and make sure that Ethernet1 is configured with a valid IP Address. Is ethernet1 statically configured with a routable IP Address or does it get the ip address via DHCP.


Let me know if it helps.


Regards,

Arul



Actions

This Discussion