What's normal broadcast traffic on switches running PVST or PVST+

Unanswered Question
Nov 8th, 2006
User Badges:
  • Bronze, 100 points or more

We have a 6500 and 4500, connected via a Dot11Q trunk. PVST is enabled on both ends. Here are the applicable config lines:


6500 (Sup720, 12.2(18)SXD7):


spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

!

interface GigabitEthernet3/48

no ip address

switchport

switchport access vlan 2

switchport trunk native vlan 2

switchport mode trunk

switchport voice vlan 811

!


4500 (SupIV, 12.2(31)SG):


spanning-tree mode pvst

spanning-tree extend system-id


interface GigabitEthernet2/1

switchport access vlan 2

switchport trunk encapsulation dot1q

switchport trunk native vlan 2

!


It seems to be working, despite the 6500 being set as a trunk and 4500 being set as an access port. However when attached to the 6500 and running EtherReal, I see PVST+ packets being sent to the interface on my PC at a rate of about 10 every second. On the 4500, I see only the expected ARP broadcasts.


Is this type of traffic normal for PVST, or is this definitely a misconfiguration I should fix?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3.5 (2 ratings)
Loading.
amit-singh Wed, 11/08/2006 - 21:32
User Badges:
  • Blue, 1500 points or more

Hi,


Can you Please paste the output of " Show interface gig 3/48 switchport" and Show interface gig 2/1 switchport "


It is working because both the links have auto-negotiated the trunk. We will be able to clarify after looking at the outputs of the above commands requested.


HTH,

-amit singh


johnnylingo Thu, 11/09/2006 - 09:29
User Badges:
  • Bronze, 100 points or more

Sure, here is from the 6500:


Name: Gi3/48

Switchport: Enabled

Administrative Mode: trunk

Operational Mode: trunk

Administrative Trunking Encapsulation: dot1q

Operational Trunking Encapsulation: dot1q

Negotiation of Trunking: On

Access Mode VLAN: 2 (VLAN0002)

Trunking Native Mode VLAN: 2 (VLAN0002)

Voice VLAN: 811 (VLAN0811)

Administrative private-vlan host-association: none

Administrative private-vlan mapping: none

Administrative private-vlan trunk native VLAN: none

Administrative private-vlan trunk encapsulation: dot1q

Administrative private-vlan trunk normal VLANs: none

Administrative private-vlan trunk private VLANs: none

Operational private-vlan: none

Trunking VLANs Enabled: ALL

Pruning VLANs Enabled: 2-1001

Capture Mode Disabled

Capture VLANs Allowed: ALL

Voice VLAN: 811 (VLAN0811)

Appliance trust: none


And from the 4500:


Name: Gi2/1

Switchport: Enabled

Administrative Mode: dynamic auto

Operational Mode: trunk

Administrative Trunking Encapsulation: dot1q

Operational Trunking Encapsulation: dot1q

Negotiation of Trunking: On

Access Mode VLAN: 2 (VLAN0002)

Trunking Native Mode VLAN: 2 (VLAN0002)

Administrative Native VLAN tagging: enabled

Voice VLAN: none

Administrative private-vlan host-association: none

Administrative private-vlan mapping: none

Administrative private-vlan trunk native VLAN: none

Administrative private-vlan trunk Native VLAN tagging: enabled

Administrative private-vlan trunk encapsulation: dot1q

Administrative private-vlan trunk normal VLANs: none

Administrative private-vlan trunk associations: none

Administrative private-vlan trunk mappings: none

Operational private-vlan: none

Trunking VLANs Enabled: ALL

Pruning VLANs Enabled: 2-1001

Capture Mode Disabled

Capture VLANs Allowed: ALL

Unknown unicast blocked: disabled

Unknown multicast blocked: disabled

Appliance trust: none

amit-singh Thu, 11/09/2006 - 09:37
User Badges:
  • Blue, 1500 points or more

Hi,


As suggested in earlier post, It is working as both the interface has negotiated on the trunk mode using DTP (Dynamic trunking protocol) which is enabled by default on the switch interfaces. Check the " operational Mode:Trunk" and " negotiation of Trunking:ON" status.


Switch sends the STP Bpdu out all the switch interfaces.So when you are using sniffer on the port and looking up some of the STP traffic that is normal.


HTH, Please rate if it does.


-amit singh

johnnylingo Thu, 11/09/2006 - 12:47
User Badges:
  • Bronze, 100 points or more

Interesting. Would MIST or RSTP have the same behavior?

glen.grant Thu, 11/09/2006 - 16:11
User Badges:
  • Purple, 4500 points or more

RSTP would don't know about mist . A few spanning tree packets on aport is not going to hurt anything performance wise on a 100 meg port . It will save your behind if someone miswires something .

johnnylingo Fri, 11/10/2006 - 11:24
User Badges:
  • Bronze, 100 points or more

I guess my question is why are the PVST+ packets being seen on the 6500 but not the 4500?


Another odd thing I noticed is the spanning tree root appears to be set to a Dell switch inside a blade server. Obviously, our spanning tree root should be the 6500 and I'm working on correcting that.

Actions

This Discussion