×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Strange Lan Problem --HELP

Answered Question
Nov 8th, 2006
User Badges:

In my company, we have a Core-Layer3 switch, and configured the netwrok into some VLANs.

There is a new computer installed with 2 NICs,one ip is set to VLAN2 (192.168.1.79/24), and another is set

to VLAN100(192.168.100.79/24) and all the VLAN setting on switch is correct.

In my office ,I could ping 192.168.1.79, but i couldn't ping 192.168.100.79, but i could ping 192.168.100.9

(another computer),and on computer 192.168.100.9 I could ping 192.168.100.79...


The Trace information as following,(192.168.1.35 is core layer3 switch)

The IP of tracing computer I used to trace is 192.168.1.170 (VLAN2)


Tracing route to monitor.bbb.com [192.168.100.9]

over a maximum of 30 hops:


1 <1 ms <1 ms <1 ms sha_h_td7172.bbb.com [192.168.1.35]

2 <1 ms <1 ms <1 ms monitor.bbb.com [192.168.100.9]


Trace complete.


C:\Documents and Settings\sheldonwu>tracert 192.168.100.79


Tracing route to 192.168.100.79 over a maximum of 30 hops


1 <1 ms <1 ms <1 ms sha_h_td7172.bbb.com [192.168.1.35]

2 * * * Request timed out.

3 * * * Request timed out.

4 * * * Request timed out.

5 * ^C

C:\Documents and Settings\sheldonwu>


Core Layer3 Switch Routing as follwing.


C 192.168.241.0/24 is directly connected, Vlan241

C 192.168.247.0/24 is directly connected, Vlan52

C 192.168.246.0/24 is directly connected, Vlan51

C 192.168.200.0/24 is directly connected, Vlan200

C 192.168.1.0/24 is directly connected, Vlan2

C 192.168.100.0/24 is directly connected, Vlan100

S* 0.0.0.0/0 [1/0] via 192.168.1.10

C 192.168.242.0/23 is directly connected, Vlan70

C 192.168.244.0/23 is directly connected, Vlan60


And I could ping 192.168.100.79 on Core Layer3 Switch...

Could someone tell me the reason ?? ....


Correct Answer by Endwigast about 10 years 9 months ago

the reason you could ping 192.168.1.79 is because it is configured with a gateway.

the reson you could ping 192.168.100.79 from 192.168.100.9 is because they are on the same subnet, 100.9 doesn't need to go through a gateway to get to 100.79.

the reason you could not ping 192.168.100.79 from other vlans is because the nic with the 100.79 ip doesn't have a gateway configured.

the reason you could not configure 100.9 with a gateway is because windows doesn't allow 2 nic's with both configured with a gateway

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Sureshdank Wed, 11/08/2006 - 19:29
User Badges:

You are not able to ping 192.168.100.79 from the new computer right but you are able to ping other hosts in that subnet.


Have you configured both interfaces of PC with gateways of their vlan IP.


Regards,

Suresh Jain

sheldon.wu Wed, 11/08/2006 - 19:54
User Badges:

Yes, I configured, I don't konw why in the same subnet I just could ping one....

amit-singh Wed, 11/08/2006 - 20:50
User Badges:
  • Blue, 1500 points or more

Hi There,


Have you enabled the NIC Teaming on the PC ?


What happens if you disconnect the other link 192.168.1.79. Can you reach 192.168.100.79 ?

Can other PC in the same Vlan 100 ping 192.168.10.79?


Post the switch config.


-amit singh





sheldon.wu Thu, 11/09/2006 - 01:04
User Badges:

If I disconnect the 192.168.1.79, I still couldn't ping the 192.168.100.79. And Vlan100's computer could ping 192.168.100.79

So ...very strange...

kiran_8095 Wed, 11/08/2006 - 22:10
User Badges:

Hi


Is it a windows PC, if yes then give route print in the command prompt. Please post the output.

sheldon.wu Thu, 11/09/2006 - 01:00
User Badges:

My L3 Switch configuration as following: (Part1)


SW-7F-CORE01#show run

Building configuration...


Current configuration : 7699 bytes

!

! Last configuration change at 01:43:10 UTC Thu Nov 9 2006

! NVRAM config last updated at 03:36:21 UTC Fri Oct 13 2006

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

service compress-config

!

hostname SW-7F-CORE01

!

boot-start-marker

boot-end-marker

!

enable secret xxx

!

no aaa new-model

ip subnet-zero

no ip domain-lookup

ip domain-name bbb.com

ip name-server 192.168.1.43

!

no ip dhcp snooping information option

ip dhcp-server 192.168.1.43

!

no file verify auto

!

spanning-tree mode pvst

spanning-tree extend system-id

spanning-tree vlan 2,51,70,200,241 priority 24576

spanning-tree vlan 52,60,100,500 priority 28672

power redundancy-mode redundant

!

!

!

vlan internal allocation policy ascending

!

interface Port-channel1

description Etherchannel_To_sha-6f-C4948-L3-sw02

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/1

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/2

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/3

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/4

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/5

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/6

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/7

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/8

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/9

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/10

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/11

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/12

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/13

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/14

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/15

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/16

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/17

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/18

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/19

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/20

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/21

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/22

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/23

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/24

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/25

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/26

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/27

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/28

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/29

switchport trunk encapsulation dot1q

switchport mode trunk

!


sheldon.wu Thu, 11/09/2006 - 01:02
User Badges:

(Part2)

interface GigabitEthernet1/30

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/31

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/32

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/33

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/34

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/35

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/36

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/37

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/38

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/39

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/40

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/41

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/42

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/43

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode on

!

interface GigabitEthernet1/44

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode on

!

interface GigabitEthernet1/45

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/46

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/47

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/48

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface Vlan1

no ip address

shutdown

!

interface Vlan2

ip address 192.168.1.58 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

standby 2 ip 192.168.1.3

standby 2 priority 110

standby 2 preempt

!

interface Vlan51

ip address 192.168.246.2 255.255.255.0

ip helper-address 192.168.1.43

no ip redirects

no ip unreachables

no ip proxy-arp

standby 51 ip 192.168.246.1

standby 51 priority 110

standby 51 preempt

!

interface Vlan52

ip address 192.168.247.2 255.255.255.0

ip helper-address 192.168.1.43

no ip redirects

no ip unreachables

no ip proxy-arp

standby 52 ip 192.168.247.1

standby 52 priority 90

standby 52 preempt

!

interface Vlan60

ip address 192.168.244.2 255.255.254.0

ip helper-address 192.168.1.43

no ip redirects

no ip unreachables

no ip proxy-arp

standby 60 ip 192.168.244.1

standby 60 priority 90

standby 60 preempt

!

interface Vlan70

ip address 192.168.242.2 255.255.254.0

ip helper-address 192.168.1.43

no ip redirects

no ip unreachables

no ip proxy-arp

standby 70 ip 192.168.242.1

standby 70 priority 110

standby 70 preempt

!

interface Vlan100

ip address 192.168.100.17 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

standby 100 ip 192.168.100.1

standby 100 priority 90

standby 100 preempt

!

interface Vlan200

ip address 192.168.200.18 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

standby 200 ip 192.168.200.1

standby 200 priority 110

standby 200 preempt

!

interface Vlan241

ip address 192.168.241.1 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

!

ip route 0.0.0.0 0.0.0.0 192.168.1.10

ip http server

!

!

banner login ^C

^C

!

line con 0

exec-timeout 30 0

stopbits 1

line vty 0 4

exec-timeout 20 0

password 7 0832584B051504

login

line vty 5 15

exec-timeout 5 0

password 7 05080F1C2243

login

!

end


SW-7F-CORE01#

sheldon.wu Thu, 11/09/2006 - 01:08
User Badges:

Ooh~ when I down the 192.168.1.79~~and another ip could be ping... Maybe it's so called teaming ...But how could I disable it?

The os I used is Debian(sarge), Thanks.

sheldon.wu Thu, 11/09/2006 - 01:19
User Badges:

But when the two NICs are up ,VLAN100 could ping the 192.168.100.79..... And on this computer, I only set the gateway 192.168.100.1, configuration is following:

Kernel IP routing table

Destination Gateway Genmask Flags Metric Ref Use Iface

localnet * 255.255.255.0 U 0 0 0 eth0

localnet * 255.255.255.0 U 0 0 0 eth2

default 192.168.100.1 0.0.0.0 UG 0 0 0 eth0


with it, I could ping other VLAN's computer.

Correct Answer
Endwigast Thu, 11/09/2006 - 06:25
User Badges:

the reason you could ping 192.168.1.79 is because it is configured with a gateway.

the reson you could ping 192.168.100.79 from 192.168.100.9 is because they are on the same subnet, 100.9 doesn't need to go through a gateway to get to 100.79.

the reason you could not ping 192.168.100.79 from other vlans is because the nic with the 100.79 ip doesn't have a gateway configured.

the reason you could not configure 100.9 with a gateway is because windows doesn't allow 2 nic's with both configured with a gateway

royalblues Thu, 11/09/2006 - 21:15
User Badges:
  • Green, 3000 points or more

In response to the above post, if you want the connectivity you could add a route on the machine with dual nic



Actions

This Discussion