851W configuration problem

Unanswered Question

Hi all,


I'm trying to setup a 851W router as a wireless AP and I have no previous experience, so sorry in advance if I ask dumb questions! :) I have otherwise a lot of experience with Cisco but I just started using the wireless hardware.

Basically I have a SOHO setup with a DSL modem and static IPs. FastEthernet4 is the outside and the inside network (VLAN1) is 10.100.1.x/24. I used SDM to configure the wireless portion and I can actually connect using the laptop, but I do not get a DHCP address. I would like to obtain an address from the configured pool but it doesn't work and I'm not sure where the problem is, any idea? I don't understand the whole concept about wireless configuration and bridging, etc. If someone has some links that I could look at that would be great.

Also what security do you recommend WEP or WPA, and how I do I configure them?

Here's a copy of the config, let me know if you can help! Thanks


version 12.3

no service pad

service timestamps debug datetime localtime

service timestamps log datetime localtime

service password-encryption

!

hostname MJ851W

!

boot-start-marker

boot-end-marker

!

logging buffered 65536 debugging

enable secret

!


no aaa new-model

ip subnet-zero

ip dhcp excluded-address 10.100.1.254

ip dhcp excluded-address 10.100.1.101 10.100.1.254

!

ip dhcp pool CLIENT

import all

network 10.100.1.0 255.255.255.0

default-router 10.100.1.254

netbios-name-server 10.3.4.31 10.1.4.31

dns-server 10.3.4.12 10.1.4.12

lease 0 2

!

!

no ip cef

ip inspect name myfw cuseeme timeout 3600

ip inspect name myfw ftp timeout 3600

ip inspect name myfw rcmd timeout 3600

ip inspect name myfw realaudio timeout 3600

ip inspect name myfw smtp timeout 3600

ip inspect name myfw tftp timeout 30

ip inspect name myfw udp timeout 15

ip inspect name myfw tcp timeout 3600

ip inspect name myfw h323 timeout 3600

no ip domain lookup

ip domain name cisco.com

ip ssh maxstartups 2

no ftp-server write-enable

!

!

!

!

!

!

!

interface FastEthernet0

no ip address

no cdp enable

!

interface FastEthernet1

no ip address

no cdp enable

!

interface FastEthernet2

no ip address

no cdp enable

!

interface FastEthernet3

no ip address

no cdp enable

!

interface FastEthernet4

ip address 204.54.26.140 255.255.255.0

ip inspect myfw out

ip nat outside

ip virtual-reassembly

no ip mroute-cache

duplex auto

speed auto

no cdp enable

crypto map vpn

!

interface Dot11Radio0

no ip address

ip virtual-reassembly

!

encryption key 1 size 128bit 7 xxxxxxxxxxxxxxxxxxxxxxxxx transmit-key

encryption mode wep mandatory

!

ssid WIFI

authentication open

!

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0

station-role root

no dot11 extension aironet

no cdp enable

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface Vlan1

description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$

ip address 10.100.1.254 255.255.255.0

ip nat inside

ip virtual-reassembly

ip route-cache flow

ip tcp adjust-mss 1452

!

ip classless

ip route 0.0.0.0 0.0.0.0 204.54.26.141

ip route 10.1.0.0 255.255.0.0 FastEthernet4

ip route 10.3.0.0 255.255.0.0 FastEthernet4

ip route 10.20.0.0 255.255.0.0 FastEthernet4

ip route 10.100.3.0 255.255.255.0 10.3.1.254

!

ip http server

ip http authentication local

ip http secure-server

ip http secure-port 10080

ip http secure-ciphersuite rc4-128-sha

ip http timeout-policy idle 5 life 86400 requests 10000

ip nat inside source list 102 interface FastEthernet4 overload

!


no cdp run

!

control-plane

!

banner motd ^C


!

line con 0

login local

no modem enable

transport preferred all

transport output all

line aux 0

login local

transport preferred all

transport output all

line vty 0 4

privilege level 15

login local

transport preferred all

transport input telnet ssh

transport output all

!

scheduler max-task-time 5000

end


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Stephen Rodriguez Fri, 11/10/2006 - 08:25
User Badges:
  • Purple, 4500 points or more

You need to create a BVI 1 interface, move the IP address and all the other internal commands from the VLAN 1 interface to it, and then add the VLAN 1 interface to bridge group 1.

Actions

This Discussion