Recommended IOS and SIP Firmware Versions for use with Asterisk

Unanswered Question
Nov 14th, 2006
User Badges:
  • Bronze, 100 points or more

Hi All,


Implementing Asterisk PBX for a small office (CCM too expensive, CME not enough features), but will be using 7940/7960 SIP phones and an 2811 Voice Gateway with a VWIC2-1MFT-T1/E1 connected to the PSTN.


My question is what software versions would be recommend for the SIP Gateway and Phones? I'm not sure to go with 12.4 or 12.4T on the Gateway, and to use 7.5 or 8.4 for the SIP Phones. Any experience with a similar setup greatly appreciated.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
marcin_kuzmicki Tue, 11/14/2006 - 17:08
User Badges:

Go for highest possible software version on the phones. Use G711 codec all the way.

Last time I tested not all the features were working for 7.x SIP firmware (ie half of the features from xml applications was not working).

That's why you might want to check out chan_sccp for Asterisk and leave the SCCP firmware on the phone you'll have all the good features but... there might be some stability issues with chan_sccp :-)


Oh and don't forget to lest us know how did it go :-)



johnnylingo Wed, 11/15/2006 - 07:38
User Badges:
  • Bronze, 100 points or more

I'm definitely agreeing on the Phone firmware. 6.X had a call setup delay bug, 7.X has seemed fine and so has 8.X. I have a feeling they'll want to just stay with the SIP version for simplicity, but that's good to know.


It's the Gateway I'm more unsure about. In particular, I see 12.4(6)T has some features regarding SIP that isn't present in earlier version, such as SIP GW Support for Busy Out. But, I'd like to stick with the LD or GD release if possible.

johnnylingo Wed, 01/17/2007 - 12:03
User Badges:
  • Bronze, 100 points or more

I found a possible bug with IOS 12.4(6)T where call setup delay was happening. Unfortunately I couldn't identify any type of pattern in the calls. Changed to 12.4(7c) and all was well.

Actions

This Discussion