CISCO AIRONET 1200 RE-CONFIGURATION AFTER ERASE FLASH:???

Unanswered Question
Nov 25th, 2006

Hi ,

I have a CISCO 1200 AIRONET . I have been trying to configure them using to update the IOS and text files .

by mistake had used erase flash command !!

I can get basic commands including help, copy, boot, dir etc.

The prompt appears as shown below :

ap : help

? -- Present list of available commands

boot -- Load and boot an executable image

cat -- Concatenate (type) file(s)

copy -- Copy a file

delete -- Delete file(s)

dir -- List files in directories

flash_init -- Initialize flash filesystem(s)

format -- Format a filesystem

fsck -- Check filesystem consistency

help -- Present list of available commands

load_helper -- Load and initialize a helper image

memory -- Present memory heap utilization information

mkdir -- Create dir(s)

more -- Concatenate (display) file(s)

rename -- Rename a file

reset -- Reset the system

rmdir -- Delete empty dir(s)

set -- Set or display environment variables

set_param -- Set system parameters in flash

trap -- Cause a software breakpoint to occur

type -- Concatenate (type) file(s)

-- MORE --

unset -- Unset one or more environment variables

version -- Display boot loader version

ap :

**************************************

ap : dir

List of filesystems currently registered:

flash[0]: (read-write)

xmodem[1]: (read-only)

null[2]: (read-write)

bs[3]: (read-only)

I also tried using the following commands :

ap:flash_init

Initializing Flash...

...The flash is already initialized.

ap: load_helper

ap: boot

Loading ""...: permission denied

Error loading ""

Interrupt within 5 seconds to abort boot process.

Boot process failed...

ap:

*************************************

I also tried copying the ios through XModem and Flash but im unable to copy !!

ap: copy xmodem: flash

Unknown cmd: copy

ap: copy xmodem: flash:c2950-i6q4l2-mz.121-20.EA2.bin

Begin the Xmodem or Xmodem-1K transfer now...

CCCCCCCCCCBB0BB0xmodem:: I/O error

ap:

What May be the problem ? does any one have a solution for this !!

Thanks.

I have this problem too.
1 vote
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
scottmac Sun, 11/26/2006 - 08:16

Here's the process from this document on Cisco's main site (edited to fit the page):

http://www.cisco.com/en/US/products/hw/wireless/ps430/products_configuration_guide_chapter09186a00804e7d5c.html#wp1038660

:

Using the CLI

Step 1 Open the CLI using a Telnet session or a connection to the wireless device console port.

Step 2 Reboot the wireless device by removing power and reapplying power.

Step 3 Let the wireless device boot until it begins to inflate the image. When you see these lines on the CLI, press Esc:

Loading "flash:/c350-k9w7-mx.v122_13_ja.20031010/c350-k9w7-mx.v122_13_ja.20031010"

...########################################################################### ...

Step 4 When the ap: command prompt appears, enter the set command to assign an IP address, subnet mask, and default gateway to the wireless device.

Note You must use upper-case characters when you enter the IP-ADDR, NETMASK, and DEFAULT_ROUTER options with the set command.

Your entries might look like this example:

ap: set IP_ADDR 192.168.133.160

ap: set NETMASK 255.255.255.0

ap: set DEFAULT_ROUTER 192.168.133.1

Step 5 Enter the tftp_init command to prepare the wireless device for TFTP.

ap: tftp_init

Step 6 Enter the tar command to load and inflate the new image from your TFTP server. The command must include this information:

?the -xtract option, which inflates the image when it is loaded

?the IP address of your TFTP server

?the directory on the TFTP server that contains the image

?the name of the image

?the destination for the image (the wireless device Flash)

Your entry might look like this example:

ap: tar -xtract tftp://192.168.130.222/images/c350-k9w7-tar.122-13.JA1 flash:

Step 8 Enter the set BOOT command to designate the new image as the image that the wireless device uses when it reboots. The wireless device creates a directory for the image that has the same name as the image, and you must include the directory in the command. Your entry might look like this example:

ap: set BOOT flash:/c350-k9w7-mx.122-13.JA1/c350-k9w7-mx.122-13.JA1

Step 9 Enter the set command to check your bootloader entries.

ap: set

BOOT=flash:/c350-k9w7-mx.122-13.JA1/c350-k9w7-mx.122-13.JA1

DEFAULT_ROUTER=192.168.133.1

IP_ADDR=192.168.133.160

NETMASK=255.255.255.0

Step 10 Enter the boot command to reboot the wireless device. When the wireless device reboots, it loads the new image.

ap: boot

Good Luck

Scott

ncp-bahwanit Mon, 11/27/2006 - 07:11

Hi Scott ,

Thanks for your response .

I tried the procedures ,as given that document ,but it did not work.

I even tried pressing the mode button and connecting the Aironet to the PC using a Cross over cable and then powering it on to load the Image from the default path as shown in the document , but it is giving an error as shown in the follwoing log,

can you make out any thing from this ???

Base ethernet MAC Address: 00:18:ba:83:34:aa

Initializing ethernet port 0...

Reset ethernet port 0...

Reset done!

ethernet link up, 100 mbps, half-duplex

Ethernet port 0 initialized: link is up

button is pressed, wait for button to be released...

button pressed for 22 seconds

process_config_recovery: set IP address and config to default 10.0.0.1

process_config_recovery: image recovery

image_recovery: Download default IOS tar image tftp://255.255.255.255/c1200-k9w7

-tar.default

examining image...tftp://255.255.255.255/c1200-k9w7-tar.default: connection time

d out

ERROR: Failed to open archive file tftp://255.255.255.255/c1200-k9w7-tar.default

The system is unable to boot automatically because there

are no bootable files to boot.

I even tried downloading another copy of the IOS and tried using it .

But the error

"Failed to open archive " continues .

Has any one faced this problem earlier ??

Please help !!

Thanks & Regards,

Magesh.G

scottmac Mon, 11/27/2006 - 07:21

"Timed out" usually means that it either couldn't find the TFTP server, or the path / filename is not found.

Check the address and setup of your TFTP server, make sure the TFTP root directory is set correctly, and verifiy the filename.

Good Luck

Scott

ncp-bahwanit Mon, 11/27/2006 - 21:30

I am unable to ping the Aironet IP from the PC ,though Ethernet is showing UP and the windows task bar shows 100 Mbps and connected .

Even after changing it to default settings

i.e; IN THE AIRONET

IP_ADDRESS 10.0.0.1

NETMASK 255.255.255.0

And PC ip address to

10.0.0.29

what may be the problem ?

pls revert !!

frankzehrer Tue, 11/28/2006 - 00:53

Hi Meikanda,

Try these settings for your client:

IP: 10.0.0.5

Subnet: 255.0.0.0

Default Gateway: 10.0.0.0

In the Aironet the dfault settings should be 10.0.0.1 and 255.0.0.0 as mask.

Best regards,

Frank

tcostello Thu, 11/30/2006 - 13:15

Did you ever resolve this problem? I did the same thing (erased flash) and am having the same problems. I upgraded from vxworks to ios, then tried upgrading the ios.

patoberli Wed, 12/27/2006 - 04:54

Found the problem, had the same issue.

After setting the IP Adress and Subnetmask enter a:

ap: ether_init

That will start and initialize your network port.

After this can you further progress with the post.

eugene_zuzik Thu, 12/28/2006 - 03:55

Yep, thank you all guys, it does work. I could copy over the new IOS file.

What I have done exactly:

- renamed my image file to c1200-k9w7-tar.default;

- set correct directory with TFTP server;

- set my PC ip address as: 10.0.0.2 255.255.255.254 (check first ur AP subnet if it?s the same using ?set? command;

- Disconnect power (the power jack for external power or the Ethernet cable for in-line power) from the access point.

Press and hold the MODE button while you reconnect power to the access point.

Hold the MODE button until the status LED turns red (approximately 20 to 30 seconds), and release the MODE button. (as Cisco advices: http://www.cisco.com/en/US/products/hw/wireless/ps430/products_configuration_guide_chapter09186a00804e7d5c.html#wp1038660);

- AP picked up the image file without any problems.

P.S. I could not ping my AP from PC at all

Thank you,

Eugene

Actions

Login or Register to take actions

This Discussion

Posted November 25, 2006 at 6:19 AM
Stats:
Replies:9 Avg. Rating:
Views:2687 Votes:1
Shares:0
Tags: No tags.

Discussions Leaderboard