QoS on 3560 for Avaya phone

Unanswered Question
Nov 29th, 2006
User Badges:

I have the following QoS settings on 3560 access layer switches for Avaya phones.


mls qos map policed-dscp 0 10 18 24 25 34 to 8

mls qos map cos-dscp 0 8 16 24 34 46 48 56

mls qos srr-queue output cos-map queue 1 threshold 3 5

mls qos srr-queue output cos-map queue 2 threshold 1 2 4

mls qos srr-queue output cos-map queue 2 threshold 2 3

mls qos srr-queue output cos-map queue 2 threshold 3 6 7

mls qos srr-queue output cos-map queue 3 threshold 3 0

mls qos srr-queue output cos-map queue 4 threshold 3 1

mls qos srr-queue output dscp-map queue 1 threshold 3 46

mls qos srr-queue output dscp-map queue 2 threshold 1 16 18 20 22 25 32 34 36

mls qos srr-queue output dscp-map queue 2 threshold 1 38

mls qos srr-queue output dscp-map queue 2 threshold 2 24

mls qos srr-queue output dscp-map queue 2 threshold 3 48 56

mls qos srr-queue output dscp-map queue 3 threshold 3 0

mls qos srr-queue output dscp-map queue 4 threshold 1 8

mls qos srr-queue output dscp-map queue 4 threshold 3 10 12 14

mls qos queue-set output 1 threshold 2 70 80 100 100

mls qos queue-set output 1 threshold 4 40 100 100 100

mls qos

!

class-map match-all VOICE

match ip dscp ef

class-map match-all ANY

match access-group name ANY

class-map match-all CALL-SIGNALING

match ip dscp cs3

!

!

policy-map QOS-3560

class VOICE

set dscp ef

police 32000 8000 exceed-action drop

class CALL-SIGNALING

set dscp cs3

police 1000000 8000 exceed-action policed-dscp-transmit

class ANY

set dscp default

police 5000000 8000 exceed-action policed-dscp-transmit

!

!

interface FastEthernet0/1

description phone port

switchport access vlan 148

switchport voice vlan 200

service-policy input QOS-3560

speed 100

duplex full

spanning-tree portfast

spanning-tree bpduguard enable

!

interface GigabitEthernet0/1

description uplink port

switchport trunk encapsulation dot1q

switchport mode trunk

srr-queue bandwidth share 1 70 25 5

srr-queue bandwidth shape 3 0 0 0

priority-queue out

mls qos trust cos

!


I got some questions.

1. Would this QoS configuration work fine?

2. There will be no voice traffic until some weeks later. Would this QoS configuration affect normal data traffic?

3. Do I need "mls qos trust cos" command on the ip phone switch port? Since it's only the pc that would connect to the switch port at the moment, if someone change the cos value of the data packet, would the switch be fooled and put it in a high priority queue? How to prevent this?

4. If I'm going to disable QoS, can I just remove "mls qos" and leave all other QoS configuration intact?

Thanks in advance.


Daniel

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

Actions

This Discussion