Remote 7940 + CCM - one way audio - NAT traversal for RTP ???

Unanswered Question
Dec 3rd, 2006
User Badges:

Hi all

We tried to connect remote IP Phone 7940 to CCM4.1(3). CCM has public Ip adress and 7940 is behind NAT (DEbian machine). Phone has registered normally, call is connected, but I have only one way RTP. RTP from IPT is going well, no RTP to IPT. I think, there is a problem in NAT. Is there a way how to travers NAT for RTP? When I am using IP communicator, solution is using my public IP address in item Preferences/audio/network. How to fix this issue with HW IP phone?

Many thanks for replies

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
amit-singh Sun, 12/03/2006 - 23:53
User Badges:
  • Blue, 1500 points or more


Where are you netting the ip address. On the firewall or the router. What model's do you have.

-amit singh

amit-singh Mon, 12/04/2006 - 01:26
User Badges:
  • Blue, 1500 points or more


One way problem is usually a routing issue/problem.

To locate the problem get the following information :

1. Detailed level CCM trace for a call which has one way audio. Mention the called/calling

party number. You can configure the detailed traces from the following link :

2. Span the ethernet port of the gateway used for calls.

3. Also the sniffer trace from the WAN gateway where the IP PHone is located.

What I suspect is happening here and as the Linux server is the NAT device it will not support skinny packet inspection which will be need to change the IP in the skinny packet

from a private IP to the Public IP.

The best option will be to use VPN between the two sites and taking care to see that the both the private IP address are routable to each other over the VPN tunnel .This will

take care of any NAT issue.

Below is the link which expalins the need of skinny NAT inspection support for IP Phones.

HTH,Please rate if it does.

-amit singh


This Discussion